Imported Debian patch 1.8.2-2 debian debian/1.8.2-2
authorBalint Reczey <balint@balintreczey.hu>
Tue, 9 Oct 2012 09:39:42 +0000 (11:39 +0200)
committerMati Aharoni (Kali Linux Developer) <muts@kali.org>
Wed, 5 Dec 2012 13:05:59 +0000 (08:05 -0500)
78 files changed:
debian/README.Debian [new file with mode: 0644]
debian/README.Debian.security [new file with mode: 0644]
debian/changelog
debian/compat
debian/control
debian/copyright
debian/dirs
debian/ethereal-common.NEWS [new file with mode: 0644]
debian/libwireshark-data.files [new file with mode: 0644]
debian/libwireshark-dev.files [new file with mode: 0644]
debian/libwireshark-dev.header-files [new file with mode: 0644]
debian/libwireshark2.files [new file with mode: 0644]
debian/libwireshark2.lintian-overrides [new file with mode: 0644]
debian/libwireshark2.shlibs [new file with mode: 0644]
debian/libwiretap-dev.files [new file with mode: 0644]
debian/libwiretap-dev.header-files [new file with mode: 0644]
debian/libwiretap2.docs [new file with mode: 0644]
debian/libwiretap2.files [new file with mode: 0644]
debian/libwiretap2.shlibs [new file with mode: 0644]
debian/libwsutil-dev.files [new file with mode: 0644]
debian/libwsutil-dev.header-files [new file with mode: 0644]
debian/libwsutil2.files [new file with mode: 0644]
debian/libwsutil2.lintian-overrides [new file with mode: 0644]
debian/libwsutil2.shlibs [new file with mode: 0644]
debian/license-text-about-dialog [new file with mode: 0644]
debian/patches/01_idl2deb.patch [new file with mode: 0755]
debian/patches/02_asn2deb.patch [new file with mode: 0755]
debian/patches/03_preferences.patch [new file with mode: 0755]
debian/patches/04_asn2wrs_ply.patch [new file with mode: 0644]
debian/patches/05_note-README-when-running-as-root.patch [new file with mode: 0644]
debian/patches/06_release-version.patch [new file with mode: 0644]
debian/patches/08_wireshark-desktop-menu.patch [new file with mode: 0755]
debian/patches/09_idl2wrs.patch [new file with mode: 0755]
debian/patches/16_licence_about_location.patch [new file with mode: 0755]
debian/patches/17_fix_from_1.8.3_fix_HSRP_crash.patch [new file with mode: 0644]
debian/patches/17_fix_from_1.8.3_fix_LDP_crash.patch [new file with mode: 0644]
debian/patches/17_fix_from_1.8.3_fix_PPP_crash.patch [new file with mode: 0644]
debian/patches/17_fix_from_1.8.3_fix_infinite_loop_in_DRDA_dissector.patch [new file with mode: 0644]
debian/patches/series [new file with mode: 0644]
debian/po/POTFILES.in [new file with mode: 0644]
debian/po/cs.po [new file with mode: 0644]
debian/po/da.po [new file with mode: 0644]
debian/po/de.po [new file with mode: 0644]
debian/po/es.po [new file with mode: 0644]
debian/po/eu.po [new file with mode: 0644]
debian/po/fi.po [new file with mode: 0644]
debian/po/fr.po [new file with mode: 0644]
debian/po/hu.po [new file with mode: 0644]
debian/po/id.po [new file with mode: 0644]
debian/po/it.po [new file with mode: 0644]
debian/po/ja.po [new file with mode: 0644]
debian/po/ko.po [new file with mode: 0644]
debian/po/nl.po [new file with mode: 0644]
debian/po/pt.po [new file with mode: 0644]
debian/po/pt_BR.po [new file with mode: 0644]
debian/po/ru.po [new file with mode: 0644]
debian/po/sk.po [new file with mode: 0644]
debian/po/sv.po [new file with mode: 0644]
debian/po/templates.pot [new file with mode: 0644]
debian/po/vi.po [new file with mode: 0644]
debian/rules
debian/source/format [new file with mode: 0644]
debian/templates [new file with mode: 0644]
debian/tshark.docs [new file with mode: 0644]
debian/watch
debian/wireshark-common.config [new file with mode: 0644]
debian/wireshark-common.files
debian/wireshark-common.lintian-overrides [new file with mode: 0644]
debian/wireshark-common.manpages
debian/wireshark-common.postinst [new file with mode: 0644]
debian/wireshark-common.postrm [new file with mode: 0644]
debian/wireshark-dev.docs
debian/wireshark-dev.files
debian/wireshark-dev.manpages
debian/wireshark-dev.prerm
debian/wireshark-doc.docs [new file with mode: 0644]
debian/wireshark.docs [new file with mode: 0644]
debian/wireshark.files

diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644 (file)
index 0000000..f5b66d3
--- /dev/null
@@ -0,0 +1,75 @@
+
+I. Capturing packets with Wireshark/Tshark
+
+   There are two ways of installing Wireshark/Tshark on Debian:
+
+   I./a. Installing dumpcap without allowing non-root users to capture packets
+
+      Only root user will be able to capture packets. It is advised to capture
+      packets with the bundled dumpcap program as root and then run 
+      Wireshark/Tshark as an ordinary user to analyze the captured logs. [2]
+
+      This is the default on Debian systems.
+      
+   I./b. Installing dumpcap and allowing non-root users to capture packets
+
+      Members of the wireshark group will be able to capture packets on network 
+      interfaces. This is the preferred way of installation if Wireshark/Tshark
+      will be used for capturing and displaying packets at the same time, since
+      that way only the dumpcap process has to be run with elevated privileges 
+      thanks to the privilege separation[1].
+
+      Note that no user will be added to group wireshark automatically, the 
+      system administrator has to add them manually.
+
+      The additional privileges are provided using the Linux Capabilities
+      system where it is available and resort to setting the set-user-id bit 
+      of the dumpcap binary as a fall-back, where the Linux Capabilities system
+      is not present (Debian GNU/kFreeBSD, Debian GNU/Hurd).
+
+      Linux kernels provided by Debian support Linux Capabilities, but custom
+      built kernels may lack this support. If the support for Linux
+      Capabilities is not present at the time of installing wireshark-common
+      package, the installer will fall back to set the set-user-id bit to
+      allow non-root users to capture packets.
+
+      If installation succeeds with using Linux Capabilities, non-root users
+      will not be able to capture packets while running kernels not supporting
+      Linux Capabilities.
+
+      Note that capturing USB packets is not enabled for non-root users by using
+      Linux Capabilities. You have to capture the packets using the method
+      described in I./a., setting the set-user-id permanently using
+      dpkg-statoverride or running Wireshark as root.
+
+   The installation method can be changed any time by running:
+   dpkg-reconfigure wireshark-common
+
+
+II. Installing SNMP MIBs
+
+    SNMP [4] OIDs can be decoded using MIBs provided by other packages.
+    wireshark-common suggests snmp-mibs-downloader which package can be used to
+    download a set of common MIBs Wireshark/Tshark tries to load at startup.
+
+    At the time of writing, MIBs are distributed under DFSG incompatible terms
+    [5] thus snmp-mibs-downloader has to be in the non-free archive area.
+    To keep wireshark in the main area [7], wireshark-common does not depend on
+    or recommend snmp-mibs-downloader and as a result snmp-mibs-downloader is
+    not installed automatically with wireshark.
+
+    To make Wireshark/Tshark able to decode OIDs, please install
+    snmp-mibs-downloader manually.
+
+    To help Wireshark/Tshark to decode OIDs without having to install packages
+    manually, please support the initiative of requesting additional rights
+    from RFC authors [5].
+
+
+   [1] http://wiki.wireshark.org/Development/PrivilegeSeparation
+   [2] http://wiki.wireshark.org/CaptureSetup/CapturePrivileges
+   [3] https://blog.wireshark.org/2010/02/running-wireshark-as-you
+   [4] http://wiki.wireshark.org/SNMP
+   [5] http://wiki.debian.org/NonFreeIETFDocuments
+   [6] http://www.debian.org/doc/debian-policy/ch-archive.html#s-non-free
+   [7] http://www.debian.org/doc/debian-policy/ch-archive.html#s-main
diff --git a/debian/README.Debian.security b/debian/README.Debian.security
new file mode 100644 (file)
index 0000000..f8795b4
--- /dev/null
@@ -0,0 +1,14 @@
+
+ Handling security fixes in source package wireshark
+
+Wireshark is a network protocol analyzer and it's ability to perform deep 
+packet inspection in live traffic may encourage users to use Wireshark/Tshark
+as a part of an intrusion detection or traffic monitoring system.
+In that case, please note that Wireshark/Tshark may contain remotely 
+triggerable bugs causing crashes or allowing code injection.
+
+Bugs allowing code injection will be fixed in regular Debian Security 
+Advisories, but fixes for pure crash bugs may be delayed.
+
+ -- Balint Reczey <balint@balintreczey.hu> Fri, 10 Jul 2009 15:38:33 +0200
+
index bfc73ca..d512e9b 100644 (file)
-wireshark (1.8.2) unstable; urgency=low
+wireshark (1.8.2-2) unstable; urgency=high
 
-  * Self-made package
+  * security fixes from Wireshark 1.8.3 (Closes: #689972):
+    - The HSRP dissector could go into an infinite loop (CVE-2012-5237)
+    - The PPP dissector could abort (CVE-2012-5238)
+    - Martin Wilck discovered an infinite loop in the DRDA dissector
+      (CVE-2012-5239)
+    - Laurent Butti discovered a buffer overflow in the LDP dissector
+      (CVE-2012-5240)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 09 Oct 2012 11:39:42 +0200
+
+wireshark (1.8.2-1) unstable; urgency=high
+
+  * New upstream release 1.8.2 (skipping 1.8.1 in Debian)
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.8.2.html
+    - security fixes:
+      - The PPP dissector could crash (Closes: #680056)(CVE-2012-4048)
+      - The NFS dissector could use excessive amounts of CPU (CVE-2012-4049)
+      - The DCP ETSI dissector could trigger a zero division. Reported by
+         Laurent Butti. (CVE-2012-4285)
+      - The MongoDB dissector could go into a large loop. Reported by
+        Ben Schmidt. (CVE-2012-4287)
+      - The XTP dissector could go into an infinite loop. Reported by
+        Ben Schmidt. (CVE-2012-4288)
+      - The ERF dissector could overflow a buffer. Reported by
+        Laurent Butti. (CVE-2012-4294 CVE-2012-4295)
+      - The AFP dissector could go into a large loop. Reported by
+        Stefan Cornelius. (CVE-2012-4289)
+      - The RTPS2 dissector could overflow a buffer. Reported by
+        Laurent Butti. (CVE-2012-4296)
+      - The GSM RLC MAC dissector could overflow a buffer. Reported by
+        Laurent Butti. (CVE-2012-4297)
+      - The CIP dissector could exhaust system memory. Reported by
+        Ben Schmidt. (CVE-2012-4291)
+      - The STUN dissector could crash. Reported by Laurent Butti.
+        (CVE-2012-4292)
+      - The EtherCAT Mailbox dissector could abort. Reported by
+        Laurent Butti. (CVE-2012-4293)
+      - The CTDB dissector could go into a large loop. Reported by
+        Ben Schmidt. (CVE-2012-4290)
+      - The pcap-ng file parser could trigger a zero division (CVE-2012-4286)
+      - The Ixia IxVeriWave file parser could overflow a buffer
+        (CVE-2012-4298)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sun, 19 Aug 2012 14:30:56 +0200
+
+wireshark (1.8.0-1) unstable; urgency=low
+
+  * New upstream release 1.8.0 (Closes: #678585)
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.8.0.html
+  * fix lintian pedantic mode warnings
+    - use set -e in maintainer scripts
+    - refer to GPLv2 via symlink
+    - fix spacing in debian/control
+    - depend on debhelper (>= 9)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 22 Jun 2012 19:25:19 +0200
+
+wireshark (1.8.0~rc1-1) unstable; urgency=low
+
+  * New upstream release 1.8.0 release candidate 1
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.8.0.html
+    - drop 07_use-theme-icon.patch as it has been integrated upstream
+    - bump library versions to 2.0.0 and rename library packages to
+      libwsutil2, libwiretap2 and libwireshark2
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 07 Jun 2012 01:04:16 +0200
+
+wireshark (1.6.8-1) unstable; urgency=medium
+
+  * New upstream release 1.6.8
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.8.html
+    - security fixes:
+      - Infinite and large loops in the ANSI MAP, ASF, BACapp, Bluetooth
+        HCI, IEEE 802.11, IEEE 802.3, LTP, and R3 dissectors have been
+        fixed (No assigned CVE number)
+      - The DIAMETER dissector could try to allocate memory improperly
+        and crash (No assigned CVE number)
+      - Wireshark could crash on SPARC processors due to misaligned
+        memory. Discovered by Klaus Heckelmann (No assigned CVE number)
+    - NEWS file is empty, stop shipping it in Debian package
+  * update standards-version to 3.9.3
+  * use dpkg-buildflags for hardening
+  * depend on dpkg-dev (>= 1.16.1~) for dpkg-buildflags
+  * bump debhelper compatibility level to v9
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 22 May 2012 23:50:21 +0200
+
+wireshark (1.6.7-1) unstable; urgency=low
+
+  * New upstream release 1.6.7
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.7.html
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 11 Apr 2012 15:41:17 +0200
+
+wireshark (1.6.6-1) unstable; urgency=high
+
+  * New upstream release 1.6.6
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.6.html
+    - security fixes (Closes: #666058):
+      - The ANSI A dissector could dereference a NULL pointer and crash
+      - The IEEE 802.11 dissector could go into an infinite loop
+      - The pcap and pcap-ng file parsers could crash trying to read ERF data
+      - The MP2T dissector could try to allocate too much memory and crash
+  * depend on automake instead of automake1.9
+  * update watch file to watch bzip2 compressed archives
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 28 Mar 2012 12:34:10 +0200
+
+wireshark (1.6.5-2) unstable; urgency=low
+
+  * clarify when set-user-id bit is set for dumpcap in README.Debian
+    (Closes: #649350)
+  * add notes about capturing USB frames to README.Debian
+  * package and use SVG icon for Wireshark (Closes: #661759)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sun, 15 Jan 2012 11:16:10 -0800
+
+wireshark (1.6.5-1) unstable; urgency=high
+
+  * New upstream release 1.6.5
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.5.html
+    - security fixes:
+      - Laurent Butti discovered that Wireshark failed to properly check
+        record sizes for many packet capture file formats.
+        (No assigned CVE number.)
+      - Wireshark could dereference a NULL pointer and crash.
+        (No assigned CVE number.)
+      - The RLC dissector could overflow a buffer.
+        (No assigned CVE number.)
+  * build architecture dependent and independent packages separately
+  * [Debconf translation updates]
+    - Indonesian (Mahyuddin Susanto). (Closes: #653938)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 12 Jan 2012 12:53:09 +0100
+
+wireshark (1.6.4-1) unstable; urgency=low
+
+  * New upstream release 1.6.4
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.4.html
+  * remove Joost Yervante Damad from uploaders as he has resigned
+    Thank you Joost for taking care of Wireshark packages for many years!
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sat, 19 Nov 2011 11:21:58 +0100
+
+wireshark (1.6.3-1) unstable; urgency=high
+
+  * New upstream release 1.6.3
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.3.html
+    - security fixes:
+      - The CSN.1 dissector could crash
+        (No assigned CVE number.)
+      - Huzaifa Sidhpurwala of Red Hat Security Response Team discovered
+        that the Infiniband dissector could dereference a NULL pointer.
+        (No assigned CVE number.)
+      - Huzaifa Sidhpurwala of Red Hat Security Response Team discovered a
+        buffer overflow in the ERF file reader. (No assigned CVE number.)
+    -  bump library versions
+  * add build-arch and build-indep targets to debian/rules
+  * [Debconf translation updates]
+    - Slovak (Slavko). (Closes: #647082)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 01 Nov 2011 21:04:31 +0100
+
+wireshark (1.6.2-1) unstable; urgency=high
+
+  * New upstream release 1.6.2
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.2.html
+    - security fixes
+      - A large loop in the OpenSafety dissector could cause a crash.
+        (CVE-2011-3484)
+      - A malformed IKE packet could consume excessive resources.
+        (CVE-2011-3266)
+      - A malformed capture file could result in an invalid root tvbuff and
+        cause a crash. (CVE-2011-3483 )
+      - Wireshark could run arbitrary Lua scripts. (CVE-2011-3360)
+      - The CSN.1 dissector could crash. (CVE-2011-3482)
+    - don't show subversion revision in window title (Closes: #635116)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sun, 18 Sep 2011 04:10:15 -1000
+
+wireshark (1.6.1-1) unstable; urgency=high
+
+  * New upstream release 1.6.1
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.1.html
+    - security fixes
+       - The Lucent/Ascend file parser was susceptible to an infinite loop
+         (CVE-2011-2597)
+       - The ANSI MAP dissector was susceptible to an infinite loop
+         (No assigned CVE number.)
+  * use linux-any wildcard for architecture-specific dependencies
+    (Closes: #634671)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 19 Jul 2011 14:52:12 +0200
+
+wireshark (1.6.0-2) unstable; urgency=low
+
+  * [Debconf translation updates]
+    - Korean (si-cheol KO). (Closes: #630951)
+  * show a hint to read README.Debian when showing the warning about
+    running Wireshark as root
+    Thanks to Evan Huus for the suggestion.
+  * don't ship .la files for plugins, it keeps lintian happy
+  * migrate to dh_python2 from dh_pysupport
+  * use dh_prep instead of obsoleted dh_clean -k in debian/rules
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sun, 10 Jul 2011 00:28:09 +0200
+
+wireshark (1.6.0-1) unstable; urgency=low
+
+  * New upstream release 1.6.0
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.6.0.html
+    - Decode protocols selectively using tshark -O (Closes: #179309)
+    - Support opening files larger than 2GB on all platforms
+      (Closes: #539287)
+    - Bump library versions (Closes: #627146)
+  * depend on omniidl instead of omniidl4 transitional package
+  * [Debconf translation updates]
+    - Dutch (Jeroen Schot). (Closes: #626145)
+    - Hungarian (Balint Reczey).
+  * start shipping libwireshark2, libwiretap2 and libwsutil2 instead of
+    libwireshark0, libwiretap0 and libwsutil0, respectively
+  * drop 05_bump_so_versions.patch as upstream started library versioning
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 07 Jun 2011 21:29:16 +0200
+
+wireshark (1.5.1-1) experimental; urgency=low
+
+  * New upstream development release 1.5.1
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.5.1.html
+  * update standards-version to 3.9.2
+  * clarify in README.Debian that only root is able to capture packets in
+    default installation (Closes: #621801)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 07 Apr 2011 19:27:08 +0200
+
+wireshark (1.5.0-1) experimental; urgency=low
+
+  * New upstream development release 1.5.0
+    - release notes:
+      http://www.wireshark.org/news/20110124.html
+    - Allow <interval> to be successfully sscanf'd no matter the locale
+      for the decimal symbol (Closes: #454621)
+    - Use more meaningful temp file name (Closes: #419710)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 08 Feb 2011 14:30:12 +0100
+
+wireshark (1.4.3-2) unstable; urgency=low
+
+  * re-upload to unstable
+
+ -- Balint Reczey <balint@balintreczey.hu>  Mon, 07 Feb 2011 14:34:06 +0100
+
+wireshark (1.4.3-1) experimental; urgency=high
+
+  * New upstream release 1.4.3
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.4.3.html
+    - security fixes
+       - FRAsse discovered that the MAC-LTE dissector could overflow a buffer.
+         (No assigned CVE number.)
+       - FRAsse discovered that the ENTTEC dissector could overflow a buffer.
+         (CVE-2010-4538) (Closes: #608990)
+       - The ASN.1 BER dissector could assert and make Wireshark exit
+         prematurely. (No assigned CVE number.)
+  * drop 25_libwsutil-version.patch since it has been integrated upstream
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 12 Jan 2011 15:31:35 +0100
+
+wireshark (1.4.2-3) experimental; urgency=low
+
+  [ W. Borgert ]
+  * support IDL's #include in idl2deb (Closes: #314833)
+  
+  [ Balint Reczey ]
+  * really ship include files in libwsutil-dev
+  * raise Python 2.6 compatible exceptions (Closes: #585370)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 24 Dec 2010 00:00:11 +0100
+
+wireshark (1.4.2-2) experimental; urgency=low
+
+  * separated libwsutil and related headers in libwsutil0 and
+    libwsutil-dev packages
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 25 Nov 2010 23:26:09 +0100
+
+wireshark (1.4.2-1) experimental; urgency=low
+
+  * New upstream release 1.4.2
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.4.2.html
+    - security fixes
+       - Nephi Johnson of BreakingPoint discovered that the LDSS dissector
+         could overflow a buffer. (No assigned CVE number.)
+       - The ZigBee ZCL dissector could go into an infinite loop.
+         (No assigned CVE number.)
+  * drop 05_fix-display-filter-update-when-changing-profile.patch
+    patch since it has been integrated upstream
+
+ -- Balint Reczey <balint@balintreczey.hu>  Sat, 20 Nov 2010 18:41:41 +0100
+
+wireshark (1.4.1-1) experimental; urgency=high
+
+  * New upstream release 1.4.1
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.4.1.html
+    - add support for sll.ltype hooks (Closes: #594390)
+    - security fixes
+       - The Penetration Test Team of NCNIPC (China) discovered that the
+         ASN.1 BER dissector was susceptible to a stack overflow
+         (CVE-2010-3445)
+  * pick fix for improperly backported display filter update when changing
+    profile
+  * [Debconf translation updates]
+    - Basque (Iñaki Larrañaga Murgoitio).
+    - Vietnamese (Clytie Siddall). (Closes: #598498)
+  * make wireshark-dev depend on libwireshark-dev and libwiretap-dev
+    (Closes: #596108)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 03 Sep 2010 13:20:33 +0200
+
+wireshark (1.4.0-1) experimental; urgency=low
+
+  [ Balint Reczey ]
+  * New upstream release 1.4.0
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.4.0.html
+  * drop 26_offline-documentation.patch patch since it has been integrated
+    upstream
+  * [Debconf translation updates]
+    - French (Simon Paillard). (Closes: #593214)
+    - Danish (Joe Hansen). (Closes: #594738)
+    - Brazilian Portuguese (Adriano Rafael Gomes). (Closes: #594780)
+    - Basque (Iñaki Larrañaga Murgoitio).
+  * changed versioned conflicts to conflict with << 1.4.0~rc2-1 versions
+    instead of conflicting with <= 1.2.7-1 ones to allow smooth upgrades
+    from versions between 1.2.7-1 and 1.4.0~rc2-1 (Closes: #593875)
+  * debian/control: updated policy to 3.9.1 (Eloy Paris removed the .la
+    files to become compliant)
+
+  [ Eloy Paris ]
+  * Removed /usr/lib/libwiretap.la from the libwiretap-dev package and
+    /usr/lib/libwireshark.la and /usr/lib/libwsutil.la from the
+    libwireshark-dev package since external programs linking against
+    libwiretap and libwireshark do not need them. Refer to the Debian
+    Policy Manual 10.2 ("Libraries") for further information.
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 01 Sep 2010 23:52:27 +0200
+
+wireshark (1.4.0~rc2-2) experimental; urgency=low
+
+  * New wireshark-doc package for shipping offline documentation
+    (Closes: #68746)
+  * make libwireshark0-data suggest snmp-mibs-downloader instead of
+    wireshark-common
+  * [Debconf translation updates]
+    - Japanese (Hideki Yamane (Debian-JP)).  (Closes: #591563)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 30 Jul 2010 16:34:05 +0200
+
+wireshark (1.4.0~rc2-1) experimental; urgency=low
+
+  [ Eloy Paris ]
+  * New upstream release.
+    - Make tshark list interfaces for non-root user (Closes: #582298)
+    - Fix duplicate inconsistent attributes in RADIUS dictionary.
+      (Closes: #570132)
+  * New libwireshark0, libwireshark-dev, libwiretap0, libwiretap-dev
+    packages that reorganize libraries, header files, etc. as follows:
+    - Moved libwireshark.so.* from package wireshark-common to package
+      libwireshark0.
+    - Moved libwsutil.so.* from package wireshark-common to package
+      libwireshark0.
+    - Moved libwiretap.so.* from package wireshark-common to package
+      libwiretap0.
+    - Moved header files, .so symlinks, and static libraries from package
+      wireshark-dev to libwireshark-dev and libwiretap-dev, depending on
+      the case.
+    - Moved plugins in /usr/lib/wireshark/ from package wireshark-common
+      to package libwireshark0.
+    This provides more package granularity and allows easier use of
+    libraries provided by the Wireshark project by applications that
+    are not maintained by the Wireshark project (package kismet currently
+    appears to use services offered by libwiretap, and upcoming package
+    netexpect will use libwireshark services [see ITP bug #587056]).
+  * Dropped 23_lintian-overrides.patch since we no longer have binaries
+    with RPATHs because after the library separation work mentioned above
+    our libraries are in /usr/lib and not in /usr/lib/wireshark, eliminating
+    the need for RPATHs. Also tweaked debian/rules, debian/tshark.files,
+    and debian/wireshark-common.files so the lintian overrides
+    are not installed.
+  * Dropped the following patches since they have been integrated
+    upstream:
+    - 05_libsnmp_path.patch
+    - 07_mib_tip.patch
+    - 11_disable_oid_resolution_by_default.patch
+    - 12_fix_about_crash.patch
+    - 21_dumpcap.patch
+
+  [ Balint Reczey ]
+  * Dropped the following patches since they have been integrated
+    upstream:
+    - 10_prevent_libsmi_crash.patch
+    - 04_asn2wrs_ply.patch
+    - 06_giop-buffer.patch
+  * moved platform independent files needed by libwireshark0 to 
+    new libwireshark0-data package from wireshark-common
+  * New upstream release 1.4.0~rc2
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 30 Jul 2010 15:27:21 +0200
+
+wireshark (1.2.10-1) unstable; urgency=high
+
+  * New upstream release 1.2.10
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.10.html
+    - security fixes
+       - The SigComp Universal Decompressor Virtual Machine could overrun a
+         buffer. (CVE-2010-2287)
+       - Due to a regression the ASN.1 BER dissector could exhaust stack
+         memory. (CVE-2010-2284)
+       - The GSM A RR dissector could crash. (No assigned CVE number.)
+       - The IPMI dissector could go into an infinite loop.
+         (No assigned CVE number.)
+  * [Debconf translation updates]
+    - German (Helge Kreutzmann). (Closes: #590484)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 30 Jul 2010 08:30:02 +0200
+
+wireshark (1.2.9-2) unstable; urgency=low
+
+  * ship README.Debian with wireshark and tshark packages in addition to
+    shipping it with wireshark-common
+  * Debconf template update to refer to README.Debian instead of going into
+    technical details
+  * [Debconf translation updates]
+    - German (Helge Kreutzmann). (Closes: #587559, #587560)
+    - Portuguese (Pedro Ribeiro). (Closes: #587213)
+    - Swedish (Martin Ågren).
+    - Italian (Luca Monducci).
+    - Czech (Martin Sin). (Closes: #586556)
+    - Russian (Yuri Kozlov). (Closes: #586580)
+    - Spanish (Francisco Javier Cuadrado). (Closes: #588809)
+  * debian/control: updated policy to 3.9.0 (no changes needed)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 21 Jul 2010 00:33:00 +0200
+
+wireshark (1.2.9-1) unstable; urgency=high
+
+  * New upstream release 1.2.9
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.9.html
+    - security fixes
+       - The SMB dissector could dereference a NULL pointer.
+         (No assigned CVE number.)
+       - J. Oquendo discovered that the ASN.1 BER dissector could overrun
+         the stack. (No assigned CVE number.)
+       - The SMB PIPE dissector could dereference a NULL pointer on some
+         platforms. (No assigned CVE number.)
+       - The SigComp Universal Decompressor Virtual Machine could go into
+         an infinite loop. (No assigned CVE number.)
+       - The SigComp Universal Decompressor Virtual Machine could overrun a
+         buffer. (No assigned CVE number.)
+  * drop sensitive open patch as it has been integrated upstream
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 10 Jun 2010 21:44:58 +0200
+
+wireshark (1.2.8-1) unstable; urgency=low
+  * New upstream release 1.2.8
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.8.html
+    - Fix crash when double-clicking on empty packet list (Closes: #576097)
+    - security fixes
+       - The DOCSIS dissector could crash. (No assigned CVE number.)
+  [ Hilko Bengen ]
+  * provide debug symbols in wireshark-dbg package (Closes: #574284)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 06 May 2010 17:26:54 +0200
+
+wireshark (1.2.7-1) unstable; urgency=low
+  * New upstream release 1.2.7
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.7.html
+  * fix purging wireshark-common when removing wireshark system group fails
+  * fix crash when opening About box with disabled OID resolution
+    (Closes: #574086)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 01 Apr 2010 11:11:37 +0100
+
+wireshark (1.2.6-5) unstable; urgency=low
+
+  * disable OID resolution in default configuration (Closes: #568050)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 02 Mar 2010 19:38:07 +0100
+
+wireshark (1.2.6-4) unstable; urgency=low
+
+  * fix spelling of 'privileges' in README.Debian (Closes: #571258)
+  * prevent crash in libsmi (Closes: #567799)
+  * describe problem with MIBs in README.Debian
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 17 Feb 2010 15:36:53 +0100
+
+wireshark (1.2.6-3) unstable; urgency=low
+
+  * falling back to setting set-user-id bit if using Linux Capabilities fails
+    (Closes: #570193)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 17 Feb 2010 11:29:56 +0100
+
+wireshark (1.2.6-2) unstable; urgency=low
+
+  * build-depend on new libcap-dev instead of libcap2-dev if libcap2 is not
+    available (Closes: #568083)
+  * update standards-version to 3.8.4
+  * drop dpatch patch system
+  * use Linux Capabilities for allowing dumpcap to capture packets instead of
+    set-user-id bit where possible
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 02 Feb 2010 16:34:59 +0100
+
+wireshark (1.2.6-1) unstable; urgency=high
+
+  * New upstream release 1.2.6
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.6.html
+    - security fixes
+       - Babi discovered several buffer overflows in the LWRES dissector.
+         (No assigned CVE number.)
+    (Closes: #565744)
+  * [Debconf translation updates]
+    - Brazilian Portuguese (Rafael Henrique da Silva Correia).
+      (Closes: #565306)
+  * remove dependency on libsnmp-base
+  * suggest snmp-mibs-downloader instead of libsmi2-common
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 15 Jan 2010 21:51:34 +0100
+
+wireshark (1.2.5-1) unstable; urgency=high
+
+  * New upstream release 1.2.5
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.5.html
+    - security fixes
+       - The Daintree SNA file parser could overflow a buffer. 
+         (No assigned CVE number.)
+       - The SMB and SMB2 dissectors could crash. (No assigned CVE number.)
+       - The IPMI dissector could crash on Windows. (No assigned CVE number.)
+  * fix FTBS because of missing idl2deb.dbk (Closes: #560553)
+  * suggest solutions on missing MIBs popup (Closes: #560727)
+  * restrict watch check to stable versions
+  * change source package format to 3.0 (quilt)
+  * new maintainer is Balint Reczey
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 11 Dec 2009 16:29:01 +0100
+
+wireshark (1.2.4-3) unstable; urgency=low
+
+  * depend on libsnmp-base instead of libsmi2-common (Closes: #557626)
+  * libsmi2-common is just suggested by wireshark-common from now
+  * build-depend on python-ply
+
+ -- Balint Reczey <balint@balintreczey.hu>  Mon, 23 Nov 2009 10:38:21 +0100
+
+wireshark (1.2.4-2) unstable; urgency=low
+
+  [ Jakub Wilk ]
+  * import lex from ply in asn2wrs (Closes: #554613)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Thu, 19 Nov 2009 23:29:24 +0100
+
+wireshark (1.2.4-1) unstable; urgency=low
+
+  * New upstream release 1.2.4
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.4.html
+  [ Jakub Wilk ]
+  * make wireshark-dev depend on python-ply to fix asn2wrs (Closes: #554613)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 17 Nov 2009 15:11:10 +0100
+
+wireshark (1.2.3-1) unstable; urgency=high
+
+  * New upstream release 1.2.3
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.3.html
+    - security fixes
+       - The Paltalk dissector could crash on alignment-sensitive processors.
+         (CVE-2009-3549)
+       - The DCERPC/NT dissector could crash. (CVE-2009-3550)
+       - The SMB dissector could crash. (CVE-2009-3551)
+    (Closes: #553583)
+  [ Eloy Paris ]
+  * added missing libraries and header files to wireshark-dev (Closes: #552025)
+
+ -- Balint Reczey <balint@balintreczey.hu>  Wed, 28 Oct 2009 14:35:20 +0100
+
+wireshark (1.2.2-2) unstable; urgency=low
+
+  * Debconf templates and debian/control reviewed by the debian-l10n-
+    english team as part of the Smith review project. Closes: #547130
+  * [Debconf translation updates]
+    - German (Helge Kreutzmann).  Closes: #547229
+    - Basque (Piarres Beobide).  Closes: #547268
+    - Portuguese (Pedro Ribeiro).  Closes: #547381
+    - Swedish (Martin Ågren).  Closes: #547383
+    - Vietnamese (Clytie Siddall).  Closes: #547800
+    - French (Simon Paillard).  Closes: #548340
+    - Italian (Luca Monducci).  Closes: #548605
+    - Japanese (Hideki Yamane (Debian-JP)).  Closes: #548655
+    - Spanish (Francisco Javier Cuadrado).  Closes: #548700
+    - Czech (Martin Sin).  Closes: #548728
+    - Russian (Yuri Kozlov).  Closes: #549086
+    - Finnish (Esko Arajärvi).  Closes: #549609
+
+ -- Christian Perrier <bubulle@debian.org>  Thu, 17 Sep 2009 14:06:52 +0200
+
+wireshark (1.2.2-1) unstable; urgency=high
+
+  * New upstream release 1.2.2
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.2.html
+    - security fixes
+       - The GSM A RR dissector could crash. (CVE-2009-3242)
+       - The OpcUa dissector could use excessive CPU and memory. (CVE-2009-3241)
+       - The TLS dissector could crash on some platforms.
+    (Closes: #547704)
+  * dropped sigpipe patch as it has been integrated upstream
+  * debian/{control,rules}: add and enable hardened build for PIE
+    Thanks to Kees Cook <kees@ubuntu.com> for the patch. (Closes: #542736)
+  * update standards-version to 3.8.3
+  * applied dumpcap patch that was added to source package in 1.0.7-1 
+    but was not applied during build
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 28 Aug 2009 00:44:22 +0200
+
+wireshark (1.2.1-2) unstable; urgency=low
+
+  * added option to install dumpcap with setuid root
+  * removed wireshark-root.desktop to discourage running Wireshark as root
+  * dropped umask patch
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 28 Jul 2009 18:30:03 +0200
+
+wireshark (1.2.1-1) unstable; urgency=high
+
+  * New upstream release 1.2.1
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.1.html
+    - security fixes
+       - The IPMI dissector could overrun a buffer. (CVE-2009-2559)
+       - The AFS dissector could crash. (CVE-2009-2562)
+       - The Infiniband dissector could crash on some platforms. (CVE-2009-2563)
+       - The Bluetooth L2CAP dissector could crash. (CVE-2009-2560)
+       - The RADIUS dissector could crash. (CVE-2009-2560)
+       - The MIOP dissector could crash. (CVE-2009-2560)
+       - The sFlow dissector could use excessive CPU and memory. (CVE-2009-2561)
+    (Closes: #538237)
+  * dropped gnutls pkg-config patch as it has been integrated upstream
+  * include asn2wrs.py (Closes: #518441)
+  * fix inclusion of Python modules wireshark_be.py and wireshark_gen.py
+  * updated idl2deb (Closes: #470316)
+     Thanks to W. Borgert for the patch.
+  * override lintian warning binary-or-shlib-defines-rpath
+  * update standards-version to 3.8.2
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 14 Jul 2009 20:01:56 +0200
+
+wireshark (1.2.0-1) unstable; urgency=low
+
+  * New upstream release 1.2.0
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.2.0.html
+    (Closes: #487613, #520884, #482545, #376405, #512298)
+  * use c-ares instead of adns (Closes: #427928, #411265)
+  * depend on libgeoip1 to make use of brand new GeoIP support in 1.2.0 
+  * added description for 09_idl2wrs.dpatch
+  * recommend menu instead of gksu (Closes: #524360)
+  * dropped Clique RM dissector patch as it is still not integrated upstream
+  * depend on libsmi2-common
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 30 Jun 2009 20:48:16 -0700
+
+wireshark (1.0.8-2) unstable; urgency=low
+
+  * detect gnutls using pkg-config (Closes: #529913)
+     Thanks to Andreas Metzler for the patch.
+  * depend on libsmi2-dev (Closes: #490429)
+  * updated sigpipe patch to match upstream's latest solution
+
+ -- Balint Reczey <balint@balintreczey.hu>  Tue, 30 Jun 2009 12:55:39 -0700
+
+wireshark (1.0.8-1) unstable; urgency=low
+
+  * New upstream release 1.0.8
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.0.8.html
+    - security fixes:
+       - The PCNFSD dissector could crash.(No assigned CVE number.)
+  * add README.source (Closes: #524364)
+  * removed wireshark-dev's dependency on removed omniidl package
+
+ -- Balint Reczey <balint@balintreczey.hu>  Fri, 26 Jun 2009 20:31:26 -0700
+
+wireshark (1.0.7-1) unstable; urgency=low
+
+  * New upstream release 1.0.7
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.0.7.html
+    - security fixes:
+      - The PROFINET dissector was vulnerable to a format string
+        overflow. (CVE-2009-1210)
+      - The LDAP dissector could crash on Windows. (CVE-2009-1267)
+      - The Check Point High-Availability Protocol (CPHAP) dissector
+        could crash. (CVE-2009-1268)
+      - Wireshark could crash while loading a Tektronix .rf5 file
+        (CVE-2009-1269)
+  * update standards-version to 3.8.1
+  * add 21_dumpcap.dpatch with patch from Rob Leslie <rob@mars.org>
+    that should avoid dumpcap seeing stop on CTRL-C as an error
+    (Closes: #518435)
+
+ -- Joost Yervante Damad <andete@debian.org>  Sat, 11 Apr 2009 10:06:45 +0200
+
+wireshark (1.0.6-1) unstable; urgency=low
+
+  * new upstream release 1.0.6
+    - release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-1.0.6.html
+    - security fixes:
+      - On non-Windows systems, Wireshark could crash if the HOME
+        environment variable contained sprintf-style string
+        formatting characters
+      - Wireshark could crash while reading a malformed NetScreen
+        snoop file
+      - Wireshark could crash while reading a Tektronix K12 text
+        capture file
+  * add 20_sigpipe patch from ubuntu, which restores the default
+    sigpipe action, meaning that the app won't hang under gksu
+    (Closes: #478169)
+
+ -- Joost Yervante Damad <andete@debian.org>  Sat, 07 Feb 2009 15:35:10 +0100
+
+wireshark (1.0.5-1) unstable; urgency=low
+
+  * New upstream release 1.0.5
+    - release notes:
+     http://www.wireshark.org/docs/relnotes/wireshark-1.0.5.html
+    - security fixes:
+      - The SMTP dissector could consume excessive amounts of CPU and memory
+      - The WLCCP dissector could go into an infinte loop
+
+ -- Joost Yervante Damad <andete@debian.org>  Sat, 13 Dec 2008 14:31:33 +0100
+
+wireshark (1.0.4-1) unstable; urgency=low
+
+  * New upstream release 1.0.4
+    - release notes:
+     http://www.wireshark.org/docs/relnotes/wireshark-1.0.4.html
+    - security fixes:
+      - Bluetooth ACL dissector could crash or abort
+      - The Q.931 dissector could crash or abort
+      - Wireshark could abort while reading Tamos CommView
+        capture files
+      - the USB dissector could crash, also BT RFCOMM
+      - PRP and MATE dissectors could make Wireshark crash
+    - CVE-2008-4680, CVE-2008-4681, CVE-2008-4682, CVE-2008-4683,
+      CVE-2008-4684, CVE-2008-4685
+  * disable clique_rm support patch (if you're interested in this
+    dissector please get it accepted by upstream)
+  * add description to some patches
+
+ -- Joost Yervante Damad <andete@debian.org>  Fri, 05 Dec 2008 10:35:47 +0100
+
+wireshark (1.0.3-1) unstable; urgency=high
+
+  * New upstream release 1.0.3 (Closes: #497878)
+    - release notes:
+     http://www.wireshark.org/docs/relnotes/wireshark-1.0.3.html
+    - security fixes:
+      - The NCP dissector was susceptible to a number of problems,
+        including buffer overflows and an infinite loop
+        (CVE-2008-3146, CVE-2008-3932)
+      - Wireshark could crash while uncompressing zlib-compressed
+        packet data (CVE-2008-3933)
+      - Wireshark could crash while reading a Tektronix .rf5 file
+        (CVE-2008-3934)
+    - other fixes:
+      - Following a TCP stream could incorrectly reassemble packets
+        (Closes: #496768)
+
+ -- Joost Yervante Damad <andete@debian.org>  Fri, 12 Sep 2008 15:05:58 +0200
+
+wireshark (1.0.2-3) unstable; urgency=low
+
+  * remove build-dependency on libsmi-dev; libsmi
+    seems to be in bad shape in Debian; don't want
+    to be dependent on it this close to the release
+
+ -- Joost Yervante Damad <andete@debian.org>  Tue, 22 Jul 2008 19:15:23 +0200
+
+wireshark (1.0.2-2) unstable; urgency=low
+
+  * switch to libcap2 (Closes: #489310)
+  * include rawshark in common (Closes: #490436)
+  * include dumpcap manpage (Closes: #490434)
+  * build-depend on libsmi-dev (Closes: #490429)
+  * switch to standards-version 3.8.0.1
+
+ -- Joost Yervante Damad <andete@debian.org>  Sun, 20 Jul 2008 18:34:25 +0200
+
+wireshark (1.0.2-1) unstable; urgency=high
+
+  * New upstream release 1.0.2
+    - release notes:
+     http://www.wireshark.org/docs/relnotes/wireshark-1.0.2.html
+    - security fixes:
+      - Wireshark could crash while reassembling packets
+        (CVE-2008-3145)
+
+ -- Joost Yervante Damad <andete@debian.org>  Fri, 11 Jul 2008 13:48:49 +0200
+
+wireshark (1.0.1-1) unstable; urgency=high
+
+  [ Frederic Peters ]
+  * debian/patches/20_set_foreground.dpatch: set black text for packet detail
+    rows that are set to a light gray background.  (closes: #478769)
+  * debian/control: updated Conflicts and Replaces to 1.0.0-3, so upgrades
+    from more versions are possible.
+
+  [ Joost Yervante Damad ]
+  * New upstream release 1.0.1
+    - release notes:
+     http://www.wireshark.org/docs/relnotes/wireshark-1.0.1.html
+    -  security fixes:
+      - The PANA and KISMET dissectors could force Wireshark to quit
+        unexpectedly
+      - The RTMPT dissector could crash
+      - The RMI dissector could disclose system memory
+      - The syslog dissector could crash
+    - (enable setuid dumpcap install -> disabled again for now,
+       needs discussion first)
+    - del 20_set_foreground.dpatch; incorporated upstream
+
+ -- Joost Yervante Damad <andete@debian.org>  Tue, 01 Jul 2008 21:08:31 +0200
+
+wireshark (1.0.0-3) unstable; urgency=low
+
+  * remove transitional "ethereal" packages
+    (Closes: #477529, #477532, #477534, #477541)
+  * create README.Debian with note about the sometimes surprising
+    display filter syntax (Closes: #456506, #456507)
+  * tethereal is completely gone now (Closes: #410058)
+  * be more liberal with respect to umask when creating files
+    (Closes: 191088): 19_umask.dpatch
+
+ -- Joost Yervante Damad <andete@debian.org>  Sat, 26 Apr 2008 10:20:02 +0200
+
+wireshark (1.0.0-2) unstable; urgency=low
+
+  [Joost Yervante Damad]
+  * avoid /usr/share/wireshark/wireshark (Closes: #476574)
+  * disable patch 07 and 14, I think patch 07 caused the
+    build failure which introduced patch 14
+  * this version works with "ForwardX11Trusted no" (Closes: #298740)
+  * disable patch 10 (obsolete)
+  * submission (tcp/587) is recognized as SMTP now (Closes: #456513)
+  * save as works for filtered output (Closes: #456502)
+  * preferences settings get active immediately now (Closes: #259319)
+
+  [Frederic Peters]
+  * debian/control: updated Depends from automake1.8 to automake1.9
+    (closes: #474341)
+
+ -- Joost Yervante Damad <andete@debian.org>  Tue, 22 Apr 2008 19:59:24 +0200
+
+wireshark (1.0.0-1) unstable; urgency=low
+
+  * Several security issues were solved in 0.99.7 already:
+    (closes: #452381)
+    * allow remote attackers to cause a denial of service (crash) via (1) a
+      crafted MP3 file or (2) unspecified vectors to the NCP dissector
+      (CVE-2007-6111)
+    * Buffer overflow in the PPP dissector Wireshark (formerly Ethereal)
+      0.99.6 allows remote attackers to cause a denial of service (crash)
+      and possibly execute arbitrary code via unknown vectors.
+      (CVE-2007-6112)
+    * Wireshark (formerly Ethereal) 0.10.12 to 0.99.6 allows remote
+      attackers to cause a denial of service (long loop) via a malformed DNP
+      packet (CVE-2007-6113)
+    * Multiple buffer overflows in Wireshark (formerly Ethereal) 0.99.0
+      through 0.99.6 allow remote attackers to cause a denial of service
+      (crash) and possibly execute arbitrary code via (1) the SSL dissector
+      or (2) the iSeries (OS/400) Communication trace file parser
+      (CVE-2007-6114)
+    * Buffer overflow in the ANSI MAP dissector for Wireshark (formerly
+      Ethereal) 0.99.5 to 0.99.6, when running on unspecified platforms,
+      allows remote attackers to cause a denial of service and possibly
+      execute arbitrary code via unknown vectors. (CVE-2007-6115)
+    * The Firebird/Interbase dissector in Wireshark (formerly Ethereal)
+      0.99.6 allows remote attackers to cause a denial of service (infinite
+      loop or crash) via unknown vectors. (CVE-2007-6116)
+    * Unspecified vulnerability in the HTTP dissector for Wireshark
+      (formerly Ethereal) 0.10.14 to 0.99.6 has unknown impact and remote
+      attack vectors related to chunked messages. (CVE-2007-6117)
+    * The MEGACO dissector in Wireshark (formerly Ethereal) 0.9.14 to 0.99.6
+      allows remote attackers to cause a denial of service (long loop and
+      resource consumption) via unknown vectors. (CVE-2007-6118)
+    * The DCP ETSI dissector in Wireshark (formerly Ethereal) 0.99.6 allows
+      remote attackers to cause a denial of service (long loop and resource
+      consumption) via unknown vectors. (CVE-2007-6119)
+    * The Bluetooth SDP dissector Wireshark (formerly Ethereal) 0.99.2 to
+      0.99.6 allows remote attackers to cause a denial of service (infinite
+      loop) via unknown vectors. (CVE-2007-6120)
+    * Wireshark (formerly Ethereal) 0.8.16 to 0.99.6 allows remote attackers
+      to cause a denial of service (crash) via a malformed RPC Portmap
+      packet. (CVE-2007-6121)
+  * current wireshark has SSL support (closes: #172939)
+  * and H323 support (closes: #117201)
+  * resizing columns bugfix was applied last year (closes: #369044)
+  * new upstream release 1.0.0
+    http://www.wireshark.org/docs/relnotes/wireshark-1.0.0.html
+  * remove debian/ directory from upstream
+  * update 14_disable-cmip.dpatch.
+  * if wireshark has no priv, it now prints:
+      dumpcap: There are no interfaces on which a capture can be done
+      (closes: #468400)
+  * wireshark uses su-to-root now (closes: #472478)
+  * vulnerabilities fixed:
+    * The X.509sat and other dissector could crash (CVE-2008-1561)
+    * The LDAP dissector could crash on Windows and other platforms.
+      (CVE-2008-1562)
+    * The SCCP dissector could crash while using the "decode as"
+      feature (CVE-2008-1563)
+
+ -- Joost Yervante Damad <andete@debian.org>  Tue, 01 Apr 2008 19:48:19 +0200
+
+wireshark (0.99.8-1) unstable; urgency=medium
+
+  * New upstream release.
+    * release notes:
+      http://www.wireshark.org/docs/relnotes/wireshark-0.99.8.html
+    * Fixes strptime() problem; debian/patches/18_strptime_proto.dpatch
+      no longer needed; (closes: #452772)
+    * Fixed security issues:
+      * The SCTP dissector could crash. (CVE-2008-1070)
+      * The SNMP dissector could crash. (CVE-2008-1071)
+      * (closes: #469488)
+  * updated debian/patches/05_plugin-libdir.dpatch, as upstream
+    incorporated part of the patch
+  * updated debian/patches/08_wireshark-desktop-menu.dpatch
+  * updated debian/patches/14_disable-cmip.dpatch
+  * use su-to-root isof gksu (closes: #454051)
+  * make init.lua a conffile (closes: #458689)
+  * use $(CURDIR) isof `pwd` in debian/rules
+  * lintian fixes:
+    * I: wireshark binary: desktop-entry-contains-encoding-key
+      /usr/share/applications/wireshark-root.desktop
+    * W: wireshark binary: su-wrapper-not-su-to-root
+      /usr/share/applications/wireshark-root.desktop gksu
+  * bump standards version to 3.7.2.2 (3.7.3.0 still needs more checking)
+  * update debhelper compat to 5
+  * bump standards version to 3.7.3.0
+  * update debhelper compat to 6
+  * remove debian/ dir from upstream tar file
+
+ -- Joost Yervante Damad <andete@debian.org>  Wed, 12 Mar 2008 20:47:56 +0100
+
+wireshark (0.99.7-1.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * debian/patches/18_strptime_proto.dpatch: Define __USE_XOPEN when
+    using the strptime function.  (closes: #452772)
+
+ -- dann frazier <dannf@debian.org>  Mon, 10 Mar 2008 14:16:45 -0600
+
+wireshark (0.99.7-1) unstable; urgency=high
+
+  * New upstream release.
+    * fixes several security issues:
+      * The IPv6 dissector could loop excessively.  (CVE-2007-6439)
+      * The USB dissector could loop excessively or crash.  (CVE-2007-6439)
+      * The SMB dissector could crash.  (CVE-2007-6438)
+      * The RPL dissector could go into an infinite loop.  (CVE-2007-6450)
+      * The WiMAX dissector could crash due to unaligned access on some
+        platforms.  (CVE-2007-6441)
+      * The CIP dissector could attempt to allocate a huge amount of memory
+        and crash.  (CVE-2007-6451)
+  * debian/patches/04_drop-capabilities.dpatch: disable "drop capabilities"
+    patch as Wireshark now has a dumpcap binary that drop capabilities and
+    capture network.  This fixes issues of dropping too many capabilities.
+    (closes: #453292)
+  * debian/control, debian/rules: enabled LUA support.  (closes: #412097)
+  * debian/patches/17_clique_rm_support.dpatch: add support for the CliqueRM
+    protocol.  (closes: #454739)
+  * debian/patches/05_plugin-libdir.dpatch: updated to fix plugin installation.
+    (closes: #454758)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 21 Dec 2007 17:56:59 +0100
+
+wireshark (0.99.7~pre1-2) unstable; urgency=low
+
+  * debian/rules: adds LD_LIBRARY_PATH when calling dpkg-shlibdeps and adds
+    a wireshark-common shlibs file.  (closes: #453801)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 05 Dec 2007 16:27:59 +0100
+
+wireshark (0.99.7~pre1-1) unstable; urgency=high
+
+  * New upstream pre-version; packaged since it fixes security issues:
+    * Could crash when reading an MP3 file.
+    * Could loop excessively while reading a malformed DNP packet.
+    * The SSL dissector could overflow a buffer.
+    * The ANSI MAP dissector could be susceptible to a buffer overflow on some
+      platforms.
+    * The Firebird/Interbase dissector could go into an infinite loop or
+      crash.
+    * The NCP dissector could cause a crash.
+    * The HTTP dissector could crash on some systems while decoding chunked
+      messages.
+    * The MEGACO dissector could enter a large loop and consume system
+      resources.
+    * The DCP ETSI dissector could enter a large loop and consume system
+      resources.
+    * The iSeries (OS/400) Communication trace file parser could overflow a
+      buffer.
+    * The PPP dissector could overflow a buffer.
+    * The Bluetooth SDP dissector could go into an infinite loop.
+    * A malformed RPC Portmap packet could cause a crash.
+  * debian/patches/03_preferences.dpatch: modified to directly change
+    epan/prefs.c instead of going through configure.in modification.
+  * debian/patches/04_drop-capabilities.dpatch: configure check for libcap has
+    been integrated upstream, removed from patch, but added required explicit
+    -lcap linkage.
+  * debian/patches/05_plugin-libdir.dpatch, debian/rules: reduced patch; using
+    a configure flag instead of overriding plugindir.
+  * debian/patches/08_wireshark-desktop-menu.dpatch: updated.
+  * debian/patches/14_disable-cmip.dpatch: updated.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 22 Nov 2007 19:49:41 +0100
+
+wireshark (0.99.6rel-5) unstable; urgency=low
+
+  * debian/patches/16_licence_about_location.dpatch: removed GPL copy from
+    file used to fill the About dialog and created a new file with reference
+    to copy in /usr/share/common-licences/
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 29 Sep 2007 15:56:38 +0200
+
+wireshark (0.99.6rel-4) unstable; urgency=low
+
+  * debian/patches/14_disable-cmip.dpatch: removed automake generated part as
+    it can cause problems on a second build.  (closes: #442760)
+  * debian/control: upgraded build-depends from libportaudio-dev to
+    portaudio19-dev (closes: #431222)
+  * debian/patches/08_wireshark-desktop-menu.dpatch: updated to add Encoding
+    entry, as required by desktop file spec
+  * debian/patches/08_wireshark-desktop-menu.dpatch: updated Categories entry
+    to remove Application.
+  * debian/wireshark-root.desktop: updated Categories to remove Application.
+  * debian/wireshark.menu: renamed Apps to Applications and Net to Network,
+    and added a subsubmenu, "Monitoring", to comply with new menu policy.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 28 Sep 2007 21:02:41 +0200
+
+wireshark (0.99.6rel-3) unstable; urgency=low
+
+  * debian/rules: added check for wireshark-dev headers (closes: #436247)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 24 Aug 2007 14:19:01 +0000
+
+wireshark (0.99.6rel-2) unstable; urgency=low
+
+  * debian/rules: added -02 -g CFLAGS (closes: #439298)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 24 Aug 2007 07:48:08 +0000
+
+wireshark (0.99.6rel-1) unstable; urgency=low
+
+  * New upstream release.
+    * named 0.99.6rel to be greater than 0.99.6pre
+  * added epan/ subdirectories to dev header files (closes: #436247)
+    * I still need someone to provide me with test code so an extension can
+      actually be built and tested at build time.
+  * debian/rules: added --enable-warnings-as-errors=no to configure flags
+  * debian/patches/15_sensitive_open.dpatch: new patch to allow keyboard
+    selection of capture file in open dialog (closes: #439198)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 23 Aug 2007 09:13:00 +0000
+
+wireshark (0.99.6pre1-1) unstable; urgency=high
+
+  * New upstream pre-release, with security fixes:
+    * could crash when dissecting an HTTP chunked response
+    * could crash while reading iSeries capture files
+    * could exhaust system memory while reading a malformed DCP ETSI packet
+    * could loop excessively while reading a malformed SSL packet
+    * DHCP/BOOTP dissector was susceptible to an off-by-one error
+    * could loop excessively while reading a malformed MMS packet
+  * debian/control: added libkrb5-dev to build-deps so Kerberos support is
+    built.
+  * debian/control: replaced {Source-Version} with appropriate {binary:Version}
+  * debian/wireshark-dev.header-files: use wildcards to get all headers
+    (closes: #423000)
+  * debian/patches/14_disable-cmip.dpatch: disable CMIP dissector which
+    doesn't build at the moment.
+  * debian/rules: don't ignore all errors on make distclean
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 25 Jun 2007 13:33:43 +0200
+
+wireshark (0.99.5-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/patches/09_idl2wrs.dpatch: updated to patch idl2wrs.sh.in.
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 01 Apr 2007 08:58:40 +0000
+
+wireshark (0.99.4-5) unstable; urgency=high
+
+  * debian/patches/00list: really include backported security fixes, stupid me.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 26 Feb 2007 09:30:29 +0000
+
+wireshark (0.99.4-4) unstable; urgency=high
+
+  * Backported security fixes from 0.99.5pre1
+    * The TCP dissector could hang or crash while reassembling HTTP packets.
+    * The HTTP dissector could crash.
+    * On some systems, the IEEE 802.11 dissector could crash.
+    * On some systems, the LLT dissector could crash.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 19 Jan 2007 21:49:04 +0100
+
+wireshark (0.99.4-3) unstable; urgency=low
+
+  * debian/control: added build dependency on libportaudio-dev so sniffed voip
+    G.711 calls are listenable. (closes: #398673)
+  * debian/patches/08_wireshark-desktop-menu.dpatch: removed extraneous .rej
+    file from patch.
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 19 Nov 2006 16:39:26 +0000
+
+wireshark (0.99.4-2) unstable; urgency=low
+
+  * debian/wireshark-dev.files: added more headers, so that dissectors for 
+    DCE/RPC interfaces can be build externally. (closes: #397292)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  6 Nov 2006 12:48:20 +0100
+
+wireshark (0.99.4-1) unstable; urgency=high
+
+  * Backported security patches from yet unreleased 0.99.4 (closes: #396258)
+    * http://www.wireshark.org/security/wnpa-sec-2006-03.html has details
+    * HTTP dissector could crash (CVE-2006-5468)
+    * LDAP dissector (and others) could crash (CVE-2006-5740)
+    * XOT dissector could attempt to allocate a large amount of memory and
+      crash (CVE-2006-4805)
+    * WBXML dissector could crash (CVE-2006-5469)
+    * MIME Multipart dissectar was susceptible to an off-by-one error
+      (CVE-2006-4574)
+    * Parsing a WEP key could cause a crash
+  * debian/control: disabled libcap-dev for kfreebsd and hurd
+    (closes: #375022)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed,  1 Nov 2006 10:05:05 +0100
+
+wireshark (0.99.3a-2) unstable; urgency=low
+
+  * debian/ethereal-common.NEWS: added a note about ethereal -> wireshark name
+    change.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 12 Oct 2006 15:42:48 +0200
+
+wireshark (0.99.3a-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/patches/11_iscsi_dissector.dpatch, 12_ipsec_dissector.dpatch,
+    13_q2931_security_fix.dpatch: security patches that were backported.
+  * debian/patches/11_typo_packet-dap: fixed a typo s/diwsect/dissect/
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 18 Sep 2006 18:56:12 +0200
+
+wireshark (0.99.2-6) unstable; urgency=low
+
+  * Acknowledge NMU, thank Steinar.
+  * debian/wireshark-dev.postinst: removed rests of old Python module
+    compilation, it is not needed by new policy.  (closes: #385357)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed,  6 Sep 2006 23:34:36 +0200
+
+wireshark (0.99.2-5.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Backport security fixes from 0.99.3a (via Subversion); fixes
+    CVE-2006-4331, CVE-2006-4333 (CVE-2006-4330 was fixed in last upload,
+    and CVE-2006-4332 is not relevant for Debian). (Closes: #384529)
+
+ -- Steinar H. Gunderson <sesse@debian.org>  Tue,  5 Sep 2006 02:15:53 +0200
+
+wireshark (0.99.2-5) unstable; urgency=low
+
+  * debian/patches/11_iscsi_dissector.dpatch: new patch, fixing bug reported
+    against iSCSI dissector, taken from upstream (r18832) (closes: #381860)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  7 Aug 2006 16:59:50 +0200
+
+wireshark (0.99.2-4) unstable; urgency=low
+
+  * debian/control: set ethereal-dev section to devel, it was lost in copy
+    pasting.
+  * debian/control, debian/rules, debian/pyversions: updated to new Python
+    policy. (closes: #380986)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue,  1 Aug 2006 13:05:21 +0200
+
+wireshark (0.99.2-3) unstable; urgency=low
+
+  * debian/control: added dummy transitional packages to provide an upgrade
+    path from ethereal.  (closes: #380647)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 31 Jul 2006 18:21:27 +0200
+
+wireshark (0.99.2-2) unstable; urgency=low
+
+  * debian/rules: set --datadir so that DATAFILE_DIR is correct (it was
+    wrongly set to "${prefix}/share/wireshark" and not expanded.
+    * AUTHORS-SHORT is now displayed correclty in about dialog
+    * colofilters is now found and used properly
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 26 Jul 2006 13:27:54 +0200
+
+wireshark (0.99.2-1) unstable; urgency=high
+
+  * New upstream release. (closes: #378745)
+    * The project changed name, ethereal is now wireshark. (closes: #351941)
+      See http://www.wireshark.org/news/20060607.html
+      * tethereal has been renamed to tshark
+      * idl2eth has been renamed to idl2wrs
+    * Urgency high since it fixes security issues
+      * http://www.wireshark.org/security/wnpa-sec-2006-01.html has details
+      * crash in GSM BSSMAP dissector (CVE-2006-3627)
+      * format string overflow in ANSI MAP dissector (CVE-2006-3628)
+      * format string overflow in Checkpoint FW-1 dissector (CVE-2006-3628)
+      * format string overflow in MQ dissector (CVE-2006-3628)
+      * format string overflow in XML dissector (CVE-2006-3628)
+      * large memory allocation in MOUNT dissector (CVE-2006-3629)
+      * off-by-one errors in NCP NMAS and NDPS dissectors (CVE-2006-3630)
+      * format string overflow in NTP dissector (CVE-2006-3628)
+      * infinite loop in SSH dissector (CVE-2006-3631)
+      * buffer overflow in NFS dissector (CVE-2006-3632)
+  * debian/wireshark-dev.header-files: includes missing files
+    (closes: #376522, #368860)
+  * debian/copyright: list source files that are under a license different
+    than Wireshark.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 24 Jul 2006 19:29:26 +0200
+
+ethereal (0.99.0-1) unstable; urgency=high
+
+  * New upstream release (urgency high since it fixes security issues;
+    see http://www.ethereal.com/appnotes/enpa-sa-00023.html advisory)
+    * crash in H.248 dissector (CVE-2006-1937)
+    * infinite loop in UMA dissector (CVE-2006-1933)
+    * crash in X.509if dissector (CVE-2006-1937)
+    * crash in SRVLOC dissector (CVE-2006-1937)
+    * crash in H.245 dissector (CVE-2006-1937)
+    * off-by-one error in OID printing routine (CVE-2006-1932)
+    * buffer overflow in COPS dissector (CVE-2006-1935)
+    * buffer overflow in ALCAP dissector (CVE-2006-1934)
+    * crash in statistics counter (CVE-2006-1937)
+    * crash with malformed capture (CVE-2006-1938)
+    * crash with invalid display filter (CVE-2006-1939)
+    * crash in general packet dissector (CVE-2006-1937)
+    * crash in AIM dissector (CVE-2006-1937)
+    * crash in RPC dissector (CVE-2006-1939)
+    * crash in DCERPC dissector (CVE-2006-1939)
+    * crash in ASN.1 dissector (CVE-2006-1939)
+    * crash in SMB PIPE dissector (CVE-2006-1938)
+    * excessive loop in BER dissector (CVE-2006-1933)
+    * abort in SNDCP dissector (CVE-2006-1940)
+    * buffer overrun in Network Instruments file code (CVE-2006-1934)
+    * buffer overrun in NetXray/Windows Sniffer file code (CVE-2006-1934)
+    * crash in GSM SMS dissector (CVE-2006-1939)
+    * buffer overrun in ALCAP dissector (CVE-2006-1934)
+    * buffer overrun in telnet dissector (CVE-2006-1936)
+    * crash in ASN.1 based dissectors (CVE-2006-1939)
+    * crash in DCERPC NT dissector (CVE-2006-1939)
+    * crash in PER dissector (CVE-2006-1939)
+  * debian/patches/04_drop-capabilities.dpatch: updated.
+  * debian/control: added build-depends on libgnutls-dev since libgnutls can
+    now be used for SSL support.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  1 May 2006 14:50:42 +0200
+
+ethereal (0.10.14-2) unstable; urgency=low
+
+  * debian/watch: added watch file.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  6 Mar 2006 00:03:13 +0100
+
+ethereal (0.10.14-1) unstable; urgency=low
+
+  * New upstream release.
+  * Acknowledge NMU, thanks for the support while I was away.
+  * debian/patches/11-security-CVE-2005-3651.dpatch: removed since included
+    upstream.
+  * debian/patches/07_gcc4.dpatch: removed part about packet-cms since it now
+    causes the build to fail.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 23 Feb 2006 11:04:11 +0100
+
+ethereal (0.10.13-1.3) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Build-conflict with libsnmp-dev, not just libsnmp5-dev, to prevent
+    accidental linkage with openssl.  Closes: #353613.
+
+ -- Steve Langasek <vorlon@debian.org>  Sun, 19 Feb 2006 18:03:20 -0800
+
+ethereal (0.10.13-1.2) unstable; urgency=high
+
+  * Non-maintainer upload.
+  * High-urgency upload for RC bugfix.
+  * Add missing epan/gnuc_format_check.h, epan/ipv6-utils.h headers to
+    ethereal-dev.  Closes: #344011.
+  * Build-depend on automake1.9 instead of automake; the latter points to
+    the ancient automake1.4 package, which was not what's used upstream.
+
+ -- Steve Langasek <vorlon@debian.org>  Fri, 17 Feb 2006 17:47:37 -0800
+
+ethereal (0.10.13-1.1) unstable; urgency=high
+
+  * Non-maintainer upload.
+  * Fix buffer overflow in OSPF dissector (CVE-2005-3651)
+
+ -- Moritz Muehlenhoff <jmm@debian.org>  Sun, 25 Dec 2005 11:15:28 +0100
+
+ethereal (0.10.13-1) unstable; urgency=high
+
+  * New upstream release (urgency high since it fixes security issues;
+    see http://www.ethereal.com/appnotes/enpa-sa-00021.html advisory)
+    * memory exhaustion by ISAKMP, FC-FCS, RSVP, ISIS LSP dissectors
+      (CAN-2005-3241)
+    * crash in IrDA dissector and SMB transaction payload reassembly
+      (CAN-2005-3242)
+    * buffer overflow in AgentX and SLIMP3 dissectors (CAN-2005-3243)
+    * infinite loop in BER dissector (CAN-2005-3244)
+    * memory exhaustion by ONC RPC dissector with option "Dissect unknown RPC
+      program numbers" (CAN-2005-3245)
+    * NULL pointer in sFlow, RTnet, SCSI dissectors (CAN-2005-3246)
+    * infinite loop and crash in SigComp UDVM (CAN-2005-3247)
+    * division by zero in X11 dissector (CAN-2005-3248)
+    * invalid pointer freed in WSP dissecto (CAN-2005-3249)
+    * buffer overflow in SRVLOC dissector (CAN-2005-3184)
+  * debian/patches/04_drop-capabilities.dpatch: updated
+  * debian/patches/08_ethereal-desktop-menu.dpatch: updated
+  * debian/patches/09_idl2eth.dpatch: updated
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  8 Dec 2005 14:18:07 +0100
+
+ethereal (0.10.12-6) unstable; urgency=low
+
+  * Rebuilt with gtk/atk from unstable. (closes: #329889)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 24 Sep 2005 11:11:40 +0200
+
+ethereal (0.10.12-5) unstable; urgency=low
+
+  * debian/ethereal-dev.header-files: added missing epan/range.h
+    (closes: #306426)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 23 Sep 2005 18:28:04 +0200
+
+ethereal (0.10.12-4) unstable; urgency=low
+
+  * debian/control: upgraded automake dependency of ethereal-dev to 1.8.
+  * debian/patches/11_diameter_vendors.dpatch: removed, wrong.
+  * debian/ethereal-common.files: add capinfos.
+  * debian/ethereal-common.manpages: add capinfos man page.
+  * debian/changelog: fixed 0.6.3-2 header line since lintian now complains
+    about the old way of closing bugs from changelogs.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 12 Aug 2005 00:43:39 +0200
+
+ethereal (0.10.12-3) unstable; urgency=low
+
+  * debian/patches/04_drop-capabilities.dpatch: don't exit on failure, simply
+    skip the capabilities part; use g_warning to output messages.
+    (closes: #321204)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  4 Aug 2005 09:41:24 +0200
+
+ethereal (0.10.12-2) unstable; urgency=low
+
+  * debian/patches/04_drop-capabilities.dpatch: preserves CAP_DAC_READ_SEARCH
+    which seems necessary for sudo usage (closes: #320453)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 31 Jul 2005 12:56:50 +0200
+
+ethereal (0.10.12-1) unstable; urgency=high
+
+  * New upstream release; urgency high since it fixes security issues in many
+    dissectors; see http://www.ethereal.com/appnotes/enpa-sa-00020.html
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 27 Jul 2005 09:57:17 +0200
+
+ethereal (0.10.11-5) unstable; urgency=low
+
+  * debian/patches/11_diameter_vendors.dpatch: correctly add diameter vendors
+    (patch by Joost Yervante Damad) (closes: #316082)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 18 Jul 2005 20:18:43 +0200
+
+ethereal (0.10.11-4) unstable; urgency=low
+
+  * debian/: now using dpatch, started from Ubuntu patch, merged with current
+    package patches.
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 17 Jul 2005 18:58:05 +0200
+
+ethereal (0.10.11-3) unstable; urgency=low
+
+  * Modified capabilities patch so it doesn't try to keep CAP_NET_RAW if it
+    doesn't have it. (closes: #318689)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 17 Jul 2005 10:29:31 +0200
+
+ethereal (0.10.11-2) unstable; urgency=low
+
+  * Use capabilities to mitigate security risk, patch from J.H.M. Dassen (Ray)
+    (closes: #315670)
+  * debian/control: build-depends on libcap-dev
+  * epan/dissectors/packet-cmip.c: fixed dissect_cmip_InvokeIDType declaration
+    mismatch.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 16 Jul 2005 10:58:03 +0200
+
+ethereal (0.10.11-1) unstable; urgency=high
+
+  * New upstream release; urgency high since it fixes security issues in the
+    following dissectors:
+    * format string vulnerabilities: ANSI A, DHCP
+    * segmentation faults: GSM MAP, AIM, TZSP, Bittorrent, SMB, GSM, SMB
+      NETLOGON
+    * buffer overflows: DISTCC, FCELS, SIP, ISIS, CMIP, CMP, CMS, CRMF, ESS,
+      OCSP, PKIX1Explitit, PKIX Qualified, X.509, NCP, ISUP, TCAP,
+      Presentation
+    * null pointer exception: KINK, WSP, SMB Mailslot, H.245, MGCP, RPC
+    * infinite loops: LMP, EIGRP, MEGACO, L2TP
+    * uncaught assertions: Telnet, 802.3, BER, IAX2, RADIUS, SMB PIPE, MRDISC
+    * memory exhaustion: DICOM
+    * unclassified: Fibre Channel, LDAP, NTLMSSP
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  5 May 2005 08:43:00 +0200
+
+ethereal (0.10.10-2) unstable; urgency=high
+
+  * Several security fixes from upstream subversion tree for the following
+    dissectors:
+    * DLSw (infinite loop)
+    * ICEP (double free)
+    * NDPS (memory exhaustion)
+    * Q931 (buffer overflow)
+    * RSVP (infinite loop) (CAN-2005-1281)
+    * SRVLOC (infinite loop)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 25 Apr 2005 15:30:55 +0200
+
+ethereal (0.10.10-1) unstable; urgency=high
+
+  * New upstream release; urgency high since it fixes security issues.
+    * Fixes buffer overflow in Etheric dissector. (CAN-2005-0704)
+    * Fixes crash in GPRS-LLC dissector. (CAN-2005-0705)
+    * Fixes buffer overflow in 3G-A11 dissector. (CAN-2005-0699)
+      (was already fixed in Debian package)
+  * debian/ethereal-dev.header-files: some files moved to epan/
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 14 Mar 2005 10:16:03 +0100
+
+ethereal (0.10.9-2) unstable; urgency=high
+
+  * Backported packet-3g-a11.c from upstream subversion trunk.
+    (fixes buffer overflows in 3G-A11 dissector)
+    (CAN-2005-0699 (under review)) (closes: #298771)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 10 Mar 2005 10:25:08 +0100
+
+ethereal (0.10.9-1) unstable; urgency=high
+
+  * New upstream release; urgency high since it fixes security issues.
+    * Fixes infinite loop in COPS dissector. (CAN-2005-0006)
+    * Fixes assertion in DLSw dissector. (CAN-2005-0007)
+    * Fixes memory corruption in DNP dissector. (CAN-2005-0008)
+    * Fixes assertion in Gnutella dissector. (CAN-2005-0009)
+    * Fixes memory corruption in MMSE dissector. (CAN-2005-0010)
+    * Fixes buffer overflow in X11 dissector. (CAN-2005-0084)
+  * asn2deb and idl2deb manpages relicensed by W. Borgert from GFDL to GPL
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 20 Jan 2005 23:03:19 +0100
+
+ethereal (0.10.8-4) unstable; urgency=low
+
+  * Updated libtool version in wiretap/ directory. (closes: #289962)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 12 Jan 2005 10:14:41 +0100
+
+ethereal (0.10.8-3) unstable; urgency=low
+
+  * Fixed dissect_cmip_InvokeIDType declaration (FTBFS with gcc-4.0)
+    (closes: #288990)
+  * epan/dissectors/packet-giop.c: fixed segfault with some GIOP packets
+    (closes: #288746)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri,  7 Jan 2005 14:43:03 +0100
+
+ethereal (0.10.8-2) unstable; urgency=low
+
+  * Restored lost patch to idl2eth; sorry. (closes: #288740)
+  * ethereal_gen.py: fixed some includes.
+  * epan/prefs.c: Use sensible-brower as default browser.
+  * debian/control: build-depends on libpcap0.8-dev.
+  * debian/control: lower-case first letter of descriptions.
+
+ -- Frederic Peters <fpeters@debian.org>  Wed,  5 Jan 2005 14:34:57 +0100
+
+ethereal (0.10.8-1) unstable; urgency=high
+
+  * New upstream release.
+    * Now parses Auth option in DHCPv6 (closes: #283534)
+    * Urgency high since it fixes security issues with DICOM, RTP, HTTP
+      and SMB <http://www.ethereal.com/appnotes/enpa-sa-00016.html>
+      (CAN-2004-1139, CAN-2004-1140, CAN-2004-1141 and CAN-2004-1142)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 15 Dec 2004 22:13:41 +0100
+
+ethereal (0.10.7-3) unstable; urgency=low
+
+  * epan/prefs.c: changed default font to "monospace 10" (closes: #232408)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 19 Nov 2004 18:31:22 +0100
+
+ethereal (0.10.7-2) unstable; urgency=low
+
+  * plugins/opsi/packet-opsi.c: backported resource exhaustion fix
+    (closes: #280556)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 18 Nov 2004 21:50:28 +0100
+
+ethereal (0.10.7-1) unstable; urgency=low
+
+  * New upstream release. (closes: #277923)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  1 Nov 2004 14:11:35 +0100
+
+ethereal (0.10.6-4) unstable; urgency=low
+
+  * Build in clean chroot; stupid me.  (closes: #276560)
+  * debian/rules: remove config.log on clean.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 15 Oct 2004 00:12:58 +0200
+
+ethereal (0.10.6-3) unstable; urgency=medium
+
+  * Upgrades libtool (closes: #276515)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 14 Oct 2004 18:40:03 +0200
+
+ethereal (0.10.6-2) unstable; urgency=medium
+
+  * debian/ethereal-dev.header-files: added missing header files
+    (closes: #270581)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed,  8 Sep 2004 10:34:12 +0200
+
+ethereal (0.10.6-1) unstable; urgency=high
+
+  * New upstream realease.
+    * Gtk-Critical messages are fixed (closes: #260341, #263118)
+  * debian/rules: run libtoolize to fix sonames; fix a FTBFS bug
+    (closes: #265379)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 15 Aug 2004 11:58:03 +0200
+
+ethereal (0.10.5-4) unstable; urgency=low
+
+  * link libethereal.so to libadns and libm (closes: #262015)
+    (since this is a private shared library I don't think it was required)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 29 Jul 2004 15:41:02 +0200
+
+ethereal (0.10.5-3) unstable; urgency=low
+
+  * debian/ethereal-dev.header-files: install packet-rpc.h, crc16.h and crc32.h
+    (closes: #259375)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 14 Jul 2004 12:50:34 +0200
+
+ethereal (0.10.5-2) unstable; urgency=low
+
+  * Compile and install plugins (closes: #259199)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 13 Jul 2004 13:40:41 +0000
+
+ethereal (0.10.5-1) unstable; urgency=low
+
+  * New upstream release with security fixes.
+    + <http://www.ethereal.com/appnotes/enpa-sa-00015.html>
+    + Fixed the crash in protocol hierarchy (closes: #244743)
+    + Ethereal can be configured not to bug you about unsaved captures
+      (closes: #235721)
+  * Updated omniorb URL (closes: #257512)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 13 Jul 2004 10:16:55 +0200
+
+ethereal (0.10.4-3) unstable; urgency=low
+
+  * debian/rules: install libethereal in /usr/lib/ethereal, not /usr/lib/
+  * debian/ethereal-dev.header-files: added packet-ber.h
+  * idl2deb: ETH_VER_IMPORT and non-versioned autotools (closes: #255570)
+  * debian/control: updated depends to libpcap0.7-dev, no more libpcap-dev
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 22 Jun 2004 09:02:39 +0200
+
+ethereal (0.10.4-2) unstable; urgency=low
+
+  * Rebuilt against GTK+ 2.4; now in unstable.
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 25 May 2004 22:28:37 +0200
+
+ethereal (0.10.4-1) unstable; urgency=high
+
+  * New upstream release with security fixes.
+    <http://www.ethereal.com/appnotes/enpa-sa-00014.html>
+  * (sorry about the delay; I was away and forgot about this release)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 16 May 2004 00:02:53 +0200
+
+ethereal (0.10.3-3) unstable; urgency=low
+
+  * debian/control: removed dependency on gksu; moved to recommends
+  * debian/EtherealAsRoot.desktop: added TryExec=gksu so that the menu is
+    only shown when gksu is installed
+  * debian/ethereal.menu: removed entry for "ethereal as root" since
+    """running ethereal itself requires some wits, and user possesing
+    such skills would be able to launch it from xterm."""
+  * "Our Priorities are Our Users (...)", but ignore them if they ask
+    about gksu support; it's against the holy Debian Policy Manual and
+    a """300kB dependency *is* a big dependency""".
+  * This closes the bug and everybody is happy (closes: #240682)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 10 Apr 2004 21:16:30 +0200
+
+ethereal (0.10.3-2) unstable; urgency=high
+
+  * Acknowledge NMU. (sorry)  (urgency high, security fixes)
+  * debian/control: added Build-Conflicts on libsnmp-dev
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 28 Mar 2004 23:14:51 +0200
+
+ethereal (0.10.3-1.0.1) unstable; urgency=low
+
+  * Recompile-only NMU.
+  * i386 package was uploaded with dependencies on GNOME libs from
+    experimental; rebuild using only dependencies from unstable.
+
+ -- Steve Langasek <vorlon@debian.org>  Sat, 27 Mar 2004 21:27:01 -0600
+
+ethereal (0.10.3-1) unstable; urgency=high
+
+  * New upstream release with security fixes. (hence urgency high)
+    http://www.ethereal.com/appnotes/enpa-sa-00013.html
+  * debian/rules: remove upstream debian/menu on build
+  * debian/control: added dependency on gksu
+  * debian/menu: added an entry to start ethereal with gksu
+    (closes: #71994)
+  * added another .desktop entry to start ethereal with gksu from Gnome menu
+  * Upstream changes; libethereal and libwiretap handled differently; they may
+    end up in new packages (but go in ethereal-common for now)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 27 Mar 2004 14:09:49 +0100
+
+ethereal (0.10.2-2) unstable; urgency=low
+
+  * New files in ethereal-dev (closes: #236702)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun,  7 Mar 2004 21:43:17 +0100
+
+ethereal (0.10.2-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/control: added libpcre3-dev to Build-Depends
+
+ -- Frederic Peters <fpeters@debian.org>  Fri,  5 Mar 2004 15:56:50 +0100
+
+ethereal (0.10.1-1) unstable; urgency=low
+
+  * New upstream release.
+  * Include W. Bogert asn2deb (closes: #233603)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 19 Feb 2004 18:02:08 +0100
+
+ethereal (0.10.0-6) unstable; urgency=low
+
+  * debian/ethereal-common.manpages: added ethereal-filter.4
+    (closes: #230256)
+  * debian/control: updated build-depends on docbook-xsl since docbook.xsl
+    moved.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 29 Jan 2004 18:11:43 +0100
+
+ethereal (0.10.0-5) unstable; urgency=low
+
+  * debian/rules: quotes around CFLAGS. (closes: #228492)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 19 Jan 2004 12:14:02 +0100
+
+ethereal (0.10.0-4) unstable; urgency=low
+
+  * Backported hexdump summary fix from CVS (closes: #226248)
+    http://www.ethereal.com/lists/ethereal-cvs/200312/msg00257.html
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  5 Jan 2004 15:27:06 +0100
+
+ethereal (0.10.0-3) unstable; urgency=low
+
+  * ethereal_gen.py: patched to handle ushort/ulong union discriminators.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 18 Dec 2003 23:27:51 +0100
+
+ethereal (0.10.0-2) unstable; urgency=low
+
+  * debian/ethereal-dev.header-files: added missing header files.
+    (closes: #224246)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 17 Dec 2003 13:24:21 +0100
+
+ethereal (0.10.0-1) unstable; urgency=low
+
+  * New upstream release. (closes: #223857)
+    * correct fonts with GTK2. (closes: #197571)
+    * Includes missing help/ directory from CVS.
+  * Acknowledge NMU, thanks Ray.
+    * Security issues. (closes: #219590)
+    * idl2deb permissions. (closes: #211506)
+  * New idl2deb version, thanks. (closes: #213962)
+  * debian/ethereal-dev.header-files: include some missing header files
+    (closes the remaining of #211506)
+  * debian/control: versioned build-depends on debhelper.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 13 Dec 2003 17:11:09 +0100
+
+ethereal (0.9.16-0.1) unstable; urgency=high
+
+  * NMU.
+  * New upstream release (addresses #219590 for sid).
+    Fixes potential security issues with several dissectors:
+    * GTP (http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0925)
+    * ISAKMP and MEGACO
+      (http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0926)
+    * SOCKS (http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0927)
+    The upstream security advisory is enpa-sa-00011, available at
+    http://www.ethereal.com/appnotes/enpa-sa-00011.html
+  * [debian/rules]
+    * Don't remove doc/ethereal.pod and doc/tethereal.pod so the package
+      builds with pbuilder.
+    * Install idl2deb with execute permissions.
+
+ -- J.H.M. Dassen (Ray) <jdassen@debian.org>  Mon, 10 Nov 2003 12:11:55 +0100
+
+ethereal (0.9.15-1) unstable; urgency=low
+
+  * New upstream release. (closes: #210272)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 10 Sep 2003 16:13:17 +0200
+
+ethereal (0.9.14-5) unstable; urgency=low
+
+  * debian/control: versioned build-depends on docbook-xsl (closes: #208734)
+  * debian/rules: compiles with -mieee on alpha
+
+ -- Frederic Peters <fpeters@debian.org>  Sun,  7 Sep 2003 09:57:25 +0200
+
+ethereal (0.9.14-4) unstable; urgency=low
+
+  * debian/rules: install .desktop and images for menu.
+    (closes: #207271)
+  * debian/control: updated policy to 3.6.1.0 (no changes needed)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 30 Aug 2003 23:27:00 +0200
+
+ethereal (0.9.14-3) unstable; urgency=low
+
+  * Add manpage for idl2deb
+  * Include missing header files. (closes: #197181)
+    - from same bug: remove dependency of ethereal-dev against ethereal-common
+    - from same bug: added dependency to libglib2.0-dev
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 19 Aug 2003 11:55:27 +0200
+
+ethereal (0.9.14-2) unstable; urgency=low
+
+  * Built for Python 2.3 since omniidl4 has been updated quickly.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 14 Aug 2003 10:19:18 +0200
+
+ethereal (0.9.14-1) unstable; urgency=low
+
+  * The "I'm so happy to be alive I'll fix plenty of bugs" release
+  * New upstream release. (closes: #204345)
+  * Include W. Bogert idl2deb script
+  * debian/control: depends on current versions of omniidl or omniidl4 since
+    they only exist for Python 2.2 and I don't want ethereal-dev to break when
+    they will switch to Python 2.3.  I'll then release a new version.
+  * Several UI issues resolved upstream (closes: #199763)
+  * ethereal can now decode Jabber protocol (closes: #133099)
+  * debian/control: build-depends on libadns1-dev so that it now use the GNU
+    ADNS library for name resolution (closes: #197505)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 13 Aug 2003 00:06:27 +0200
+
+ethereal (0.9.13-1) unstable; urgency=low
+
+  * New upstream release.  Fixing several security issues.
+    (closes: #197107)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 12 Jun 2003 10:00:57 +0200
+
+ethereal (0.9.12-3) unstable; urgency=low
+
+  * Rebuilt with new libpcap. (closes: #196831)
+  * Built with GTK+ 2.2 (instead of GTK+ 1.2). (closes: #193450)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 11 Jun 2003 17:45:07 +0200
+
+ethereal (0.9.12-2) unstable; urgency=low
+
+  * Forgot to update version-depends and it didn't use ${source-version}.
+    Fixed. (closes: #192213)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed,  7 May 2003 01:16:45 +0200
+
+ethereal (0.9.12-1) unstable; urgency=high
+
+  * New upstream release.  Fixing several security issues.
+    (closes: #192107)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue,  6 May 2003 22:03:10 +0200
+
+ethereal (0.9.9-2) unstable; urgency=low
+
+  * Updated config.guess and config.sub to work on mips and mipsel
+    architectures (manually then through the patch provided by
+    Martin Godisch). (closes: #178701)
+  * Update to packet-socks.c
+  * debian/control: ethereal-dev now depends upon omniidl | omniidl4
+    (closes: #182620)
+  * idl2eth no longer needs PYTHONPATH to be set explicitely.
+    (closes: #182621)
+  * debian/ethereal-dev.header-files: included config.h and reassemble.h since
+    they seem necessary. (closes: #183625)
+  * Thanks to W. Borgert for bug reporting.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri,  7 Mar 2003 22:52:27 +0000
+
+ethereal (0.9.9-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/control: Tightened ethereal-common dependencies.
+    (closes: #172861, #176236, #178027)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 24 Jan 2003 14:38:53 +0100
+
+ethereal (0.9.8-3) unstable; urgency=low
+
+  * debian/control: added versioned dependency between (t)ethereal and
+    ethereal-common to get the plug-ins. (closes: #172861)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 13 Dec 2002 10:39:27 +0100
+
+ethereal (0.9.8-2) unstable; urgency=low
+
+  * Updated config.sub and config.guess with the ones from autotools-dev
+    (closes: #172407)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 10 Dec 2002 09:52:45 +0100
+
+ethereal (0.9.8-1) unstable; urgency=low
+
+  * New upstream release.
+  * This added (some) support for counting IPv6 packets during capture.
+    (closes: #164472)
+  * 0.9.7 fixed the LMP dissector. (closes: #163513)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  9 Dec 2002 10:00:51 +0100
+
+ethereal (0.9.7-2) unstable; urgency=low
+
+  * debian/control: added libgtk2.0-dev to build depends.
+  * debian/control: removed libsnmp-dev from build depends (ethereal is
+    compiled without SNMP support since it would link against libssl)
+    (the build-dep caused failure to build on architectures where perl 5.8
+    wasn't ready (dependency on libsnmp-perl))
+  * debian/control: added python, automake and autoconf to build depends.
+  * debian/rules: creating aclocal-missing directory on build.
+      (those bugs closes: #163443) (patch by LaMont Jones)
+  * debian/rules: install Python files to 2.2 directory, not 2.1
+  * debian/ethereal-dev.postinst: fixed Python version (closes: #163153)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  7 Oct 2002 15:06:06 +0200
+
+ethereal (0.9.7-1) unstable; urgency=low
+
+  * New upstream release. (closes: #162972)
+  * debian/copyright: include upstream author name. (closes: #151015)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue,  1 Oct 2002 16:20:45 +0200
+
+ethereal (0.9.6-2) unstable; urgency=low
+
+  * debian/control: changed Python dep to >= 2.2 and << 2.3 since 2.2 is now
+    the default version in sid.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 14 Sep 2002 23:29:23 +0200
+
+ethereal (0.9.6-1) unstable; urgency=low
+
+  * New upstream release.
+  * Fixes security issue in the ISIS protocol dissector (susceptible to
+    buffer overflow).
+     (see http://www.ethereal.com/appnotes/enpa-sa-00006.html)
+  * Add missing header files (packet-tcp.h and packet-tpkt.h) to ethereal-dev
+    (closes: #158808)
+  * Add default PYTHONPATH to idl2eth (closes: #158909)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  2 Sep 2002 10:13:06 +0200
+
+ethereal (0.9.5-3) unstable; urgency=low
+
+  * Rebuilt with new libpcap0.7. (closes: #156206)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 10 Aug 2002 19:25:29 +0200
+
+ethereal (0.9.5-2) unstable; urgency=low
+
+  * Do not run libtoolize since it creates a bogus libtool file.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  8 Jul 2002 16:07:00 +0200
+
+ethereal (0.9.5-1) unstable; urgency=low
+
+  * New upstream release.
+  * Fixes several security issues.
+    (http://www.ethereal.com/appnotes/enpa-sa-00005.html)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 29 Jun 2002 19:13:30 +0200
+
+ethereal (0.9.4-1) unstable; urgency=medium
+
+  * New upstream release.
+  * Fixes four security issues. (closes: #147595)
+    (http://www.ethereal.com/appnotes/enpa-sa-00004.html)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 20 May 2002 01:10:21 +0200
+
+ethereal (0.9.3-1) unstable; urgency=medium
+
+  * New upstream release
+  * Fixes ASN.1 zero-length g_malloc that could lead to security problems.
+    (see http://www.ethereal.com/appnotes/enpa-sa-00003.html)
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 31 Mar 2002 21:45:11 +0200
+
+ethereal (0.9.2-3) unstable; urgency=low
+
+  * debian/rules: fixed typo that could have caused snmp not to be built.
+    (closes: #140147) This would happen if 1) built from the CVS tree and 2)
+    built on a system without libsnmp-dev ("impossible" since we build-depend
+    on it). Anyway it is fixed for correctness.
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 27 Mar 2002 14:00:31 +0100
+
+ethereal (0.9.2-2) unstable; urgency=low
+
+  * Added libwiretap.a to ethereal-dev (closes: #137971)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 12 Mar 2002 11:59:04 +0100
+
+ethereal (0.9.2-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Tue,  5 Mar 2002 10:30:24 +0100
+
+ethereal (0.9.1-8) unstable; urgency=low
+
+  * debian/control: changed ethereal-dev section to devel.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 25 Feb 2002 14:50:49 +0100
+
+ethereal (0.9.1-7) unstable; urgency=low
+
+  * debian/control: changed ethereal-dev Depends line to use omniidl-python
+    and no omniorb.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 25 Feb 2002 13:47:42 +0100
+
+ethereal (0.9.1-6) unstable; urgency=low
+
+  * debian/control: fix Depends line for ethereal-dev (added libpcap-dev)
+  * idl2eth: added PYTHONPATH so that it runs.
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 18 Feb 2002 11:48:01 +0100
+
+ethereal (0.9.1-5) unstable; urgency=low
+
+  * debian/rules: added --disable-ssl so that ethereal is not built with
+    ssl support and may be uploaded to main. (closes: #134273)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 18 Feb 2002 09:33:30 +0100
+
+ethereal (0.9.1-4) unstable; urgency=low
+
+  * debian/rules: added forgotten header files to ethereal-dev.
+    (really closes: #105916)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 15 Feb 2002 10:12:15 +0100
+
+ethereal (0.9.1-3) unstable; urgency=low
+
+  * debian/rules: after the quick and dirty repackaging of 0.9.1-1 this one
+    should be much better: 4 packages: ethereal-common, ethereal, tethereal
+    and etherel-dev (last three depending on ethereal-common).
+    This should address Christian Kurz remarks.
+       (closes: #133798, #133796, #133806)
+    This should also please W. Borgert. (closes: #105916)
+
+ -- Frederic Peters <fpeters@debian.org>  Wed, 13 Feb 2002 20:36:12 +0100
+
+ethereal (0.9.1-2) unstable; urgency=low
+
+  * debian/control: fixed typo in tethereal description (closes: #133019)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri,  8 Feb 2002 23:55:49 +0100
+
+ethereal (0.9.1-1) unstable; urgency=low
+
+  * New upstream release.
+  * Fixed protocol hierarchy display (closes: #131676)
+  * It is possible to see TOS fields instead of DS fields in IP header.
+    (option in preferences dialog) (closes: #121046)
+  * debian/rules: totally revamped build process: create an additional
+    tethereal package that doesn't depend on GTK+ (closes: #103488)
+    It is not yet perfect but I'm working on it...
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 28 Jan 2002 18:25:25 +0100
+
+ethereal (0.9.0-1) unstable; urgency=low
+
+  * New upstream release.
+  * Upstream fixed SNMP bugs (closes: #114361, #119580)
+  * Upstream fixed Sender->Receiver bug (closes: #112327)
+  * debian/copyright: fixed 'license' spelling.
+  * debian/rules: fixed 'clean' target to remove temporary files.
+  * debian/rules: moved $sysconfdir to /usr/share/ethereal since $sysconfdir
+    is not used here to store config files. (closes: #127638)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  3 Jan 2002 19:43:18 +0100
+
+ethereal (0.8.20-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 19 Oct 2001 10:49:35 +0200
+
+ethereal (0.8.19-2) unstable; urgency=low
+
+  * debian/rules: added call to libtoolize so that it compiles on hppa.
+    (closes: #108662)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon, 17 Sep 2001 14:23:34 +0200
+
+ethereal (0.8.19-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/control: improved description of package. (closes: #104744)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 14 Jul 2001 11:57:12 +0200
+
+ethereal (0.8.17-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 13 Apr 2001 13:33:35 +0200
+
+ethereal (0.8.16-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  8 Mar 2001 09:07:34 +0100
+
+ethereal (0.8.15-2) unstable; urgency=low
+
+  * Rebuilt against libsnmp4.2 (closes: #83720)
+  * It is possible to not go in promiscuous mode (-p) (actually it was for
+    some time...) (closes: #34376)
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 27 Jan 2001 13:39:05 +0100
+
+ethereal (0.8.15-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 13 Jan 2001 19:36:26 +0100
+
+ethereal (0.8.14-2) unstable; urgency=low
+
+  * Fix for the socks dissector. (closes: #81164)
+    (patch by Jeff Foster <jfoste@woodward.com>)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 11 Jan 2001 00:27:02 +0100
+
+ethereal (0.8.14-1) unstable; urgency=low
+
+  * New upstream release.
+  * Officially fixes the buffer overflow exploit mentioned below (as well
+    as other possible ones)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 21 Nov 2000 22:48:16 +0100
+
+ethereal (0.8.13-3) unstable; urgency=low
+
+  * Fixed possible buffer overflow exploit in packet-afs.c (I could not
+    reproduce it so I don't know if my fix really works, please test it)
+    (exploit is on http://www.hacksware.com)
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 21 Nov 2000 22:47:59 +0100
+
+ethereal (0.8.13-2) unstable; urgency=low
+
+  * Rebuilt against XFree86 4.0 libs (now that I'm allowed to...)
+  * Rebuilt against zlibg1 1.1.13-1 that has a correct shlibs file
+    (closes: #76533, #76552)
+  
+ -- Frederic Peters <fpeters@debian.org>  Fri, 10 Nov 2000 17:39:40 +0100
+
+ethereal (0.8.13-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sun, 29 Oct 2000 23:58:38 +0100
+
+ethereal (0.8.12-1) unstable; urgency=low
+
+  * New upstream release.
+  * Patch for SRVLOC frames has been applied upstrem.
+  
+ -- Frederic Peters <fpeters@debian.org>  Mon, 18 Sep 2000 10:22:27 +0200
+
+ethereal (0.8.11-1) unstable; urgency=low
+
+  * New upstream release.
+  * Applied patch to fix hang on some SRVLOC frames (closes: #68024)
+  
+ -- Frederic Peters <fpeters@debian.org>  Thu, 10 Aug 2000 21:06:52 +0200
+
+ethereal (0.8.10-1) unstable; urgency=low
+
+  * New upstream release.
+  * Added debhelper to Build-depends (closes: #66391)
+  
+ -- Frederic Peters <fpeters@debian.org>  Tue, 11 Jul 2000 22:36:45 +0200
+
+ethereal (0.8.9-2) unstable; urgency=low
+
+  * Updated Build-depends to match libsnmp (closes: #66018) (it's the same
+    entry as for 0.8.7-2; I need some sleep)
+  
+ -- Frederic Peters <fpeters@debian.org>  Thu, 22 Jun 2000 23:59:29 +0200
+
+ethereal (0.8.9-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Tue, 20 Jun 2000 14:17:00 +0200
+
+ethereal (0.8.8-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Wed, 10 May 2000 17:20:36 +0200
+
+ethereal (0.8.7-2) unstable; urgency=low
+
+  * Updated Build-depends to match libsnmp (closes: #63753)
+  
+ -- Frederic Peters <fpeters@debian.org>  Mon,  8 May 2000 19:02:29 +0200
+
+ethereal (0.8.7-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Mon, 17 Apr 2000 18:41:21 +0200
+
+ethereal (0.8.6-1) unstable; urgency=low
+
+  * New upstream release.
+  * Linked against libsnmp4.1 (closes: #62324)
+  
+ -- Frederic Peters <fpeters@debian.org>  Fri, 14 Apr 2000 19:45:53 +0200
+
+ethereal (0.8.4-1) unstable; urgency=low
+
+  * New upstream release.
+  * Applied fix for correct decapsulation of PPP frames (closes: #59663)
+    (patch provided by Thomas Quinot <thomas@cuivre.fr.eu.org>)
+  
+ -- Frederic Peters <fpeters@debian.org>  Sun,  5 Mar 2000 20:04:11 +0100
+
+ethereal (0.8.3-1) unstable; urgency=low
+
+  * New upstream release.
+  * Checked PPTP problems (fix was introduced in 0.8.2) (closes: #55347)
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat,  5 Feb 2000 23:51:26 +0100
+
+ethereal (0.8.2-2) unstable; urgency=low
+
+  * debian/control: fixed Build-Depends line (closes: #56707)
+  
+ -- Frederic Peters <fpeters@debian.org>  Mon, 31 Jan 2000 19:29:21 +0100
+
+ethereal (0.8.2-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat, 29 Jan 2000 01:53:50 +0100
+
+ethereal (0.8.1-2) unstable; urgency=low
+
+  * debian/control: added Build-Depends
+  * debian/control: modified description to match the README file
+  * debian/rules: added --disable-static to ./configure
+  * compiled with SNMP support (through libsnmp)
+  
+ -- Frederic Peters <fpeters@debian.org>  Thu, 20 Jan 2000 18:30:40 +0100
+ethereal (0.8.1-1) unstable; urgency=low
+
+  * New upstream release.
+  * Fixed duplicate manpage installation. (closes: #55438)
+  
+ -- Frederic Peters <fpeters@debian.org>  Wed, 19 Jan 2000 09:29:56 +0100
+
+ethereal (0.8.0-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat,  1 Jan 2000 23:50:44 +0100
+
+ethereal (0.7.9-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat, 25 Dec 1999 00:55:00 +0100
+
+ethereal (0.7.7-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Fri, 29 Oct 1999 14:09:01 +0200
+
+ethereal (0.7.3-2) unstable; urgency=low
+
+  * Fixed debian/rules to work with the new debhelper that create FHS compliant
+    packages. (Fixes: #44613)
+  
+ -- Frederic Peters <fpeters@debian.org>  Thu,  9 Sep 1999 18:29:12 +0200
+
+ethereal (0.7.3-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sun,  5 Sep 1999 20:06:10 +0200
+
+ethereal (0.7.2-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat, 14 Aug 1999 18:32:28 +0200
+ethereal (0.7.1-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat,  7 Aug 1999 16:29:03 +0200
+ethereal (0.6.3-2) unstable; urgency=low
+
+  * Renamed NEWS to changelog since this is the upstream ChangeLog
+    (fixes bug #41908)
+  
+ -- Frederic Peters <fpeters@debian.org>  Tue, 27 Jul 1999 20:19:28 +0200
+
+ethereal (0.6.3-1) unstable; urgency=low
+
+  * New upstream release.
+  * Moved directories to comply with FHS (and Standards 3.0.0)
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat, 24 Jul 1999 00:36:46 +0200
+
+ethereal (0.6.2-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Tue, 25 May 1999 16:47:08 +0200
+
+ethereal (0.6.1-1) unstable; urgency=low
+
+  * New upstream release.
+  
+ -- Frederic Peters <fpeters@debian.org>  Sun,  2 May 1999 23:30:38 +0200
+
+ethereal (0.5.1-3) unstable; urgency=low
+
+  * Fixed package building (Bug#35657 (report and patch from bartw@xs4all.nl)
+  
+ -- Frederic Peters <fpeters@debian.org>  Sat, 10 Apr 1999 19:20:29 +0200
+
+ethereal (0.5.1-2) unstable; urgency=low
+
+  * Compiled against libgtk1.2
+  * Moved /usr/etc/manuf to /etc/manuf (it's now lintian clean)
+
+ -- Frederic Peters <fpeters@debian.org>  Mon,  8 Mar 1999 22:33:04 +0100
+
+ethereal (0.5.1-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat,  9 Jan 1999 16:51:28 +0100
+
+ethereal (0.5.0-2) unstable; urgency=low
+
+  * Fixed package building (Bug#30110)
+
+ -- Frederic Peters <fpeters@debian.org>  Thu,  3 Dec 1998 13:15:53 +0100
+
+ethereal (0.5.0-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 24 Nov 1998 16:04:15 +0100
+
+ethereal (0.4.0-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 17 Oct 1998 17:20:01 +0200
+
+ethereal (0.3.17-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Frederic Peters <fpeters@debian.org>  Tue, 29 Sep 1998 20:01:11 +0200
+
+ethereal (0.3.16-2) unstable; urgency=low
+
+  * New versions aren't just for Alpha people :) (fixes #26914)
+
+ -- Frederic Peters <fpeters@debian.org>  Fri, 25 Sep 1998 17:03:39 +0200
+
+ethereal (0.3.16-1) unstable; urgency=low
+
+  * New upstream version
+
+ -- Frederic Peters <fpeters@debian.org>  Sat, 19 Sep 1998 10:55:48 +0200
+
+ethereal (0.3.15-1.1) unstable; urgency=low
+
+  * non-maintainer upload for Alpha
+  * GTK cflags ans library flags were not passed to the compiler.
+
+ -- Paul Slootman <paul@debian.org>  Mon, 21 Sep 1998 22:49:32 +0200
+
+ethereal (0.3.15-1) unstable; urgency=low
+
+  * Initial Release.
+
+ -- Frederic Peters <fpeters@debian.org>  Sun, 13 Sep 1998 23:05:47 +0200
 
- -- Wireshark Self-made package <wireshark@example.com>  Wed, 27 Jan 2010 00:00:00 +0000
index 1e8b314..ec63514 100644 (file)
@@ -1 +1 @@
-6
+9
index b4cbb14..69c518c 100644 (file)
@@ -1,55 +1,50 @@
 Source: wireshark
 Section: net
 Priority: optional
-Maintainer: Wireshark Self-made package <wireshark@example.com>
-X-Orig-Maintainer: Frederic Peters <fpeters@debian.org>
-X-Orig-Uploaders: Joost Yervante Damad <andete@debian.org>
-Standards-Version: 3.8.1.0
-Homepage: http://www.wireshark.org
-Build-Depends: libgtk2.0-dev (>=2.12.0-0), libpcap0.8-dev, flex, libz-dev, dpatch, debhelper (>= 6), libtool, python, automake1.9, autoconf, autotools-dev, libc-ares-dev, xsltproc, docbook-xsl (>= 1.64.1.0-0), libcap-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], bison, libgnutls-dev, python-support (>= 0.3), portaudio19-dev, libkrb5-dev, liblua5.1-0-dev, libsmi2-dev, libgeoip-dev
+Maintainer: Balint Reczey <balint@balintreczey.hu>
+DM-Upload-Allowed: yes
+Standards-Version: 3.9.3
+Build-Depends: libgtk2.0-dev (>=2.4.0-0), libpcap0.8-dev, flex, libz-dev, debhelper (>= 9), po-debconf, libtool, python (>= 2.6.6-3~), python-ply, automake, autoconf, autotools-dev, libc-ares-dev, xsltproc, docbook-xsl (>= 1.64.1.0-0), libxml2-utils, libpcre3-dev, libcap2-dev [linux-any] | libcap-dev (>= 2.17) [linux-any], bison, libgnutls-dev, portaudio19-dev, libkrb5-dev, liblua5.1-0-dev, libsmi2-dev, libgeoip-dev, dpkg-dev (>= 1.16.1~)
 Build-Conflicts: libsnmp4.2-dev, libsnmp-dev
-XS-Python-Version: all
+Vcs-Svn: svn://svn.debian.org/svn/collab-maint/ext-maint/wireshark/trunk
+Vcs-Browser: http://svn.debian.org/wsvn/collab-maint/ext-maint/wireshark/trunk/
+Homepage: http://www.wireshark.org/
 
 Package: wireshark-common
 Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, libwireshark2 (>= ${binary:Version}), libwiretap2 (>= ${binary:Version}), debconf, libcap2-bin [linux-any]
 Recommends: wireshark (>= ${binary:Version}) | tshark (>= ${binary:Version})
-Suggests: snmp-mibs-downloader
-Replaces: ethereal-common (<< 0.99.2-0)
-Conflicts: ethereal-common (<< 0.99.2-0)
-Description: network traffic analyser (common files)
- Wireshark is a network traffic analyzer, or "sniffer", for Unix and
- Unix-like operating systems. A sniffer is a tool used to capture 
- packets off the wire. Wireshark decodes numerous protocols (too many
- to list).
+Replaces: ethereal-common (<< 1.0.0-3)
+Conflicts: ethereal-common (<< 1.0.0-3)
+Description: network traffic analyzer - common files
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
  .
  This package provides files common to both wireshark (the GTK+ version)
  and tshark (the console version).
 
 Package: wireshark
 Architecture: any
-Depends: ${shlibs:Depends}, wireshark-common (= ${binary:Version})
-Recommends: gksu
-Replaces: ethereal (<< 0.99.2-0)
-Conflicts: ethereal (<< 0.99.2-0)
-Description: network traffic analyzer
- Wireshark is a network traffic analyzer, or "sniffer", for Unix and
- Unix-like operating systems. A sniffer is a tool used to capture 
- packets off the wire. Wireshark decodes numerous protocols (too many
- to list).
+Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version})
+Replaces: ethereal (<< 1.0.0-3)
+Conflicts: ethereal (<< 1.0.0-3)
+Description: network traffic analyzer - GTK+ version
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
  .
- This package provides wireshark (the GTK+ version)
+ This package provides the GTK+ version of wireshark.
 
 Package: tshark
 Architecture: any
-Depends: ${shlibs:Depends}, wireshark-common (= ${binary:Version})
-Replaces: tethereal (<< 0.99.2-0)
-Conflicts: tethereal (<< 0.99.2-0)
-Description: network traffic analyzer (console)
- Wireshark is a network traffic analyzer, or "sniffer", for Unix and
- Unix-like operating systems. A sniffer is a tool used to capture 
- packets off the wire. Wireshark decodes numerous protocols (too many
- to list).
+Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version})
+Replaces: tethereal (<< 1.0.0-3)
+Conflicts: tethereal (<< 1.0.0-3)
+Description: network traffic analyzer - console version
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
  .
  This package provides the console version of wireshark, named
  "tshark".
@@ -57,16 +52,163 @@ Description: network traffic analyzer (console)
 Package: wireshark-dev
 Architecture: any
 Section: devel
-Depends: ${shlibs:Depends}, omniidl4 (>= 4.0.1-2), libpcap0.8-dev, libtool, libglib2.0-dev, ${python:Depends}, snacc, autotools-dev, debhelper, cdbs, automake1.9, autoconf
-Replaces: ethereal-dev (<< 0.99.2-0)
-Conflicts: ethereal-dev (<< 0.99.2-0)
-XB-Python-Version: ${python:Versions}
-Description: network traffic analyser (development tools)
- Wireshark is a network traffic analyzer, or "sniffer", for Unix and
- Unix-like operating systems. A sniffer is a tool used to capture 
- packets off the wire. Wireshark decodes numerous protocols (too many
- to list).
+Depends: ${misc:Depends}, omniidl (>= 4.0.1-2), libpcap0.8-dev, libtool, libglib2.0-dev, ${python:Depends}, python-ply, snacc, autotools-dev, debhelper, cdbs, automake, autoconf, libwireshark-dev, libwiretap-dev
+Replaces: ethereal-dev (<< 1.0.0-3)
+Conflicts: ethereal-dev (<< 1.0.0-3)
+Description: network traffic analyzer - development tools
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
  .
- This package provides idl2wrs and other necessary files to develop
+ This package provides idl2wrs and other files necessary for developing
  new packet dissectors.
 
+Package: wireshark-dbg
+Priority: extra
+Architecture: any
+Section: debug
+Depends: ${misc:Depends}, wireshark-common (= ${binary:Version}) | wireshark (= ${binary:Version}) | tshark (= ${binary:Version})
+Description: network traffic analyzer - debug symbols
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
+ .
+ This package contains stripped debugging symbols for all Wireshark
+ programs and libraries.
+
+Package: wireshark-doc
+Priority: extra
+Architecture: all
+Section: doc
+Depends: ${misc:Depends}
+Description: network traffic analyzer - documentation
+ Wireshark is a network "sniffer" - a tool that captures and analyzes
+ packets off the wire. Wireshark can decode too many protocols to list
+ here.
+ .
+ This package contains Wireshark User's guide, Wireshark Developer's Guide
+ and the Lua Reference.
+
+Package: libwireshark2
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, libwireshark-data (>= ${source:Version}), libwsutil2 (>= ${source:Version})
+Suggests: wireshark-doc (>= ${source:Version})
+Conflicts: wireshark-common (<< 1.4.0~rc2-1)
+Replaces: wireshark-common (<< 1.4.0~rc2-1)
+Description: network packet dissection library -- shared library
+ The libwireshark library provides the network packet dissection services 
+ developed by the Wireshark project.
+
+Package: libwsutil2
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Conflicts: wireshark-common (<< 1.4.0~rc2-1), libwireshark1 (<< 1.4.2-2)
+Replaces: wireshark-common (<< 1.4.0~rc2-1), libwireshark1 (<< 1.4.2-2)
+Description: network packet dissection utilities library -- shared library
+ The libwsutil library provides utility functions for libwireshark2.
+
+Package: libwsutil-dev
+Section: libdevel
+Architecture: any
+Depends: ${misc:Depends} , libwsutil2 (= ${binary:Version})
+Conflicts: wireshark-common (<< 1.4.0~rc2-1), libwireshark-dev (<< 1.4.2-2)
+Replaces: wireshark-common (<< 1.4.0~rc2-1), libwireshark-dev (<< 1.4.2-2)
+Description: network packet dissection utilities library -- shared library
+ The libwsutil library provides utility functions for libwireshark2.
+ .
+ This package contains the static library and the C header files that are
+ needed for applications to use the libwsutil library.
+
+Package: libwireshark-data
+Section: libs
+Architecture: all
+Depends: ${misc:Depends}
+Conflicts: wireshark-common (<< 1.4.0~rc2-1)
+Replaces: wireshark-common (<< 1.4.0~rc2-1)
+Suggests: snmp-mibs-downloader
+Description: network packet dissection library -- data files
+ The libwireshark library provides the network packet dissection services 
+ developed by the Wireshark project.
+ .
+ This package contains the platform independent files.
+
+Package: libwireshark-dev
+Section: libdevel
+Depends: ${misc:Depends}, libwsutil-dev, libwireshark2 (= ${binary:Version})
+Conflicts: wireshark-dev (<< 1.4.0~rc2-1)
+Replaces: wireshark-dev (<< 1.4.0~rc2-1)
+Architecture: any
+Description: network packet dissection library -- development files
+ The "libwireshark" library provides the network packet dissection services
+ developed by the Wireshark project.
+ .
+ This package contains the static library and the C header files that are
+ needed for applications to use libwireshark services.
+
+Package: libwiretap2
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Conflicts: wireshark-common (<< 1.4.0~rc2-1)
+Description: network packet capture library -- shared library
+ Wiretap, part of the Wireshark project, is a library that allows one to
+ read and write several packet capture file formats.
+ .
+ Supported formats are: 
+  * Libpcap
+  * Sniffer
+  * LANalyzer
+  * Network Monitor
+  * "snoop"
+  * "iptrace"
+  * Sniffer Basic (NetXRay)/Windows Sniffer Pro
+  * RADCOM WAN/LAN Analyzers
+  * Lucent/Ascend access products
+  * HP-UX nettl
+  * Toshiba ISDN Router
+  * ISDN4BSD "i4btrace" utility
+  * Cisco Secure Intrustion Detection System iplogging facility
+  * pppd logs (pppdump-format files)
+  * VMS TCPTRACE
+  * DBS Etherwatch (text format)
+  * Catapult DCT2000 (.out files)
+ .
+ Wiretap's shortcomings are: no filter capability and no support for packet
+ capture.
+
+Package: libwiretap-dev
+Section: libdevel
+Depends: ${misc:Depends}, libwiretap2 (= ${binary:Version})
+Conflicts: wireshark-dev (<< 1.4.0~rc2-1)
+Replaces: wireshark-dev (<< 1.4.0~rc2-1)
+Architecture: any
+Description: network packet capture library -- development files
+ Wiretap, part of the Wireshark project, is a library that allows one to
+ read and write several packet capture file formats.
+ .
+ Supported formats are: 
+  * Libpcap
+  * Sniffer
+  * LANalyzer
+  * Network Monitor
+  * "snoop"
+  * "iptrace"
+  * Sniffer Basic (NetXRay)/Windows Sniffer Pro
+  * RADCOM WAN/LAN Analyzers
+  * Lucent/Ascend access products
+  * HP-UX nettl
+  * Toshiba ISDN Router
+  * ISDN4BSD "i4btrace" utility
+  * Cisco Secure Intrustion Detection System iplogging facility
+  * pppd logs (pppdump-format files)
+  * VMS TCPTRACE
+  * DBS Etherwatch (text format)
+  * Catapult DCT2000 (.out files)
+ .
+ Wiretap's shortcomings are: no filter capability and no support for packet
+ capture.
+ .
+ This package contains the static library and the C header files.
+
index 7517685..5f041c4 100644 (file)
@@ -27,7 +27,7 @@ Wireshark is copyright (c) 1998-2006 Gerald Combs.
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301,  USA.
 
-On Debian systems the GNU GPL may be viewed in /usr/share/common-licenses/GPL.
+On Debian systems the GNU GPL (v2) may be viewed in /usr/share/common-licenses/GPL-2.
 
 Wireshark and the "fin" logo are trademarks of Gerald Combs.
 
@@ -68,6 +68,7 @@ LGPL
 
 mkstemp.c: LGPL, from GNU C Library
 mkstemp.h: idem
+strcasecmp.c: idem
 strncasecmp.c: idem
 strptime.c: idem
 ps.c: idem
index e772481..a49457a 100644 (file)
@@ -1 +1,2 @@
 usr/bin
+usr/share/lintian/overrides
diff --git a/debian/ethereal-common.NEWS b/debian/ethereal-common.NEWS
new file mode 100644 (file)
index 0000000..050bbe3
--- /dev/null
@@ -0,0 +1,13 @@
+wireshark (0.99.2-1) unstable; urgency=low
+
+  Same developers, same code, different name. The Ethereal network protocol
+  analyzer has changed its name to Wireshark.
+
+  Name changes:
+   - ethereal  -> wireshark
+   - tethereal -> tshark
+   - idl2eth   -> idl2wrs
+   
+  See http://www.wireshark.org/news/20060607.html for more information.
+
+ -- Frederic Peters <fpeters@debian.org>  Thu, 12 Oct 2006 15:35:25 +0200
diff --git a/debian/libwireshark-data.files b/debian/libwireshark-data.files
new file mode 100644 (file)
index 0000000..a3aeb06
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/share/wireshark/*
+/etc/wireshark/init.lua
diff --git a/debian/libwireshark-dev.files b/debian/libwireshark-dev.files
new file mode 100644 (file)
index 0000000..5946264
--- /dev/null
@@ -0,0 +1,3 @@
+/usr/lib/libwireshark.so
+/usr/include/wireshark/*.h
+/usr/include/wireshark/epan/*
diff --git a/debian/libwireshark-dev.header-files b/debian/libwireshark-dev.header-files
new file mode 100644 (file)
index 0000000..15db820
--- /dev/null
@@ -0,0 +1,8 @@
+color.h
+config.h
+register.h
+epan/*.h
+epan/crypt/*.h
+epan/dfilter/*.h
+epan/dissectors/*.h
+epan/ftypes/*.h
diff --git a/debian/libwireshark2.files b/debian/libwireshark2.files
new file mode 100644 (file)
index 0000000..34f4f97
--- /dev/null
@@ -0,0 +1,3 @@
+/usr/lib/libwireshark.so.2
+/usr/lib/libwireshark.so.2.*
+/usr/lib/wireshark/libwireshark2/plugins/*.so
diff --git a/debian/libwireshark2.lintian-overrides b/debian/libwireshark2.lintian-overrides
new file mode 100644 (file)
index 0000000..a716e07
--- /dev/null
@@ -0,0 +1,12 @@
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/coseventcomm.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/cosnaming.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/docsis.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/interlink.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/m2m.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/parlay.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/stats_tree.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/tango.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/unistim.so
+libwireshark2 binary: hardening-no-fortify-functions usr/lib/wireshark/libwireshark2/plugins/unistim.so
+libwireshark2 binary: hardening-no-stackprotector usr/lib/wireshark/libwireshark2/plugins/wimax.so
+libwireshark2 binary: hardening-no-fortify-functions usr/lib/wireshark/libwireshark2/plugins/wimax.so
diff --git a/debian/libwireshark2.shlibs b/debian/libwireshark2.shlibs
new file mode 100644 (file)
index 0000000..60f84cb
--- /dev/null
@@ -0,0 +1 @@
+libwireshark 2 libwireshark2 (>= 1.8.0~rc1-1)
diff --git a/debian/libwiretap-dev.files b/debian/libwiretap-dev.files
new file mode 100644 (file)
index 0000000..f308dae
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/lib/libwiretap.so
+/usr/include/wireshark/wiretap/*
diff --git a/debian/libwiretap-dev.header-files b/debian/libwiretap-dev.header-files
new file mode 100644 (file)
index 0000000..728795b
--- /dev/null
@@ -0,0 +1 @@
+wiretap/*.h
diff --git a/debian/libwiretap2.docs b/debian/libwiretap2.docs
new file mode 100644 (file)
index 0000000..0c48271
--- /dev/null
@@ -0,0 +1 @@
+wiretap/README
diff --git a/debian/libwiretap2.files b/debian/libwiretap2.files
new file mode 100644 (file)
index 0000000..963de5f
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/lib/libwiretap.so.2
+/usr/lib/libwiretap.so.2.*
diff --git a/debian/libwiretap2.shlibs b/debian/libwiretap2.shlibs
new file mode 100644 (file)
index 0000000..9df3046
--- /dev/null
@@ -0,0 +1 @@
+libwiretap 2 libwiretap2 (>= 1.8.0~rc1-1)
diff --git a/debian/libwsutil-dev.files b/debian/libwsutil-dev.files
new file mode 100644 (file)
index 0000000..dada1d1
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/lib/libwsutil.so
+/usr/include/wireshark/wsutil/*
diff --git a/debian/libwsutil-dev.header-files b/debian/libwsutil-dev.header-files
new file mode 100644 (file)
index 0000000..2a9bb76
--- /dev/null
@@ -0,0 +1 @@
+wsutil/*.h
diff --git a/debian/libwsutil2.files b/debian/libwsutil2.files
new file mode 100644 (file)
index 0000000..7304555
--- /dev/null
@@ -0,0 +1,2 @@
+/usr/lib/libwsutil.so.2
+/usr/lib/libwsutil.so.2.0.0
diff --git a/debian/libwsutil2.lintian-overrides b/debian/libwsutil2.lintian-overrides
new file mode 100644 (file)
index 0000000..29d8d85
--- /dev/null
@@ -0,0 +1,2 @@
+libwsutil2 binary: hardening-no-stackprotector usr/lib/libwsutil.so.2.0.0
+
diff --git a/debian/libwsutil2.shlibs b/debian/libwsutil2.shlibs
new file mode 100644 (file)
index 0000000..deca153
--- /dev/null
@@ -0,0 +1 @@
+libwsutil 2 libwsutil2 (>= 1.8.0~rc1-1)
diff --git a/debian/license-text-about-dialog b/debian/license-text-about-dialog
new file mode 100644 (file)
index 0000000..f2264b5
--- /dev/null
@@ -0,0 +1,16 @@
+Wireshark is distributed under the GNU GPL version 2.  There are no
+restrictions on its use.  There are significant restrictions on its
+distribution.
+
+Parts of Wireshark can be built and distributed as libraries.  These
+parts are still covered by the GPL, and NOT by the Lesser General Public
+License or any other license.
+
+If you create a combined work using all or part of Wireshark, then your
+combined work must be released under a license compatible with the GPL.
+
+...and don't get us started on trademarks.
+
+The full text of the GNU GPL may be viewed in
+/usr/share/common-licenses/GPL-2.
+
diff --git a/debian/patches/01_idl2deb.patch b/debian/patches/01_idl2deb.patch
new file mode 100755 (executable)
index 0000000..f3653d3
--- /dev/null
@@ -0,0 +1,387 @@
+Description: idl2deb - create Debian packages from idl2wrs modules
+Forwarded: not-needed
+Author: W. Borgert <debacle@debian.org>
+
+Index: b/idl2deb
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ b/idl2deb  2010-02-15 17:24:57.000000000 +0100
+@@ -0,0 +1,216 @@
++#!/usr/bin/env python
++
++# idl2deb - quick hack by W. Martin Borgert <debacle@debian.org> to create
++# Debian GNU/Linux packages from idl2wrs modules for Wireshark.
++# Copyright 2003, 2008, W. Martin Borgert
++
++# Makefile.am and configure.ac code by:
++# Copyright 2001, Ericsson Inc.
++# Frank Singleton <frank.singleton@ericsson.com>
++#
++# Wireshark - Network traffic analyzer
++# By Gerald Combs <gerald@wireshark.com>
++# Copyright 1998 Gerald Combs
++
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License
++# as published by the Free Software Foundation; either version 2
++# of the License, or (at your option) any later version.
++# 
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++# GNU General Public License for more details.
++# 
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
++
++import optparse
++import os
++import string
++import sys
++import time
++
++scriptinfo = """idl2deb version 2008-03-10
++Copyright 2003, 2008, W. Martin Borgert
++Free software, released under the terms of the GPL."""
++
++def bootstrap():
++    """Generate Makefile.in and configure script."""
++    os.system("aclocal")
++    os.system("autoconf")
++    os.system("libtoolize --automake --copy --force")
++    os.system("automake --add-missing --copy --foreign")
++
++def create_file(preserve, filename, content, mode = None):
++    """Create a file with given content."""
++    if preserve and os.path.isfile(filename):
++        return
++    f = open(filename, 'w')
++    f.write(content)
++    f.close()
++    if mode:
++        os.chmod(filename, mode)
++
++def create_files(version, deb, email, idl, name, preserve, iso, rfc):
++    """Create all files for the .deb build process."""
++    base = os.path.basename(idl.lower().split(".idl")[0])
++    create_file(preserve, "Makefile.am", """#
++
++plugindir = @plugindir@
++
++plugin_LTLIBRARIES = %s.la
++%s_la_SOURCES = packet-%s.c
++%s_la_LDFLAGS = -module -avoid-version
++
++GLIB_CFLAGS = `pkg-config --cflags glib-2.0`
++GLIB_LIBS = `pkg-config --libs glib-2.0`
++BUILT_SOURCES = packet-%s.c
++INCLUDES = -DHAVE_CONFIG -DHAVE_SYS_TYPES_H -DHAVE_SYS_TIME_H \\
++    -DHAVE_STDARG_H -D_U_=\"__attribute__((unused))\" \\
++    -I/usr/include/wireshark -DWS_VAR_IMPORT=extern $(GLIB_CFLAGS)
++LDADD = $(GLIB_LIBS)
++
++# Libs must be cleared, or else libtool won't create a shared module.
++# If your module needs to be linked against any particular libraries,
++# add them here.
++LIBS =
++
++%s_la_DEPENDENCIES = packet-%s-static.o
++
++packet-%s-static.o: packet-%s.c
++      $(LTCOMPILE) -c -o packet-%s-static.o \\
++        -D__WIRESHARK_STATIC__ packet-%s.c
++
++packet-%s.c: """  % ((base,) * 12) + idl + """
++      $(IDL2WRS) -I. $< > $@
++""")
++
++    create_file(preserve, "configure.ac", """AC_INIT(%s, 1.0)
++AC_PROG_LIBTOOL
++AM_INIT_AUTOMAKE
++AM_MAINTAINER_MODE
++AC_PROG_CC
++AC_STDC_HEADERS
++AC_PROG_INSTALL
++AC_SUBST(CFLAGS)
++AC_SUBST(CPPFLAGS)
++AC_SUBST(LDFLAGS)
++PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.2.2)
++AC_SUBST(GLIB_CFLAGS)
++AC_SUBST(GLIB_LIBS)
++IDL2WRS=\"`type -p idl2wrs`\"
++AC_SUBST(IDL2WRS)
++WIRESHARK_VERSION=\"%s\"
++plugindir=\"$libdir/wireshark/plugins/$WIRESHARK_VERSION\"
++AC_SUBST(plugindir)
++AC_OUTPUT([Makefile])
++""" % (base, version))
++
++    if not os.path.isdir("debian"):
++        os.mkdir("debian")
++
++    create_file(preserve, "debian/rules", """#!/usr/bin/make -f
++
++include /usr/share/cdbs/1/rules/debhelper.mk
++include /usr/share/cdbs/1/class/autotools.mk
++
++PREFIX=`pwd`/debian/wireshark-giop-%s
++
++binary-post-install/wireshark-giop-%s::
++      rm -f $(PREFIX)/usr/lib/wireshark/plugins/%s/*.a
++""" % (base, base, version), 0755)
++
++    create_file(preserve, "debian/control", """Source: wireshark-giop-%s
++Section: net
++Priority: optional
++Maintainer: %s <%s>
++Standards-Version: 3.6.1.0
++Build-Depends: wireshark-dev, autotools-dev, debhelper, cdbs
++
++Package: wireshark-giop-%s
++Architecture: any
++Depends: wireshark (= %s), ${shlibs:Depends}
++Description: GIOP dissector for CORBA interface %s
++ This package provides a dissector for GIOP (General Inter-ORB
++ Protocol) for the Wireshark protocol analyser.  It decodes the CORBA
++ (Common Object Request Broker Architecture) interfaces described
++ in the IDL (Interface Definition Language) file '%s.idl'.
++""" % (base, name, email, base, deb, base, base))
++
++    create_file(preserve, "debian/changelog",
++            """wireshark-giop-%s (0.0.1-1) unstable; urgency=low
++
++  * Automatically created package.
++
++ -- %s <%s>  %s
++""" % (base, name, email, rfc))
++
++    create_file(preserve, "debian/copyright",
++            """This package has been created automatically by idl2deb on
++%s for Debian GNU/Linux.
++
++Wireshark: http://www.wireshark.org/
++
++Copyright:
++
++GPL, as evidenced by existence of GPL license file \"COPYING\".
++(the GNU GPL may be viewed on Debian systems in
++/usr/share/common-licenses/GPL)
++""" % (iso))
++
++def get_wrs_version():
++    """Detect version of wireshark-dev package."""
++    deb = os.popen(
++        "dpkg-query -W --showformat='${Version}' wireshark-dev").read()
++    debv = string.find(deb, "-")
++    if debv == -1: debv = len(deb)
++    version = deb[string.find(deb, ":")+1:debv]
++    return version, deb
++
++def get_time():
++    """Detect current time and return ISO and RFC time string."""
++    currenttime = time.gmtime()
++    return time.strftime("%Y-%m-%d %H:%M:%S +0000", currenttime), \
++           time.strftime("%a, %d %b %Y %H:%M:%S +0000", currenttime)
++
++def main():
++    opts = process_opts(sys.argv)
++    iso, rfc = get_time()
++    version, deb = get_wrs_version()
++    create_files(version, deb,
++                 opts.email, opts.idl, opts.name, opts.preserve,
++                 iso, rfc)
++    bootstrap()
++    os.system("dpkg-buildpackage " + opts.dbopts)
++
++def process_opts(argv):
++    """Process command line options."""
++    parser = optparse.OptionParser(
++        version=scriptinfo,
++        description="""Example:
++%prog -e me@foo.net -i bar.idl -n \"My Name\" -d \"-rfakeroot -uc -us\"""")
++    parser.add_option("-d", "--dbopts",
++                      default="", metavar="opts",
++                      help="options for dpkg-buildpackage")
++    parser.add_option("-e", "--email", metavar="address",
++                      default="invalid@invalid.invalid",
++                      help="use e-mail address")
++    parser.add_option("-i", "--idl", metavar="idlfile",
++                      help="IDL file to use (mandatory)")
++    parser.add_option("-n", "--name", default="No Name",
++                      help="use user name", metavar="name")
++    parser.add_option("-p", "--preserve", action="store_true",
++                      help="do not overwrite files")
++    opts, args = parser.parse_args()
++    if not opts.idl:
++        print "mandatory IDL file parameter missing"
++        sys.exit(1)
++    if not os.access(opts.idl, os.R_OK):
++        print "IDL file not accessible"
++        sys.exit(1)
++    return opts
++
++if __name__ == '__main__':
++    main()
+Index: b/idl2deb.dbk
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ b/idl2deb.dbk      2010-02-15 17:24:57.000000000 +0100
+@@ -0,0 +1,157 @@
++<?xml version='1.0' encoding='ISO-8859-1'?>
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
++"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
++  <!ENTITY command     "<command>idl2deb</command>">
++  <!ENTITY email       "<email>debacle@debian.org</email>">
++  <!ENTITY author      "W. Borgert">
++  <!ENTITY debian      "<productname>Debian GNU/Linux</productname>">
++]>
++
++<refentry>
++  <refentryinfo>
++    <address>
++      &email;
++    </address>
++    <author>
++      <firstname>W.</firstname>
++      <surname>Borgert</surname>
++    </author>
++    <copyright>
++      <year>2003</year>
++      <year>2005</year>
++      <holder>&author;</holder>
++    </copyright>
++    <date>2003-08-17</date>
++    <keywordset>
++      <keyword>CORBA</keyword>
++      <keyword>IDL</keyword>
++      <keyword>Wireshark</keyword>
++    </keywordset>
++    <revhistory>
++      <revision>
++      <revnumber>2003-08-17</revnumber>
++      <date>2003-08-17</date>
++      <authorinitials>debacle</authorinitials>
++      <revremark>First version.</revremark>
++      </revision>
++    </revhistory>
++  </refentryinfo>
++  <refmeta>
++    <refentrytitle>idl2deb</refentrytitle>
++
++    <manvolnum>1</manvolnum>
++  </refmeta>
++  <refnamediv>
++    <refname>idl2deb</refname>
++
++    <refpurpose>create a Debian package for CORBA monitoring from IDL</refpurpose>
++  </refnamediv>
++  <refsynopsisdiv>
++    <cmdsynopsis>
++      &command;
++      <arg><option>-d <replaceable>opts</replaceable></option></arg>
++      <arg><option>--dbopts=<replaceable>opts</replaceable></option></arg>
++      <arg><option>-e <replaceable>address</replaceable></option></arg>
++      <arg><option>--email=<replaceable>address</replaceable></option></arg>
++      <arg>-i <replaceable>idlfile</replaceable></arg>
++      <arg>--idl=<replaceable>idlfile</replaceable></arg>
++      <arg><option>-h</option></arg>
++      <arg><option>--help</option></arg>
++      <arg><option>-n <replaceable>name</replaceable></option></arg>
++      <arg><option>--name=<replaceable>name</replaceable></option></arg>
++      <arg><option>-p</option></arg>
++      <arg><option>--preserve</option></arg>
++      <arg><option>-v</option></arg>
++      <arg><option>--version</option></arg>
++    </cmdsynopsis>
++  </refsynopsisdiv>
++  <refsect1>
++    <title>Description</title>
++
++    <para>This manual page documents briefly the
++      <command>idl2deb</command> command.</para>
++
++    <para>&command; takes an CORBA IDL file as input and creates a
++    Debian package from it.  The package contains a loadable module
++    for the wireshark network analyser.</para>
++  </refsect1>
++  <refsect1>
++    <title>Options</title>
++
++    <variablelist>
++      <varlistentry>
++        <term><option>-d <replaceable>opts</replaceable></option>
++          <option>--dbopts=<replaceable>opts</replaceable></option></term>
++        <listitem>
++          <para>options for dpkg-buildpackage.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-e <replaceable>address</replaceable></option>
++          <option>--email=<replaceable>address</replaceable></option></term>
++        <listitem>
++          <para>use e-mail address.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-i <replaceable>idlfile</replaceable></option>
++          <option>--idl=<replaceable>idlfile</replaceable></option></term>
++        <listitem>
++          <para>IDL file to use (mandatory).</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-h</option>
++          <option>--help</option>
++        </term>
++        <listitem>
++          <para>print help and exit.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-n <replaceable>name</replaceable></option>
++          <option>--name=<replaceable>name</replaceable></option></term>
++        <listitem>
++          <para>use user name.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-p</option>
++          <option>--preserve</option></term>
++        <listitem>
++          <para>do not overwrite files.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-v</option>
++          <option>--version</option></term>
++        <listitem>
++          <para>print version and exit.</para>
++        </listitem>
++      </varlistentry>
++    </variablelist>
++
++    <para>Example:</para>
++
++    <programlisting>/usr/bin/idl2deb -e me@foo.net -i bar.idl \
++-n &quot;My Name&quot; -d &quot;-rfakeroot -uc -us&quot;</programlisting>
++
++  </refsect1>
++  <refsect1>
++    <title>See Also</title>
++
++    <para>A lot of tools are used, which you have to
++    <command>apt-get install</command>: wireshark-dev, python,
++    cdbs, autotools-dev, debhelper, dpkg-dev.</para>
++  </refsect1>
++
++  <refsect1>
++    <title>Copying</title>
++
++    <para>This manual page was written by &author; &email; for
++      &debian; (but may be used by others).  Permission is granted to
++      copy, distribute and/or modify this document under the terms of
++      the GNU General Public License, Version 2 or any later
++      version published by the Free Software Foundation.</para>
++  </refsect1>
++</refentry>
diff --git a/debian/patches/02_asn2deb.patch b/debian/patches/02_asn2deb.patch
new file mode 100755 (executable)
index 0000000..f3ddb56
--- /dev/null
@@ -0,0 +1,392 @@
+Description: asn2deb - create Debian packages from ASN.1 files
+Forwarded: not-needed
+Bug-Debian: http://bugs.debian.org/233603
+Author: W. Borgert <debacle@debian.org>
+
+Index: b/asn2deb
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ b/asn2deb  2010-02-15 17:24:58.000000000 +0100
+@@ -0,0 +1,219 @@
++#!/usr/bin/env python
++
++# asn2deb - quick hack by W. Borgert <debacle@debian.org> to create
++# Debian GNU/Linux packages from ASN.1 files for Wireshark.
++# Copyright 2004, W. Borgert
++
++# ASN.1 module for Wireshark, use of snacc type table:
++# Copyright 2003, Matthijs Melchior <matthijs.melchior@xs4all.nl>
++#
++# Wireshark - Network traffic analyzer
++# By Gerald Combs <gerald@wireshark.com>
++# Copyright 1998 Gerald Combs
++
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License
++# as published by the Free Software Foundation; either version 2
++# of the License, or (at your option) any later version.
++# 
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++# GNU General Public License for more details.
++# 
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
++
++import getopt, os, string, sys, time
++
++scriptinfo = """asn2deb version 2004-02-17
++Copyright 2004, W. Borgert
++Free software, released under the terms of the GPL."""
++
++options = {'asn':      None,
++           'dbopts':   "",
++           'email':    "invalid@invalid.invalid",
++           'help':     0,
++           'name':     "No Name",
++           'preserve': 0,
++           'version':  0}
++
++def bootstrap():
++    """Generate Makefile.in and configure script."""
++    os.system("aclocal-1.7")
++    os.system("autoconf")
++    os.system("automake-1.7 --add-missing --copy --foreign")
++
++def create_file(filename, content, mode = None):
++    """Create a file with given content."""
++    global options
++    if options['preserve'] and os.path.isfile(filename):
++        return
++    f = open(filename, 'w')
++    f.write(content)
++    f.close()
++    if mode:
++        os.chmod(filename, mode)
++
++def create_files(version, deb, email, asn, name, iso, rfc):
++    """Create all files for the .deb build process."""
++    base = asn.lower()[:-5]
++    create_file("Makefile.am", """#
++
++BUILT_SOURCES = %s.tt
++asn1ttdir = $(datadir)/wireshark/asn1
++asn1tt_DATA = %s.tt
++
++%s.tt: """  % ((base,) * 3) + asn + """
++      snacc -u /usr/include/snacc/asn1/asn-useful.asn1 -T $@ $<
++""")
++
++    create_file("configure.ac", """AC_INIT(%s, 1.0)
++AM_INIT_AUTOMAKE
++AM_MAINTAINER_MODE
++AC_PROG_INSTALL
++SNACC=\"`type -p snacc`\"
++AC_SUBST(SNACC)
++dnl WIRESHARK_VERSION=\"%s\"
++dnl plugindir=\"$prefix/share/wireshark/asn.1\"
++dnl AC_SUBST(plugindir)
++AC_OUTPUT([Makefile])
++""" % (base, version))
++
++    if not os.path.isdir("debian"):
++        os.mkdir("debian")
++
++    create_file("debian/rules", """#!/usr/bin/make -f
++
++include /usr/share/cdbs/1/rules/debhelper.mk
++include /usr/share/cdbs/1/class/autotools.mk
++
++PREFIX=`pwd`/debian/wireshark-asn1-%s
++
++binary-post-install/wireshark-asn1-%s::
++      rm -f $(PREFIX)/usr/lib/wireshark/plugins/%s/*.a
++""" % (base, base, version), 0755)
++
++    create_file("debian/control", """Source: wireshark-asn1-%s
++Section: net
++Priority: optional
++Maintainer: %s <%s>
++Standards-Version: 3.6.1.0
++Build-Depends: snacc, autotools-dev, debhelper, cdbs
++
++Package: wireshark-asn1-%s
++Architecture: all
++Depends: wireshark (= %s)
++Description: ASN.1/BER dissector for %s
++ This package provides a type table for decoding BER (Basic Encoding
++ Rules) data over TCP or UDP, described by an ASN.1 (Abstract Syntax
++ Notation 1) file '%s.asn1'.
++""" % (base, name, email, base, deb, base, base))
++
++    create_file("debian/changelog",
++            """wireshark-asn1-%s (0.0.1-1) unstable; urgency=low
++
++  * Automatically created package.
++
++ -- %s <%s>  %s
++""" % (base, name, email, rfc + "\n    (" + iso + ")"))
++
++    create_file("debian/copyright",
++            """This package has been created automatically be asn2deb on
++%s for Debian GNU/Linux.
++
++Wireshark: http://www.wireshark.com/
++
++Copyright:
++
++GPL, as evidenced by existence of GPL license file \"COPYING\".
++(the GNU GPL may be viewed on Debian systems in
++/usr/share/common-licenses/GPL)
++""" % (iso))
++
++def get_wrs_version():
++    """Detect version of wireshark-dev package."""
++    deb = os.popen(
++        "dpkg-query -W --showformat='${Version}' wireshark-dev").read()
++    debv = string.find(deb, "-")
++    if debv == -1: debv = len(deb)
++    version = deb[string.find(deb, ":")+1:debv]
++    return version, deb
++
++def get_time():
++    """Detect current time and return ISO and RFC time string."""
++    currenttime = time.gmtime()
++    return time.strftime("%Y-%m-%d %H:%M:%S +0000", currenttime), \
++           time.strftime("%a, %d %b %Y %H:%M:%S +0000", currenttime)
++
++def main():
++    global options
++    process_opts(sys.argv)
++    iso, rfc = get_time()
++    version, deb = get_wrs_version()
++    create_files(version, deb,
++                 options['email'], options['asn'], options['name'],
++                 iso, rfc)
++    bootstrap()
++    os.system("dpkg-buildpackage " + options['dbopts'])
++
++def process_opts(argv):
++    """Process command line options."""
++    global options
++    try:
++        opts, args = getopt.getopt(argv[1:], "a:d:e:hn:pv",
++                                   ["asn=",
++                                    "dbopts=",
++                                    "email=",
++                                    "help",
++                                    "name=",
++                                    "preserve",
++                                    "version"])
++    except getopt.GetoptError:
++        usage(argv[0])
++        sys.exit(1)
++    for o, a in opts:
++        if o in ("-a", "--asn"):
++            options['asn'] = a
++        if o in ("-d", "--dbopts"):
++            options['dbopts'] = a
++        if o in ("-e", "--email"):
++            options['email'] = a
++        if o in ("-h", "--help"):
++            options['help'] = 1
++        if o in ("-n", "--name"):
++            options['name'] = a
++        if o in ("-p", "--preserve"):
++            options['preserve'] = 1
++        if o in ("-v", "--version"):
++            options['version'] = 1
++    if options['help']:
++        usage(argv[0])
++        sys.exit(0)
++    if options['version']:
++        print scriptinfo
++        sys.exit(0)
++    if not options['asn']:
++        print "mandatory ASN.1 file parameter missing"
++        sys.exit(1)
++    if not os.access(options['asn'], os.R_OK):
++        print "ASN.1 file not accessible"
++        sys.exit(1)
++
++def usage(name):
++    """Print usage help."""
++    print "Usage: " + name + " <parameters>\n" + \
++          "Parameters are\n" + \
++          "  --asn      -a asn1file, ASN.1 file to use (mandatory)\n" + \
++          "  --dbopts   -d opts,     options for dpkg-buildpackage\n" + \
++          "  --email    -e address,  use e-mail address\n" + \
++          "  --help     -h,          print help and exit\n" + \
++          "  --name     -n name,     use user name\n" + \
++          "  --preserve -p,          do not overwrite files\n" + \
++          "  --version  -v,          print version and exit\n" + \
++          "Example:\n" + \
++          name + " -e me@foo.net -a bar.asn1 -n \"My Name\" " + \
++          "-d \"-rfakeroot -uc -us\""
++if __name__ == '__main__':
++    main()
+Index: b/asn2deb.dbk
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ b/asn2deb.dbk      2010-02-15 17:24:58.000000000 +0100
+@@ -0,0 +1,158 @@
++<?xml version='1.0' encoding='ISO-8859-1'?>
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
++"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
++  <!ENTITY command     "<command>asn2deb</command>">
++  <!ENTITY email       "<email>debacle@debian.org</email>">
++  <!ENTITY author      "W. Borgert">
++  <!ENTITY debian      "<productname>Debian GNU/Linux</productname>">
++]>
++
++<refentry>
++  <refentryinfo>
++    <address>
++      &email;
++    </address>
++    <author>
++      <firstname>W.</firstname>
++      <surname>Borgert</surname>
++    </author>
++    <copyright>
++      <year>2003</year>
++      <year>2005</year>
++      <holder>&author;</holder>
++    </copyright>
++    <date>2004-02-18</date>
++    <keywordset>
++      <keyword>ASN.1</keyword>
++      <keyword>BER</keyword>
++      <keyword>Wireshark</keyword>
++    </keywordset>
++    <revhistory>
++      <revision>
++      <revnumber>1</revnumber>
++      <date>2004-02-18</date>
++      <authorinitials>debacle</authorinitials>
++      <revremark>First version.</revremark>
++      </revision>
++    </revhistory>
++  </refentryinfo>
++  <refmeta>
++    <refentrytitle>asn2deb</refentrytitle>
++
++    <manvolnum>1</manvolnum>
++  </refmeta>
++  <refnamediv>
++    <refname>asn2deb</refname>
++
++    <refpurpose>create a Debian package for BER monitoring from ASN.1</refpurpose>
++  </refnamediv>
++  <refsynopsisdiv>
++    <cmdsynopsis>
++      &command;
++      <arg>-a <replaceable>ASN.1 file</replaceable></arg>
++      <arg>--asn=<replaceable>ASN.1 file</replaceable></arg>
++      <arg><option>-d <replaceable>opts</replaceable></option></arg>
++      <arg><option>--dbopts=<replaceable>opts</replaceable></option></arg>
++      <arg><option>-e <replaceable>address</replaceable></option></arg>
++      <arg><option>--email=<replaceable>address</replaceable></option></arg>
++      <arg><option>-h</option></arg>
++      <arg><option>--help</option></arg>
++      <arg><option>-n <replaceable>name</replaceable></option></arg>
++      <arg><option>--name=<replaceable>name</replaceable></option></arg>
++      <arg><option>-p</option></arg>
++      <arg><option>--preserve</option></arg>
++      <arg><option>-v</option></arg>
++      <arg><option>--version</option></arg>
++    </cmdsynopsis>
++  </refsynopsisdiv>
++  <refsect1>
++    <title>Description</title>
++
++    <para>This manual page documents briefly the
++      <command>asn2deb</command> command.</para>
++
++    <para>&command; takes an ASN.1 file as input and creates a Debian
++    package from it.  The package contains a loadable type table file
++    for the wireshark network analyser.  The type table is generated by
++    the ASN.1 compiler <command>snacc</command>.</para>
++  </refsect1>
++  <refsect1>
++    <title>Options</title>
++
++    <variablelist>
++      <varlistentry>
++        <term><option>-a <replaceable>ASN.1 file</replaceable></option>
++          <option>--asn=<replaceable>ASN.1 file</replaceable></option></term>
++        <listitem>
++          <para>ASN.1 file to use (mandatory).</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-d <replaceable>opts</replaceable></option>
++          <option>--dbopts=<replaceable>opts</replaceable></option></term>
++        <listitem>
++          <para>options for dpkg-buildpackage.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-e <replaceable>address</replaceable></option>
++          <option>--email=<replaceable>address</replaceable></option></term>
++        <listitem>
++          <para>use e-mail address.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-h</option>
++          <option>--help</option>
++        </term>
++        <listitem>
++          <para>print help and exit.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-n <replaceable>name</replaceable></option>
++          <option>--name=<replaceable>name</replaceable></option></term>
++        <listitem>
++          <para>use user name.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-p</option>
++          <option>--preserve</option></term>
++        <listitem>
++          <para>do not overwrite files.</para>
++        </listitem>
++      </varlistentry>
++      <varlistentry>
++        <term><option>-v</option>
++          <option>--version</option></term>
++        <listitem>
++          <para>print version and exit.</para>
++        </listitem>
++      </varlistentry>
++    </variablelist>
++
++    <para>Example:</para>
++
++    <programlisting>/usr/bin/asn2deb -e me@foo.net -a bar.asn1 \
++-n &quot;My Name&quot; -d &quot;-rfakeroot -uc -us&quot;</programlisting>
++
++  </refsect1>
++  <refsect1>
++    <title>See Also</title>
++
++    <para>A lot of tools are used, which you have to
++    <command>apt-get install</command>: wireshark-dev, python,
++    cdbs, autotools-dev, debhelper, dpkg-dev, snacc.</para>
++  </refsect1>
++
++  <refsect1>
++    <title>Copying</title>
++
++    <para>This manual page was written by &author; &email; for
++      &debian; (but may be used by others).  Permission is granted to
++      copy, distribute and/or modify this document under the terms of
++      the GNU General Public License, Version 2 or any later
++      version published by the Free Software Foundation.</para>
++  </refsect1>
++</refentry>
diff --git a/debian/patches/03_preferences.patch b/debian/patches/03_preferences.patch
new file mode 100755 (executable)
index 0000000..0c351a1
--- /dev/null
@@ -0,0 +1,15 @@
+Description: Use Debian sensible-browser
+Forwarded: not-needed
+Author: Frederic Peters <fpeters@debian.org>
+
+--- a/epan/prefs.c
++++ b/epan/prefs.c
+@@ -1253,7 +1253,7 @@
+   prefs.gui_ask_unsaved            = TRUE;
+   prefs.gui_find_wrap              = TRUE;
+   prefs.gui_use_pref_save          = FALSE;
+-  prefs.gui_webbrowser             = g_strdup(HTML_VIEWER " %s");
++  prefs.gui_webbrowser             = g_strdup("sensible-browser %s");
+   prefs.gui_window_title           = g_strdup("");
+   prefs.gui_start_title            = g_strdup("The World's Most Popular Network Protocol Analyzer");
+   prefs.gui_version_in_start_page  = TRUE;
diff --git a/debian/patches/04_asn2wrs_ply.patch b/debian/patches/04_asn2wrs_ply.patch
new file mode 100644 (file)
index 0000000..7f0f11d
--- /dev/null
@@ -0,0 +1,18 @@
+Description: Use lex/yacc from ply
+Forwarded: not-needed
+Bug-Debian: http://bugs.debian.org/554613
+Author: Jakub Wilk <ubanus@users.sf.net>
+
+--- a/tools/asn2wrs.py
++++ b/tools/asn2wrs.py
+@@ -47,8 +47,8 @@
+ import getopt
+ import traceback
+-import lex
+-import yacc
++from ply import lex
++from ply import yacc
+ from string import maketrans
diff --git a/debian/patches/05_note-README-when-running-as-root.patch b/debian/patches/05_note-README-when-running-as-root.patch
new file mode 100644 (file)
index 0000000..34b8bf0
--- /dev/null
@@ -0,0 +1,15 @@
+Description: Note about README.Debian when running wireshark as root.
+Forwarded: not-needed
+Author: Balint Reczey <balint@balintreczey.hu>
+
+--- ./ui/gtk/main.c.orig       2012-06-05 18:33:15.000000000 +0200
++++ ./ui/gtk/main.c    2012-06-07 01:13:54.000000000 +0200
+@@ -2069,7 +2069,7 @@
+       "This could be dangerous.\n\n"
+       "If you're running Wireshark this way in order to perform live capture, "
+       "you may want to be aware that there is a better way documented at\n"
+-      "http://wiki.wireshark.org/CaptureSetup/CapturePrivileges", cur_user, cur_group);
++      "/usr/share/doc/wireshark-common/README.Debian", cur_user, cur_group);
+     g_free(cur_user);
+     g_free(cur_group);
+     simple_dialog_check_set(priv_warning_dialog, "Don't show this message again.");
diff --git a/debian/patches/06_release-version.patch b/debian/patches/06_release-version.patch
new file mode 100644 (file)
index 0000000..d443e90
--- /dev/null
@@ -0,0 +1,18 @@
+Description: Don't regenerate svnversion.h
+Forwarded: not-needed
+Author: Balint Reczey <balint@balintreczey.hu>
+
+Index: ./Makefile.am
+===================================================================
+--- ./Makefile.am      (revision 37943)
++++ ./Makefile.am      (working copy)
+@@ -474,7 +474,7 @@
+ # FORCE is the portable version of .PHONY
+ FORCE:
+-svnversion.h: FORCE
++svnversion.h:
+       $(PERL) $(srcdir)/make-version.pl $(srcdir)
+ #
+
diff --git a/debian/patches/08_wireshark-desktop-menu.patch b/debian/patches/08_wireshark-desktop-menu.patch
new file mode 100755 (executable)
index 0000000..c64e764
--- /dev/null
@@ -0,0 +1,23 @@
+Description: Change Icon and Categories for desktop file
+Forwarded: not-needed
+Author: <fred@candle>
+
+Index: b/wireshark.desktop
+===================================================================
+--- a/wireshark.desktop        2010-02-15 17:23:17.000000000 +0100
++++ b/wireshark.desktop        2010-02-15 17:24:59.000000000 +0100
+@@ -68,11 +68,12 @@
+ Comment[fi]=Verkkoliikenne analysaattori
+ Comment[fr]=Analyseur de trafic réseau
+ Comment[sv]=Nätverkstrafikanalysator
+-Icon=wireshark.png
++Icon=wireshark
+ TryExec=wireshark
+ Exec=wireshark %f
+ Terminal=false
+ MimeType=application/vnd.tcpdump.pcap;
+ # Categorie entry according to version 1.0 of
+ # http://www.freedesktop.org/wiki/Specifications/menu-spec
+-Categories=System;Monitor;GTK;
++Categories=GNOME;Network;
++Encoding=UTF-8
diff --git a/debian/patches/09_idl2wrs.patch b/debian/patches/09_idl2wrs.patch
new file mode 100755 (executable)
index 0000000..acfd5ea
--- /dev/null
@@ -0,0 +1,49 @@
+Description: Do not try to locate wireshark_be.py and wireshark_gen.py in
+ non-standard places.
+Author: Frederic Peters <fpeters@debian.org>
+
+Index: b/tools/idl2wrs
+===================================================================
+--- a/tools/idl2wrs    2010-02-15 17:23:17.000000000 +0100
++++ b/tools/idl2wrs    2010-02-15 17:24:59.000000000 +0100
+@@ -48,40 +48,6 @@
+     exit 1;
+ fi
+-#
+-# Run wireshark backend, looking for wireshark_be.py and wireshark_gen.py
+-# in pythons's "site-packages" directory. If cannot find that, then
+-# try looking in current directory. If still cannot, then exit with
+-# error.
+-
+-if [ -f $PYTHONPATH/site-packages/wireshark_be.py ] && [ -f $PYTHONPATH/site-packages/wireshark_gen.py ]; then
+-    exec omniidl  -p $PYTHONPATH/site-packages -b wireshark_be $@
+-    /* not reached */
+-fi
+-
+-# Try current directory.
+-
+-if [ -f ./wireshark_be.py ] && [ -f ./wireshark_gen.py ]; then
+-    exec omniidl  -p ./ -b wireshark_be $@
+-    /* not reached */
+-fi
+-
+-# Could not find both wireshark_be.py AND wireshark_gen.py
+-# So let's just try to run it without -p, hoping that the installation
+-# set up a valid path.
+ exec omniidl -b wireshark_be $@
+-old code: not reached
+-
+-echo "idl2wrs Error: Could not find both wireshark_be.py AND wireshark_gen.py."
+-echo "Please ensure you have the PYTHONPATH variable set, or that wireshark_be.py "
+-echo "and wireshark_gen.py exist in the current directory. "
+-echo
+-echo "On this system, PYTHONPATH is : $PYTHONPATH"
+-echo
+-
+-exit 2
+-
+-
+-
diff --git a/debian/patches/16_licence_about_location.patch b/debian/patches/16_licence_about_location.patch
new file mode 100755 (executable)
index 0000000..b8d2910
--- /dev/null
@@ -0,0 +1,15 @@
+Description: Change location of license file in about dialog
+Forwarded: not-needed
+Author: Frederic Peters <fpeters@debian.org>
+
+--- a/ui/gtk/about_dlg.c
++++ b/ui/gtk/about_dlg.c
+@@ -478,7 +478,7 @@
+ #if defined(_WIN32)
+   absolute_path = get_datafile_path("COPYING.txt");
+ #else
+-  absolute_path = get_datafile_path("COPYING");
++  absolute_path = get_datafile_path("ABOUT.GPL");
+ #endif
+   page = text_page_new(absolute_path);
diff --git a/debian/patches/17_fix_from_1.8.3_fix_HSRP_crash.patch b/debian/patches/17_fix_from_1.8.3_fix_HSRP_crash.patch
new file mode 100644 (file)
index 0000000..7794dac
--- /dev/null
@@ -0,0 +1,90 @@
+From a98fae4a9fafb9fac459d67d13525af5e726fbca Mon Sep 17 00:00:00 2001
+From: Jakub Zawadzki <darkjames-ws@darkjames.pl>
+Date: Sun, 12 Aug 2012 15:08:00 +0000
+Subject: [PATCH 1/4] Revert r41311, fix bug #7581
+
+svn path=/trunk/; revision=44454
+---
+ epan/dissectors/packet-hsrp.c |   10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/epan/dissectors/packet-hsrp.c b/epan/dissectors/packet-hsrp.c
+index 3db3d4f..866249d 100644
+--- a/epan/dissectors/packet-hsrp.c
++++ b/epan/dissectors/packet-hsrp.c
+@@ -411,6 +411,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                                                      auth_buf);
+                               offset += 8;
+                               proto_tree_add_item(hsrp_tree, hf_hsrp_virt_ip_addr, tvb, offset, 4, ENC_BIG_ENDIAN);
++                              /* offset += 4; */
+                       } else if (opcode == 3) {
+                               proto_tree_add_item(hsrp_tree, hf_hsrp_adv_type, tvb, offset, 2, ENC_BIG_ENDIAN);
+                               offset += 2;
+@@ -425,6 +426,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                               proto_tree_add_item(hsrp_tree, hf_hsrp_adv_passivegrp, tvb, offset, 2, ENC_BIG_ENDIAN);
+                               offset += 2;
+                               proto_tree_add_item(hsrp_tree, hf_hsrp_adv_reserved2, tvb, offset, 4, ENC_BIG_ENDIAN);
++                              /* offset += 4; */
+                       } else {
+                               next_tvb = tvb_new_subset_remaining(tvb, offset);
+                               call_dissector(data_handle, next_tvb, pinfo, hsrp_tree);
+@@ -433,7 +435,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+         } else if ((pinfo->dst.type == AT_IPv4 && strcmp(dst,HSRP2_DST_IP_ADDR) == 0) ||
+                  (pinfo->dst.type == AT_IPv6 && pinfo->destport == UDP_PORT_HSRP2_V6)) {
+                 /* HSRPv2 */
+-                guint offset = 0;
++                guint offset = 0, offset2;
+                 proto_item *ti = NULL;
+                 proto_tree *hsrp_tree = NULL;
+                 guint8 type,len;
+@@ -449,6 +451,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                         type = tvb_get_guint8(tvb, offset);
+                         len = tvb_get_guint8(tvb, offset+1);
++                        offset2 = offset;
+                         if (type == 1 && len == 40) {
+                                 /* Group State TLV */
+                                 guint8 opcode, state = 0, ipver;
+@@ -516,6 +519,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                                               call_dissector(data_handle, next_tvb, pinfo, hsrp_tree);
+                                                 break;
+                                       }
++                                      /* offset+=16; */
+                               }
+                         } else if (type == 2 && len == 4) {
+                                 /* Interface State TLV */
+@@ -538,6 +542,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                                       proto_tree_add_item(interface_state_tlv, hf_hsrp2_active_group, tvb, offset, 2, ENC_BIG_ENDIAN);
+                                         offset+=2;
+                                       proto_tree_add_item(interface_state_tlv, hf_hsrp2_passive_group, tvb, offset, 2, ENC_BIG_ENDIAN);
++                                      /* offset+=2; */
+                                 }
+                         } else if (type == 3 && len == 8) {
+                                 /* Text Authentication TLV */
+@@ -558,6 +563,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                                                              "Authentication Data: %sDefault (%s)",
+                                                              (tvb_strneql(tvb, offset, "cisco", strlen("cisco"))) == 0 ? "" : "Non-",
+                                                              auth_buf);
++                                      /* offset += 8; */
+                                 }
+                         } else if (type == 4 && len == 28) {
+                                 /* Text Authentication TLV */
+@@ -581,6 +587,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                                         proto_tree_add_item(md5_auth_tlv, hf_hsrp2_md5_key_id, tvb, offset, 4, ENC_BIG_ENDIAN);
+                                         offset+=4;
+                                         proto_tree_add_item(md5_auth_tlv, hf_hsrp2_md5_auth_data, tvb, offset, 16, ENC_BIG_ENDIAN);
++                                        /* offset += 16; */
+                                 }
+                         } else {
+                                 /* Undefined TLV */
+@@ -590,6 +597,7 @@ dissect_hsrp(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+                               }
+                                 break;
+                       }
++                      offset = offset2+len+2;
+               }
+         }
+-- 
+1.7.10.4
+
diff --git a/debian/patches/17_fix_from_1.8.3_fix_LDP_crash.patch b/debian/patches/17_fix_from_1.8.3_fix_LDP_crash.patch
new file mode 100644 (file)
index 0000000..543ecc8
--- /dev/null
@@ -0,0 +1,76 @@
+From ac3bdf57670fd59afef128b33d11907fc28436ba Mon Sep 17 00:00:00 2001
+From: Jeff Morriss <jeff.morriss.ws@gmail.com>
+Date: Fri, 7 Sep 2012 01:35:16 +0000
+Subject: [PATCH 4/4] From Aditya Ambadkar via
+ https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7046
+ :
+
+Fix CID 703472 and (external) fuzz failure 7567:
+
+The dissect_subtlv_interface_parameters is missing the handling of BFD 2..4.
+For the crash patch, we decided to add the bfd2..4 in dissect_tlc function(in
+the diff). We plan to open a separate bug to fix
+dissect_subtlv_interface_parameters to make it handle BFD2..4. (Thanks to Arun
+Arunachalam for this analysis)
+
+From me: fix up some indentation and replace tabs with spaces (for consistency).
+
+svn path=/trunk/; revision=44801
+---
+ epan/dissectors/packet-ldp.c |   20 +++++++++++++-------
+ 1 file changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/epan/dissectors/packet-ldp.c b/epan/dissectors/packet-ldp.c
+index 86a6301..4d08088 100644
+--- a/epan/dissectors/packet-ldp.c
++++ b/epan/dissectors/packet-ldp.c
+@@ -2459,7 +2459,13 @@ dissect_tlv(tvbuff_t *tvb, guint offset, proto_tree *tree, int rem)
+                 &hf_ldp_tlv_intparam_vccv_cctype_ttl1 ,
+                 &hf_ldp_tlv_intparam_vccv_cvtype_icmpping ,
+                 &hf_ldp_tlv_intparam_vccv_cvtype_lspping ,
+-                &hf_ldp_tlv_intparam_vccv_cvtype_bfd
++                &hf_ldp_tlv_intparam_vccv_cvtype_bfd,
++                &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd2,
++                &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd3,
++                &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd4,
++                &hf_ldp_tlv_fec_vc_intparam_flowlabel_t,
++                &hf_ldp_tlv_fec_vc_intparam_flowlabel_r,
++                &hf_ldp_tlv_fec_vc_intparam_flowlabel_res
+             };
+             int vc_len = length;
+             offset += 4;
+@@ -3568,25 +3574,25 @@ proto_register_ldp(void)
+           { "BFD IP/UDP-encapsulated, for PW Fault Detection only", "ldp.msg.tlv.fec.vc.intparam.vccv.cvtype_bfd1", FT_BOOLEAN, 8,
+             NULL, 0x04, "VC FEC Interface Param VCCV CV Type BFD IP/UDP-encapsulated, for PW Fault Detection only", HFILL }},
+-      { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd2,
++        { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd2,
+           { "BFD IP/UDP-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling", "ldp.msg.tlv.fec.vc.intparam.vccv.cvtype_bfd2", FT_BOOLEAN, 8,
+             NULL, 0x08, "VC FEC Interface Param VCCV CV Type BFD IP/UDP-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling", HFILL }},
+-      { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd3,
++        { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd3,
+           { "BFD BFD PW-ACH-encapsulated, for PW Fault Detection only", "ldp.msg.tlv.fec.vc.intparam.vccv.cvtype_bfd3", FT_BOOLEAN, 8,
+             NULL, 0x10, "VC FEC Interface Param VCCV CV Type BFD PW-ACH-encapsulated, for PW Fault Detection only", HFILL }},
+-      { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd4,
++        { &hf_ldp_tlv_fec_vc_intparam_vccv_cvtype_bfd4,
+           { "BFD BFD PW-ACH-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling", "ldp.msg.tlv.fec.vc.intparam.vccv.cvtype_bfd4", FT_BOOLEAN, 8,
+             NULL, 0x20, "VC FEC Interface Param VCCV CV Type BFD PW-ACH-encapsulated, for PW Fault Detection and AC/PW Fault Status Signaling", HFILL }},
+-      { &hf_ldp_tlv_fec_vc_intparam_flowlabel_t,
++        { &hf_ldp_tlv_fec_vc_intparam_flowlabel_t,
+           { "Flow Label Transmit bit", "ldp.msg.tlv.fec.vc.intparam.flowlabel.t", FT_UINT8, BASE_DEC, NULL, 0x80, NULL, HFILL}},
+-      { &hf_ldp_tlv_fec_vc_intparam_flowlabel_r,
++        { &hf_ldp_tlv_fec_vc_intparam_flowlabel_r,
+           { "Flow Label Receive bit", "ldp.msg.tlv.fec.vc.intparam.flowlabel.r", FT_UINT8, BASE_DEC, NULL, 0x40, NULL, HFILL}},
+-    { &hf_ldp_tlv_fec_vc_intparam_flowlabel_res,
++        { &hf_ldp_tlv_fec_vc_intparam_flowlabel_res,
+           { "Flow Label Reserved", "ldp.msg.tlv.fec.vc.intparam.flowlabel.res", FT_UINT16, BASE_HEX, NULL, 0x3FFF, NULL, HFILL}},
+         { &hf_ldp_tlv_lspid_act_flg,
+-- 
+1.7.10.4
+
diff --git a/debian/patches/17_fix_from_1.8.3_fix_PPP_crash.patch b/debian/patches/17_fix_from_1.8.3_fix_PPP_crash.patch
new file mode 100644 (file)
index 0000000..bd1e00b
--- /dev/null
@@ -0,0 +1,28 @@
+From cfbeab2a4421ca0ba8f19d3958abe9e2fc5898bc Mon Sep 17 00:00:00 2001
+From: Jakub Zawadzki <darkjames-ws@darkjames.pl>
+Date: Tue, 28 Aug 2012 08:44:41 +0000
+Subject: [PATCH 2/4] Fix bug #7668
+
+Use correct field type for lcp.opt.oui
+
+svn path=/trunk/; revision=44688
+---
+ epan/dissectors/packet-ppp.c |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/epan/dissectors/packet-ppp.c b/epan/dissectors/packet-ppp.c
+index ca740c5..6109313 100644
+--- a/epan/dissectors/packet-ppp.c
++++ b/epan/dissectors/packet-ppp.c
+@@ -5570,7 +5570,7 @@ proto_register_lcp(void)
+             { "Length", "lcp.opt.length", FT_UINT8, BASE_DEC,
+                 NULL, 0x0, NULL, HFILL }},
+         { &hf_lcp_opt_oui,
+-            { "OUI", "lcp.opt.oui", FT_BYTES, BASE_NONE,
++            { "OUI", "lcp.opt.oui", FT_UINT24, BASE_HEX,
+                 NULL, 0x0, NULL, HFILL }},
+         { &hf_lcp_opt_kind,
+             { "Kind", "lcp.opt.kind", FT_UINT8, BASE_DEC_HEX,
+-- 
+1.7.10.4
+
diff --git a/debian/patches/17_fix_from_1.8.3_fix_infinite_loop_in_DRDA_dissector.patch b/debian/patches/17_fix_from_1.8.3_fix_infinite_loop_in_DRDA_dissector.patch
new file mode 100644 (file)
index 0000000..8f624c6
--- /dev/null
@@ -0,0 +1,39 @@
+From 2105bbdfcf11082765daba013b64f1c37aaf6245 Mon Sep 17 00:00:00 2001
+From: Pascal Quantin <pascal.quantin@gmail.com>
+Date: Mon, 3 Sep 2012 12:48:57 +0000
+Subject: [PATCH 3/4] Fix
+ https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7666
+ : Check that DRDA command has a minimum length of 10
+ bytes to prevent a potential infinite loop
+
+svn path=/trunk/; revision=44749
+---
+ epan/dissectors/packet-drda.c |    5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/epan/dissectors/packet-drda.c b/epan/dissectors/packet-drda.c
+index f5d701b..730f687 100644
+--- a/epan/dissectors/packet-drda.c
++++ b/epan/dissectors/packet-drda.c
+@@ -55,6 +55,7 @@
+ #include <epan/packet.h>
+ #include <epan/conversation.h>
+ #include <epan/prefs.h>
++#include <epan/expert.h>
+ #include "packet-tcp.h"
+ static int proto_drda = -1;
+@@ -696,6 +697,10 @@ dissect_drda(tvbuff_t *tvb, packet_info *pinfo, proto_tree *tree)
+     {
+         iCommand = tvb_get_ntohs(tvb, offset + 8);
+         iLength = tvb_get_ntohs(tvb, offset + 0);
++        if (iLength < 10) {
++            expert_add_info_format(pinfo, NULL, PI_MALFORMED, PI_ERROR, "Invalid length detected (%u): should be at least 10 bytes long", iLength);
++            break;
++        }
+         /* iCommandEnd is the length of the packet up to the end of the current command */
+         iCommandEnd += iLength;
+-- 
+1.7.10.4
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..0551cbb
--- /dev/null
@@ -0,0 +1,13 @@
+01_idl2deb.patch
+02_asn2deb.patch
+03_preferences.patch
+04_asn2wrs_ply.patch
+05_note-README-when-running-as-root.patch
+06_release-version.patch
+08_wireshark-desktop-menu.patch
+09_idl2wrs.patch
+16_licence_about_location.patch
+17_fix_from_1.8.3_fix_HSRP_crash.patch
+17_fix_from_1.8.3_fix_infinite_loop_in_DRDA_dissector.patch
+17_fix_from_1.8.3_fix_LDP_crash.patch
+17_fix_from_1.8.3_fix_PPP_crash.patch
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
new file mode 100644 (file)
index 0000000..cef83a3
--- /dev/null
@@ -0,0 +1 @@
+[type: gettext/rfc822deb] templates
diff --git a/debian/po/cs.po b/debian/po/cs.po
new file mode 100644 (file)
index 0000000..0bff55d
--- /dev/null
@@ -0,0 +1,66 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the wireshark package.
+# Martin Sin <martin.sin@zshk.cz>, 2009.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.1-3\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-20 17:12+0200\n"
+"Last-Translator: Martin Sin <martin.sin@zshk.cz>\n"
+"Language-Team: Czech <debian-l10n-czech@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=utf-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Mohou obyčejní uživatelé zachytávat pakety?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap můžete nainstalovat tak, že budou moci zachytávat pakety pouze "
+"členové skupiny „wireshark“. Tento způsob zachytávání paketů pomocí "
+"Wireshark/Tshark se obecně doporučuje. Druhou možností je spuštění programu "
+"přímo pod superuživatelem, to ovšem nelze doporučit, protože je pak pod tímto "
+"uživatelem spuštěna větší část potencionálně nebezpečného kódu."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Pro více informací se prosím podívejte na /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Povolení této možnosti může být bezpečnostním rizikem a tak je ve výchozím "
+"nastavení vypnuté. Jste-li na pochybách, doporučuje se nechat volbu vypnutou."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "M?? se dumpcap nainstalovat s ???setuid root????"
diff --git a/debian/po/da.po b/debian/po/da.po
new file mode 100644 (file)
index 0000000..5397fb4
--- /dev/null
@@ -0,0 +1,57 @@
+# Danish translation wireshark.
+# Copyright (C) 2010 wireshark & nedenstående oversættere.
+# This file is distributed under the same license as the wireshark package.
+# Joe Hansen <joedalton2@yahoo.dk>, 2010.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-08-28 23:51+0200\n"
+"Last-Translator: Joe Hansen <joedalton2@yahoo.dk>\n"
+"Language-Team: Danish <dansk@dansk-gruppen.dk>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Skal brugere, der ikke er superbrugere, kunne fange pakker?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap kan installeres på en måde som tillader medlemmer af systemgruppen "
+"»wireshark« at fange pakker. Dette anbefales frem for alternativet med at køre "
+"Wireshark/Tshark direkte som rod (root), da mindre af koden vil køre med "
+"ophøjede privilegier."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"For mere detaljerede information se venligst /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Aktivering af denne funktion kan udgøre en sikkerhedsrisiko, så som "
+"standard er den deaktiveret. Hvis du er i tvivl, anbefales det at lade den "
+"være deaktiveret."
diff --git a/debian/po/de.po b/debian/po/de.po
new file mode 100644 (file)
index 0000000..f442e32
--- /dev/null
@@ -0,0 +1,60 @@
+# Translation of wireshark debconf templates to German
+# Copyright (C) Helge Kreutzmann <debian@helgefjell.de>, 2009, 2010.
+# This file is distributed under the same license as the wireshark package.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.9-2\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-07-26 18:18+0200\n"
+"Last-Translator: Helge Kreutzmann <debian@helgefjell.de>\n"
+"Language-Team: de <debian-l10n-german@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr ""
+"Sollen außer dem Superuser noch andere Benutzer Pakete aufzeichen können?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap kann so installiert werden, dass Mitglieder der Systemgruppe "
+"»wireshark« Pakete aufzeichnen können. Dies wird gegenüber der Methode, "
+"Wireshark/Tshark direkt als Root zu betreiben, empfohlen, da so weniger Code "
+"mit erhöhten Rechten läuft."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Detalliertere Informationen finden Sie in /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Die Aktivierung dieser Funktionalität kann ein Sicherheitsrisiko darstellen, "
+"daher ist sie standardmäßig deaktiviert. Im Zweifelsfall wird empfohlen, sie "
+"deaktiviert zu lassen."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "Soll Dumpcap »setuid-root« installiert werden?"
diff --git a/debian/po/es.po b/debian/po/es.po
new file mode 100644 (file)
index 0000000..6065456
--- /dev/null
@@ -0,0 +1,74 @@
+# wireshark po-debconf translation to Spanish
+# Copyright (C) 2009, 2010 Software in the Public Interest
+# This file is distributed under the same license as the wireshark package.
+#
+# Changes:
+#   - Initial translation
+#       Francisco Javier Cuadrado <fcocuadrado@gmail.com>, 2009
+#
+#   - Updates
+#       Francisco Javier Cuadrado <fcocuadrado@gmail.com>, 2010
+#
+# Traductores, si no conocen el formato PO, merece la pena leer la
+# documentación de gettext, especialmente las secciones dedicadas a este
+# formato, por ejemplo ejecutando:
+#       info -n '(gettext)PO Files'
+#       info -n '(gettext)Header Entry'
+#
+# Equipo de traducción al español, por favor, lean antes de traducir
+# los siguientes documentos:
+#
+#   - El proyecto de traducción de Debian al español
+#     http://www.debian.org/intl/spanish/
+#     especialmente las notas de traducción en
+#     http://www.debian.org/intl/spanish/notas
+#
+#   - La guía de traducción de po's de debconf:
+#     /usr/share/doc/po-debconf/README-trans
+#     o http://www.debian.org/intl/l10n/po-debconf/README-trans
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.9-1\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-20 20:37+0100\n"
+"Last-Translator: Francisco Javier Cuadrado <fcocuadrado@gmail.com>\n"
+"Language-Team: Debian l10n Spanish <debian-l10n-spanish@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "¿Los usuarios sin privilegios de administración deberían poder capturar paquetes?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid "Dumpcap can be installed in a way that allows members of the \"wireshark\" system group to capture packets. This is recommended over the alternative of running Wireshark/Tshark directly as root, because less of the code will run with elevated privileges."
+msgstr "Dumpcap se puede instalar de un modo que permite a los miembros del grupo «wireshark» capturar paquetes. Se recomienda usar esto en lugar de ejecutar Wireshark/Tshark directamente como administrador («root»), porque se ejecutará menos código con privilegios de administración."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "For more detailed information please see /usr/share/doc/wireshark-common/README.Debian."
+msgstr "Para más información, vea el archivo «/usr/share/doc/wireshark-common/README.Debian»."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Enabling this feature may be a security risk, so it is disabled by default. If in doubt, it is suggested to leave it disabled."
+msgstr "Activar esta funcionalidad puede ser un riesgo de seguridad, por lo que de forma predeterminada está desactivada. En caso de duda, se recomienda dejarla desactivada."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "¿Se debe instalar dumpcap con el bit «setuid root» activo?"
+
diff --git a/debian/po/eu.po b/debian/po/eu.po
new file mode 100644 (file)
index 0000000..a1b7a5a
--- /dev/null
@@ -0,0 +1,67 @@
+# translation of wireshark_1.2.10-2_eu.po to Basque
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+#
+# Piarres Beobide <pi@beobide.net>, 2009.
+# Iñaki Larrañaga Murgoitio <dooteo@euskalgnu.org>, 2010.
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark_1.2.10-2_eu\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-09-03 10:53+0200\n"
+"Last-Translator: Iñaki Larrañaga Murgoitio <dooteo@euskalgnu.org>\n"
+"Language-Team: Basque <debian-l10n-basque@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.11.4\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Supererabiltzailea ez direnak paketeak kapturatzeko gai izan daitezke?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Sistemako \"wireshark\" taldeko partaideek paketeak kapturatzea baimentzeko "
+"modu batean instala daiteke Dumpcap. Wireshark/Tshark erabiliz paketeak "
+"supererabiltzaile gisa kapturatzeko modu hau gomendatuta dago, "
+"pribilegio handiekin kode gutxiago exekutatzen da eta."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Informazio gehiagorako, irakurri usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Eginbide hau gaitzean segurtasuneko arrisku bat sor daiteke, hau dela eta "
+"desgaituta dago lehenespenez. Zalantzako kasuan, desgaituta "
+"uztea gomendantzen da."
+
diff --git a/debian/po/fi.po b/debian/po/fi.po
new file mode 100644 (file)
index 0000000..47ae853
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright (C) 2009
+# This file is distributed under the same license as the wireshark package.
+#
+# Esko Arajärvi <edu@iki.fi>, 2009.
+msgid ""
+msgstr ""
+"Project-Id-Version: \n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2009-10-04 22:49+0300\n"
+"Last-Translator: Esko Arajärvi <edu@iki.fi>\n"
+"Language-Team: Finnish <debian-l10n-finnish@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Lokalize 1.0\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#, fuzzy
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap voidaan asentaa ajettavaksi pääkäyttäjäoikeuksilla siten, että "
+"ryhmän \"wireshark\" jäsenillä on tarvittavat oikeudet sen käyttämiseen. On "
+"suositeltavaa käyttää tätä tapaa pakettien kaappaamiseen Wiresharkilla tai "
+"Tsharkilla, sen sijaan että niitä ajettaisiin suoraan pääkäyttäjänä, koska "
+"pienempi osa koodista ajetaan tällöin pääkäyttäjäoikeuksilla."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Tämän ominaisuuden käyttöönotto saattaa olla tietoturvariski ja tästä syystä "
+"se on oletuksena poissa käytöstä. Jos olet epävarma, on suositeltavaa jättää "
+"se pois käytöstä."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "Tulisiko dumpcap asentaa asetuksella ”setuid root”?"
diff --git a/debian/po/fr.po b/debian/po/fr.po
new file mode 100644 (file)
index 0000000..322631a
--- /dev/null
@@ -0,0 +1,69 @@
+# Translation of wireshark debconf templates to French
+# Copyright (C) 2009 Debian French l10n team <debian-l10n-french@lists.debian.org>
+# This file is distributed under the same license as the wireshark package.
+#
+# Translators:
+# Simon Paillard <spaillard@debian.org>, 2009
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-07-25 21:54+0200\n"
+"Last-Translator: Simon Paillard <spaillard@debian.org>\n"
+"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Autoriser les utilisateurs non privilégiés à capturer des paquets ?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap peut être installé afin d'autoriser les membres du groupe "
+"« wireshark » à capturer des paquets. Cette méthode de capture est "
+"préférable à l'exécution de Wireshark ou Tshark avec les droits du "
+"superutilisateur, car elle permet d'exécuter moins de code avec des droits "
+"importants."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Pour plus d'informations, veuillez consulter /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Cette fonctionnalité constitue un risque pour la sécurité, c'est pourquoi "
+"elle est désactivée par défaut. En cas de doute, il est suggéré de la "
+"laisser désactivée."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "Installer dumpcap avec le bit « setuid root » ?"
diff --git a/debian/po/hu.po b/debian/po/hu.po
new file mode 100644 (file)
index 0000000..32be610
--- /dev/null
@@ -0,0 +1,61 @@
+# Translation of wireshark debconf templates to Hungarian
+# Copyright (C) 2011 Balint Reczey <balint@balintreczey.hu>
+# This file is distributed under the same license as the wireshark package.
+#
+# Translators:
+# Balint Reczey <balint@balintreczey.hu>, 2011
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2011-05-09 13:31+0200\n"
+"Last-Translator: Balint Reczey <balint@balintreczey.hu>\n"
+"Language-Team: Hungarian <debian-l10n-hungarian@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr ""
+"A rendszergazdán kívül más felhasználók is képesek legyenek lehallgatni a"
+"hálózati forgalmat?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"A dumpcap segédprogramot úgy is be lehet állítani telepítéskor, hogy lehetővé"
+"tegye a \"wireshark\" rendszer-csoport tagjainak, hogy lehallgassák a"
+"hálózati forgalmat. Ez biztonságosabb, mint rendszergazdaként futtatni a"
+"Wireshark/Tshark programokat, mivel kevesebb kód fut így rendszergazdai"
+"jogokkal ellátva."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Részletesebb információk a usr/share/doc/wireshark-common/README.Debian"
+"fájlban találhatók."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Ennek a beállításnak az engedélyezése biztonsági kockázatot hordoz."
+"Ha bizonytalan vagy, inkább ne engedélyezd."
diff --git a/debian/po/id.po b/debian/po/id.po
new file mode 100644 (file)
index 0000000..7b8310e
--- /dev/null
@@ -0,0 +1,43 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.6.4-1\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2012-01-02 02:28+0700\n"
+"Last-Translator: Mahyuddin Susanto <udienz@ubuntu.com>\n"
+"Language-Team: Debian Indonesia Translator <debian-l10n-indonesian@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Poedit-Language: Indonesian\n"
+"X-Poedit-Country: INDONESIA\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Bolehkan pengguna non-superuser untuk menangkap paket?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Dumpcap can be installed in a way that allows members of the \"wireshark\" system group to capture packets. This is recommended over the alternative of running Wireshark/Tshark directly as root, because less of the code will run with elevated privileges."
+msgstr "Dumpcap dapat dipasang dengan cara memperbolehkan anggota dari grup system \"wireshark\" untuk menangkap paket. Hal ini dianjurkan sebagai alternatif untuk menjalankan Wireshark/Tshark sebagai root, karena sedikit kode yang berjalan dengan hak tertinggi"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "For more detailed information please see /usr/share/doc/wireshark-common/README.Debian."
+msgstr "Untuk informasi lebih lanjut silakan lihat /usr/share/doc/wireshark-common/README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Enabling this feature may be a security risk, so it is disabled by default. If in doubt, it is suggested to leave it disabled."
+msgstr "Mengaktifkan fitur ini akan menyebabkan resiko keamanan, jadi secara bawaan akan di non-aktifkan. Jika ragu, disarankan untuk dibiarkan dinonaktifkan"
+
diff --git a/debian/po/it.po b/debian/po/it.po
new file mode 100644 (file)
index 0000000..31d63fa
--- /dev/null
@@ -0,0 +1,57 @@
+# Italian translation of wireshark.
+# COPYRIGHT (C) 2009 THE WIRESHARK'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the wireshark package.
+# Luca Monducci <luca.mo@tiscali.it>, 2009-2010.
+# 
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark italian debconf templates\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-26 16:26+0200\n"
+"Last-Translator: Luca Monducci <luca.mo@tiscali.it>\n"
+"Language-Team: Italian <debian-l10n-italian@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Permettere ai non-superuser di catturare i pacchetti?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap può essere installato in modo da permettere agli utenti appartenenti "
+"al gruppo di sistema \"wireshark\" di catturare i pacchetti. Questa modalità "
+"d'uso di Wireshark/Tshark è raccomandata rispetto all'esecuzione diretta da "
+"root perché viene eseguito con privilegi elevati meno codice."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Per informazioni più dettagliate si consulti /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"L'attivazione di questa funzionalità potrebbe essere rischiosa per la "
+"sicurezza e quindi normalmente non è attiva. Nel dubbio, si suggerisce di "
+"lasciarla disattivata."
diff --git a/debian/po/ja.po b/debian/po/ja.po
new file mode 100644 (file)
index 0000000..eb547de
--- /dev/null
@@ -0,0 +1,56 @@
+# Japanese translation of wireshark debconf templates.
+# Copyright (C) 2009-2010 Hideki Yamane <henrich@debian.org>
+# This file is distributed under the same license as the wireshark package.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.1-3\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-07-25 14:19+0900\n"
+"Last-Translator: Hideki Yamane <henrich@debian.org>\n"
+"Language-Team: Japanese <debian-japanese@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "非特権ユーザ (root 以外のユーザ) がパケットをキャプチャできるようにしますか?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"「wireshark」システムグループのメンバーがパケットをキャプチャできる設定で "
+"dumpcap をインストールすることができます。直接 root ユーザとして動かす別の方法と比較"
+"すると、この方が高くなった権限上で動作するコードが少なくなるのでお勧めです。"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"より詳細な情報については /usr/share/doc/wireshark-common/README.Debian を"
+"参照してください。"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"この機能を有効にするのはセキュリティ上のリスクになる可能性があるので、デフォル"
+"トでは無効にされています。分からない場合は無効のままにしておくことをお勧めし"
+"ます。"
+
diff --git a/debian/po/ko.po b/debian/po/ko.po
new file mode 100644 (file)
index 0000000..6df8ba4
--- /dev/null
@@ -0,0 +1,44 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: OSCTP\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2011-06-11 12:29+0900\n"
+"Last-Translator: si-cheol KO <kosicheol@gmail.com>\n"
+"Language-Team: Korean <debian-l10n-korean@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Poedit-Language: Korean\n"
+"X-Poedit-Country: KOREA, REPUBLIC OF\n"
+"X-Poedit-SourceCharset: utf-8\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "일반사용자가 패킷을 캡처 할 수 있도록 하시겠습니까?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Dumpcap can be installed in a way that allows members of the \"wireshark\" system group to capture packets. This is recommended over the alternative of running Wireshark/Tshark directly as root, because less of the code will run with elevated privileges."
+msgstr "root로 직접 Wireshark/Tshark를 실행시키는 것의 대안으로 좀 더 적은 권한으로 패킷캡처를 하기위해 \"wireshark\" 시스템 그룹의 일원인 Dumpcap이 설치될 수 있습니다."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "For more detailed information please see /usr/share/doc/wireshark-common/README.Debian."
+msgstr "세부정보는 /usr/share/doc/wireshark-common/README.Debian파일을 참조하세요."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Enabling this feature may be a security risk, so it is disabled by default. If in doubt, it is suggested to leave it disabled."
+msgstr "활성화 하는 것은 보안상 위험할 수 있기 때문에 기본적으로 비활성화 되어 있습니다. 비활성화로 두는 것을 추천합니다."
+
diff --git a/debian/po/nl.po b/debian/po/nl.po
new file mode 100644 (file)
index 0000000..e0f4a22
--- /dev/null
@@ -0,0 +1,61 @@
+# Dutch translation of wireshark debconf templates.
+# Copyright (C) 2011 Jeroen Schot <schot@a-eskwadraat.nl>
+# This file is distributed under the same license as the wireshark package.
+#
+# Translators:
+# Jeroen Schot <schot@a-eskwadraat.nl>, 2011.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark_1.4.5-1\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2011-05-09 11:43+0200\n"
+"Last-Translator: Jeroen Schot <schot@a-eskwadraat.nl>\n"
+"Language-Team: Debian l10n Dutch <debian-l10n-dutch@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Language: nl\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr ""
+"Moet het voor niet-beheerders mogelijk zijn om pakketjes te onderscheppen?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap kan zodanig worden geïnstalleerd dat leden van de systeemgroep "
+"\"wireshark\" netwerkpakketjes mogen onderscheppen. Dit wordt aanbevolen "
+"boven het uitvoeren  van Wireshark/Tshark als beheerder, omdat op deze "
+"manier minder code met verhoogde privileges wordt uitgevoerd."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Uitgebreide informatie hierover is te vinden in /usr/share/doc/wireshark-"
+"common/README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Het activeren van deze functionaliteit is mogelijk een beveiligingsrisico, "
+"daarom staat dit niet standaard aan. Bij twijfel wordt u aangeraden om dit "
+"niet te activeren."
diff --git a/debian/po/pt.po b/debian/po/pt.po
new file mode 100644 (file)
index 0000000..a5ced84
--- /dev/null
@@ -0,0 +1,66 @@
+# Portuguese wireshark debconf translation
+# Copyright (C) 2009, the wireshark authors
+# This file is distributed under the same license as the wireshark package.
+# 2010, Pedro Ribeiro <p.m42.ribeiro@gmail.com>.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.1-3\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-26 11:23+0100\n"
+"Last-Translator: Pedro Ribeiro <p.m42.ribeiro@gmail.com>\n"
+"Language-Team: Portuguese <traduz@debianpt.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Devem os utilizadores regulares conseguir capturar pacotes?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"O dumpcap pode ser instalado de maneira que os membros do grupo de sistema "
+"\"wireshark\" possam capturar pacotes. Este é o modo recomendado em vez da "
+"alternativa de correr o Wireshark/Tshark directamente como root, porque "
+"menos código será executado com privilégios elevados."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Para informação mais detalhada, leia por favor /usr/share/doc/wireshark-"
+"common/README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Activar esta característica pode ser um risco de segurança, por isso vem "
+"desactivada por predefinição. Em caso de dúvida, sugere-se deixá-la "
+"desactivada."
+
+#~ msgid "Should dumpcap be installed \"setuid root\"?"
+#~ msgstr "O dumpcap deve ser instalado com \"setuid root\"?"
diff --git a/debian/po/pt_BR.po b/debian/po/pt_BR.po
new file mode 100644 (file)
index 0000000..128fa5b
--- /dev/null
@@ -0,0 +1,73 @@
+# wireshark Brazilian Portuguese translation.
+# Copyright (C) 2009 the wireshark's copyright holder
+# This file is distributed under the same license as the wireshark package.
+# Rafael Henrique da Silva Correia <rafaelhenriqu@gmail.com>, 2009.
+# Adriano Rafael Gomes <adrianorg@gmail.com>, 2010.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.10-2\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-08-24 22:57-0300\n"
+"Last-Translator: Adriano Rafael Gomes <adrianorg@gmail.com>\n"
+"Language-Team: Brazilian Portuguese <debian-l10n-portuguese@lists.debian."
+"org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"pt_BR utf-8\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Não-superusuários deverão ser capazes de capturar pacotes?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of "
+#| "group wireshark will be able to run it with the permissions of the  "
+#| "'root' user. It is the preferred way of capturing packets using  "
+#| "Wireshark/Tshark over running Wireshark/Tshark as root, because that  way "
+#| "most of the code will run with less priveges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"O dumpcap pode ser instalado em um modo que permite a membros do grupo de "
+"sistema \"wireshark\" capturar pacotes. Isto é recomendado em vez da "
+"alternativa de executar o Wireshark/Tshark diretamente como root, porque "
+"menos código será executado com privilégios elevados."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Para informações mais detalhadas, por favor veja /usr/share/doc/"
+"wireshark-common/README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Enabling this feature may be a security risk, so it is disabled by "
+#| "default.  If in doubt, it is suggested to leave it disabled."
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Habilitar este recurso pode ser um risco de segurança, portanto ele é "
+"desabilitado por padrão. Se estiver em dúvida, é sugerido deixá-lo "
+"desabilitado."
+
+#~ msgid "Do you want dumpcap to be installed setuid root?"
+#~ msgstr ""
+#~ "Você quer que o comando \"dumpcap\" seja instalado com \"setuid\" root?"
diff --git a/debian/po/ru.po b/debian/po/ru.po
new file mode 100644 (file)
index 0000000..6990fc2
--- /dev/null
@@ -0,0 +1,66 @@
+# translation of ru.po to Russian
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+#
+# Yuri Kozlov <yuray@komyakino.ru>, 2009, 2010.
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.9-1\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-20 22:04+0400\n"
+"Last-Translator: Yuri Kozlov <yuray@komyakino.ru>\n"
+"Language-Team: Russian <debian-l10n-russian@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.11.4\n"
+"Plural-Forms:  nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Позволить не суперпользователям захватывать пакеты?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap можно установить таким образом, что члены "
+"группы wireshark смогут захватывать пакеты Это более "
+"рекомендуемый способ захвата пакетов с помощью Wireshark/Tshark, "
+"чем запуск самого Wireshark/Tshark с правами root, так как это позволяет "
+"выполнять почти весь код с меньшими правами."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Дополнительную информацию можно найти в файле "
+"/usr/share/doc/wireshark-common/README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Использование данной возможности влияет на безопасность, поэтому по "
+"умолчанию не используется. Если сомневаетесь, то оставьте выключенной."
+
diff --git a/debian/po/sk.po b/debian/po/sk.po
new file mode 100644 (file)
index 0000000..d432e4a
--- /dev/null
@@ -0,0 +1,60 @@
+# Slovak translations for wireshark package
+# Slovenské preklady pre balík wireshark.
+# Copyright (C) 2011 THE wireshark'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the wireshark package.
+# Automatically generated, 2011.
+# Slavko <linux@slavino.sk>, 2011.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.6.2-1\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2011-10-30 09:56+0100\n"
+"Last-Translator: Slavko <linux@slavino.sk>\n"
+"Language-Team: slovenčina <debian-l10n-slovak@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Language: sk\n"
+"Plural-Forms: nplurals=3; plural=(n==1) ? 0 : (n>=2 && n<=4) ? 1 : 2;\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Môžu bežní používatelia zachytávať pakety?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap možno nainštalovať spôsobom, ktorý dovolí zachytávať pakety členom "
+"systémovej skupiny „wireshark”. Toto je odporúčané oproti alternatívnemu "
+"spúšťaniu Wireshark/Tshark priamo s právami root, pretože bude menej kódu "
+"bežať s neobmedzenými právami."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+"Ďalšie, podrobnejšie informácie nájdete v /usr/share/doc/wireshark-common/"
+"README.Debian."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Zapnutie tejto vlastnosti môže byť bezpečnostným rizikom, aj preto je "
+"predvolene vypnutá. Ak si nie ste istý, odporúčame ponechať ju vypnutú."
diff --git a/debian/po/sv.po b/debian/po/sv.po
new file mode 100644 (file)
index 0000000..5ae5eea
--- /dev/null
@@ -0,0 +1,63 @@
+# translation of wireshark_sv.po to Swedish
+# Copyright (C) 2009
+# This file is distributed under the same license as the wireshark package.
+#
+# Martin Ågren <martin.agren@gmail.com>, 2009, 2010.
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark_sv\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-06-20 17:19+0200\n"
+"Last-Translator: Martin Ågren <martin.agren@gmail.com>\n"
+"Language-Team: Swedish <debian-l10n-swedish@lists.debian.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.11.4\n"
+"Plural-Forms:  nplurals=2; plural=(n != 1);\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Ska icke-superanvändare kunna fånga paket?"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap kan installeras på ett sätt som tillåter medlemmar i "
+"systemgruppen \"wireshark\" att fånga paket. Detta rekommenderas framför alternativet, att köra Wireshark/Tshark direkt som root, eftersom en mindre del av koden "
+"kommer köras med utökade rättigheter."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr "Se /usr/share/doc/wireshark-common/README.Debian för mer detaljerad information."
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Att aktivera denna funktion kan vara en säkerhetsrisk, så den är "
+"avaktiverad som standard. Vid tvivel rekommenderas att den lämnas "
+"avaktiverad."
+
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
new file mode 100644 (file)
index 0000000..620f710
--- /dev/null
@@ -0,0 +1,49 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: PACKAGE VERSION\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid "Should non-superusers be able to capture packets?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../templates:2001
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
diff --git a/debian/po/vi.po b/debian/po/vi.po
new file mode 100644 (file)
index 0000000..45e4aeb
--- /dev/null
@@ -0,0 +1,58 @@
+# Vietnamese translation for Wire Shark.
+# Copyright © 2010 Free Software Foundation, Inc.
+# Clytie Siddall <clytie@riverland.net.au>, 2009-2010.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: wireshark 1.2.10-2\n"
+"Report-Msgid-Bugs-To: wireshark@packages.debian.org\n"
+"POT-Creation-Date: 2010-06-20 16:35+0200\n"
+"PO-Revision-Date: 2010-09-29 22:11+0930\n"
+"Last-Translator: Clytie Siddall <clytie@riverland.net.au>\n"
+"Language-Team: Vietnamese <vi-VN@googlegroups.com>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=1; plural=0;\n"
+"X-Generator: LocFactoryEditor 1.8\n"
+
+#: ../templates:2001
+#. Type: boolean
+#. Description
+msgid "Should non-superusers be able to capture packets?"
+msgstr "Người dùng không phải siêu người dùng nên có quyền bắt gói tin không?"
+
+#: ../templates:2001
+#. Type: boolean
+#. Description
+#| msgid ""
+#| "Dumpcap can be installed with the set-user-id bit set, so members of the "
+#| "\"wireshark\" system group will have the privileges required to use it. "
+#| "This way of capturing packets using Wireshark/Tshark is recommended over "
+#| "the alternative of running them directly as superuser, because less of "
+#| "the code will run with elevated privileges."
+msgid ""
+"Dumpcap can be installed in a way that allows members of the \"wireshark\" "
+"system group to capture packets. This is recommended over the alternative of "
+"running Wireshark/Tshark directly as root, because less of the code will run "
+"with elevated privileges."
+msgstr ""
+"Dumpcap có thể được cài đặt bằng một cách cấp cho các thành viên của nhóm « wireshark » có quyền bắt gói tin. Thiết lập này khuyến khích, so với chạy Wireshark/Tshark trực tiếp dưới người chủ, vì ít mã nguồn hơn sẽ chạy với quyền truy cập cao."
+
+#: ../templates:2001
+#. Type: boolean
+#. Description
+msgid ""
+"For more detailed information please see /usr/share/doc/wireshark-common/"
+"README.Debian."
+msgstr "Để tìm chi tiết, xem tài liệu Đọc Đi « /usr/share/doc/wireshark-common/README.Debian »."
+
+#: ../templates:2001
+#. Type: boolean
+#. Description
+msgid ""
+"Enabling this feature may be a security risk, so it is disabled by default. "
+"If in doubt, it is suggested to leave it disabled."
+msgstr ""
+"Bật tính năng này có thể rủi ro bảo mật thì nó bị tắt theo mặc định. Chưa "
+"chắc nên để lại bị tắt."
index 4869053..5ac8f75 100755 (executable)
 #!/usr/bin/make -f
-# Made with the aid of dh_make, by Craig Small
+# MAde with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Cristoph Lameter.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
-include /usr/share/dpatch/dpatch.make
 DB2MAN=/usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl
 
 
-DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-PYTHON_VERSION=python2.4
-
-CFLAGS=-g -O2
+DEB_HOST_ARCH_CPU       ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_BUILD_ARCH_CPU      ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
 
 # Enable IEEE-conformant floating point math on alphas (not the default)
-ifeq (alpha-linux,$(DEB_HOST_GNU_TYPE))
+ifeq (alpha,$(DEB_HOST_ARCH_CPU))
   CFLAGS += -mieee
 endif
 
-CONFIGURE_FLAGS=--prefix=/usr --sysconfdir=/usr/share --datadir=/usr/share --libdir=/usr/lib/wireshark --disable-static --enable-warnings-as-errors=no --enable-setuid-install --with-plugins=/usr/lib/wireshark/plugins --with-lua=/usr/
+idl2deb.1: idl2deb.dbk
+       xsltproc --nonet --novalid $(DB2MAN) $<
+
+asn2deb.1: asn2deb.dbk
+       xsltproc --nonet --novalid $(DB2MAN) $<
+
+
+CONFIGURE_FLAGS=--prefix=/usr --sysconfdir=/usr/share --datadir=/usr/share --disable-static --libdir=/usr/lib --enable-warnings-as-errors=no --with-plugins=/usr/lib/wireshark/libwireshark2/plugins --with-lua=/usr/ --docdir=/usr/share/doc/wireshark-doc/
 
 configure: configure-stamp
-configure-stamp: patch
+configure-stamp:
        dh_testdir
 
-       cp /usr/share/misc/config.guess /usr/share/misc/config.sub .
+       # use release version only
+       echo "" > svnversion.h
+
        libtoolize --force --copy
        -mkdir aclocal-missing
        ./autogen.sh
-       CFLAGS="$(CFLAGS)" ./configure $(CONFIGURE_FLAGS)
+       ./configure $(CONFIGURE_FLAGS)
 
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp idl2deb.1 asn2deb.1
 build-stamp: configure-stamp
        $(MAKE)
+       $(MAKE) -C docbook wsug_html_chunked wsdg_html_chunked
+       $(MAKE) -C doc idl2wrs.1 idl2wrs.html
 
        touch build-stamp
 
-patch: patch-stamp
-patch-stamp:
-       dpatch apply-all
-
-
-clean: unpatch-stamp
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       [ ! -f Makefile ] || $(MAKE) distclean
-       rm -f rdps wireshark.1 tshark.1 wireshark-filter.4
+       [ ! -f Makefile ] || $(MAKE) distclean 
+       rm -f rdps wireshark.1 tshark.1 idl2deb.1 wireshark-filter.4 asn2deb.1 dumpcap.1 rawshark.1
        rm -f conftest conftest.c
        rm -f config.guess config.sub config.log
        rm -f config.h.in config.h configure
 
        dh_clean
 
-unpatch: unpatch-stamp
-unpatch-stamp:
-       dpatch deapply-all
-       rm -rf patch-stamp debian/patched
-
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        # Add here commands to install the files into debian/tmp
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+       rm -rf $(CURDIR)/debian/tmp/usr/share/wireshark/COPYING
+       cp debian/license-text-about-dialog $(CURDIR)/debian/tmp/usr/share/wireshark/ABOUT.GPL
        mkdir -p $(CURDIR)/debian/tmp/usr/share/applications/
-       cp debian/wireshark.desktop $(CURDIR)/debian/tmp/usr/share/applications/
+       cp wireshark.desktop $(CURDIR)/debian/tmp/usr/share/applications/
        cp tools/idl2wrs $(CURDIR)/debian/tmp/usr/bin/
-       #cp debian/wireshark-root.desktop $(CURDIR)/debian/tmp/usr/share/applications/
+       # icon for menu system
        mkdir -p $(CURDIR)/debian/tmp/usr/share/pixmaps/
-       cp image/hi48-app-wireshark.png $(CURDIR)/debian/tmp/usr/share/pixmaps/
-       cp image/wsicon32.xpm $(CURDIR)/debian/tmp/usr/share/pixmaps/
+       install -m 644 image/wsicon32.xpm $(CURDIR)/debian/tmp/usr/share/pixmaps/
+       # icons conforming to freedesktop.org standards
+       mkdir -p $(CURDIR)/debian/tmp/usr/share/icons/hicolor/scalable/apps/
+       install -m 644 image/wsicon.svg $(CURDIR)/debian/tmp/usr/share/icons/hicolor/scalable/apps/wireshark.svg
+       mkdir -p $(CURDIR)/debian/tmp/usr/share/icons/hicolor/48x48/apps/
+       install -m 644 image/wsicon48.png $(CURDIR)/debian/tmp/usr/share/icons/hicolor/48x48/apps/wireshark.png
+       mkdir -p $(CURDIR)/debian/tmp/usr/share/pyshared
+       install -m 755 $(CURDIR)/idl2deb $(CURDIR)/debian/tmp/usr/bin/
+       install -m 755 $(CURDIR)/asn2deb $(CURDIR)/debian/tmp/usr/bin/
+       install -m 755 $(CURDIR)/tools/idl2wrs $(CURDIR)/debian/tmp/usr/bin/
        mkdir -p $(CURDIR)/debian/tmp/etc/wireshark/
        mv $(CURDIR)/debian/tmp/usr/share/wireshark/init.lua \
                $(CURDIR)/debian/tmp/etc/wireshark/
        ln -s /etc/wireshark/init.lua \
                $(CURDIR)/debian/tmp/usr/share/wireshark/init.lua
-       mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
-       cp $(CURDIR)/tools/wireshark_be.py $(CURDIR)/tools/wireshark_gen.py \
-                       $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
+       install -m 644 $(CURDIR)/tools/wireshark_be.py $(CURDIR)/tools/wireshark_gen.py \
+               $(CURDIR)/debian/tmp/usr/share/pyshared
+       install -m 755 $(CURDIR)/tools/asn2wrs.py $(CURDIR)/debian/tmp/usr/share/pyshared
        mkdir -p $(CURDIR)/debian/tmp/usr/include/wireshark/
-       for F in `cat debian/wireshark-dev.header-files`; do \
+       for F in `cat debian/libwireshark-dev.header-files debian/libwsutil-dev.header-files debian/libwiretap-dev.header-files`; do \
                cp --parents $$F $(CURDIR)/debian/tmp/usr/include/wireshark; \
        done
+       # .a is no longer built; why was is used ?
+       #cp $(CURDIR)/wiretap/libwiretap.a $(CURDIR)/debian/tmp/usr/lib/
        -rm -rf $(CURDIR)/debian/tmp/usr/man
        dh_installman
-       cp doc/idl2wrs.1 $(CURDIR)/debian/tmp/usr/man
+       dh_lintian
 
        dh_movefiles
-       dh_pysupport
+       dh_python2
        dh_installdocs
        dh_installmenu
-       dh_installchangelogs NEWS
+       dh_installchangelogs
 
 # Build architecture-independent files here.
 binary-indep: install
-# We have nothing to do by default.
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdebconf -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 check: install
        # check all necessary headers are included
-       gcc -c debian/headers-check.c `pkg-config --cflags glib-2.0` -Idebian/wireshark-dev/usr/include/ -Idebian/wireshark-dev/usr/include/wireshark/ -o /dev/null
+       gcc -c debian/headers-check.c `pkg-config --cflags glib-2.0` -Idebian/libwireshark-dev/usr/include -Idebian/libwireshark-dev/usr/include/wireshark -Idebian/libwiretap-dev/usr/include/wireshark -o /dev/null
 
 # Build architecture-dependent files here.
 binary-arch: install check
-       dh_strip
-       dh_compress
-       dh_fixperms -Xdumpcap
-
-       dh_installdeb
-       LD_LIBRARY_PATH=/usr/lib/wireshark/:/usr/lib/libfakeroot/ dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_strip --dbg-package=wireshark-dbg
+       dh_compress -a
+       dh_fixperms -a
+       dh_makeshlibs
+       rm -f debian/wireshark-common.shlibs
+       dh_installdebconf -a
+       dh_installdeb -a
+       dh_shlibdeps
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
-.PHONY: build clean install check binary-indep binary-arch binary
+.PHONY: build clean install check binary-indep binary-arch binary build-arch build-indep
diff --git a/debian/source/format b/debian/source/format
new file mode 100644 (file)
index 0000000..163aaf8
--- /dev/null
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/templates b/debian/templates
new file mode 100644 (file)
index 0000000..5cbc112
--- /dev/null
@@ -0,0 +1,23 @@
+# These templates have been reviewed by the debian-l10n-english
+# team
+#
+# If modifications/additions/rewording are needed, please ask
+# debian-l10n-english@lists.debian.org for advice.
+#
+# Even minor modifications require translation updates and such
+# changes should be coordinated with translators and reviewers.
+
+Template: wireshark-common/install-setuid
+Type: boolean
+Default: false
+_Description: Should non-superusers be able to capture packets?
+ Dumpcap can be installed in a way that allows members of the "wireshark"
+ system group to capture packets. This is recommended over the
+ alternative of running Wireshark/Tshark directly as root, because
+ less of the code will run with elevated privileges.
+ .
+ For more detailed information please see
+ /usr/share/doc/wireshark-common/README.Debian.
+ .
+ Enabling this feature may be a security risk, so it is disabled by
+ default. If in doubt, it is suggested to leave it disabled.
diff --git a/debian/tshark.docs b/debian/tshark.docs
new file mode 100644 (file)
index 0000000..e174728
--- /dev/null
@@ -0,0 +1 @@
+debian/README.Debian
index 797904f..150695d 100644 (file)
@@ -1,2 +1,2 @@
 version=3
-http://www.wireshark.org/download/src/all-versions/wireshark-(.*)\.tar\.gz
+http://www.wireshark.org/download/src/all-versions/wireshark-([0-9]+\.[0-9]*[24680]\.[0-9]+)\.tar\.bz2
diff --git a/debian/wireshark-common.config b/debian/wireshark-common.config
new file mode 100644 (file)
index 0000000..c851405
--- /dev/null
@@ -0,0 +1,10 @@
+#! /bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+db_input medium wireshark-common/install-setuid || true
+db_go
+
+exit 0
index 6f92ee8..91616ec 100644 (file)
@@ -1,15 +1,6 @@
 /usr/bin/dumpcap
+/usr/bin/rawshark
 /usr/bin/capinfos
 /usr/bin/editcap
 /usr/bin/mergecap
 /usr/bin/text2pcap
-/usr/bin/rawshark
-/usr/lib/wireshark/libwireshark.so.2
-/usr/lib/wireshark/libwireshark.so.2.0.2
-/usr/lib/wireshark/libwiretap.so.2
-/usr/lib/wireshark/libwiretap.so.2.0.2
-/usr/lib/wireshark/libwsutil.so.2
-/usr/lib/wireshark/libwsutil.so.2.0.0
-/usr/lib/wireshark/plugins/*
-/usr/share/wireshark/*
-/etc/wireshark/init.lua
diff --git a/debian/wireshark-common.lintian-overrides b/debian/wireshark-common.lintian-overrides
new file mode 100644 (file)
index 0000000..2a8d98d
--- /dev/null
@@ -0,0 +1 @@
+wireshark-common binary: hardening-no-stackprotector usr/bin/mergecap
index 946309c..89f5f96 100644 (file)
@@ -1,7 +1,7 @@
-doc/dumpcap.1
 doc/editcap.1
 doc/mergecap.1
 doc/text2pcap.1
 doc/wireshark-filter.4
 doc/capinfos.1
+doc/dumpcap.1
 doc/rawshark.1
diff --git a/debian/wireshark-common.postinst b/debian/wireshark-common.postinst
new file mode 100644 (file)
index 0000000..1273790
--- /dev/null
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+PROGRAM=/usr/bin/dumpcap
+GROUP=wireshark
+
+if ! dpkg-statoverride --list $PROGRAM > /dev/null; then
+    db_get wireshark-common/install-setuid
+    if [ -e "$PROGRAM" ]; then
+       if [ "$RET" = "false" ] ; then
+           chown root:root $PROGRAM
+           chmod u=rwx,go=rx $PROGRAM
+       else
+           addgroup --quiet --system $GROUP
+           chown root:$GROUP $PROGRAM
+           if which setcap > /dev/null ; then
+                chmod u=rwx,g=rx,o=r $PROGRAM
+                if ! setcap cap_net_raw,cap_net_admin=eip $PROGRAM; then
+                   echo "Setting capabilities for dumpcap using Linux Capabilities failed."
+                   echo "Falling back to setting set-user-id bit."
+                   chmod u=rwxs,g=rx,o=r $PROGRAM
+                fi
+           else
+                chmod u=rwxs,g=rx,o=r $PROGRAM
+           fi
+        fi
+    fi
+else
+    echo "Preserving owner and mode for $PROGRAM set by dpkg-statoverride:"
+    dpkg-statoverride --list $PROGRAM
+fi
+
+#DEBHELPER#
diff --git a/debian/wireshark-common.postrm b/debian/wireshark-common.postrm
new file mode 100644 (file)
index 0000000..2ea52f7
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+set -e
+
+GROUP=wireshark
+
+if [ "$1" = "purge" ] ; then
+      if getent group $GROUP >/dev/null; then
+                if [ -x /usr/sbin/delgroup ]; then
+                        echo "Removing wireshark group..."
+                        delgroup --system $GROUP || echo "Could not remove wireshark group."
+                fi
+        fi
+fi
+
+#DEBHELPER#
index 58947a0..223c20b 100644 (file)
@@ -1,14 +1,5 @@
-doc/README.binarytrees
-doc/README.capture
 doc/README.design
 doc/README.developer
-doc/README.display_filter
 doc/README.idl2wrs
-doc/README.malloc
-doc/README.packaging
 doc/README.plugins
-doc/README.regression
-doc/README.request_response_tracking
-doc/README.stats_tree
-doc/README.tapping
 doc/README.xml-output
index c70c05e..88b32c1 100644 (file)
@@ -1,7 +1,4 @@
 /usr/bin/idl2wrs
-/usr/lib/wireshark/libwireshark.so
-/usr/lib/wireshark/libwireshark.la
-/usr/lib/wireshark/libwiretap.so
-/usr/lib/wireshark/libwiretap.la
-/usr/lib/python2.3/*
-/usr/include/wireshark/*
+/usr/bin/idl2deb
+/usr/bin/asn2deb
+/usr/share/pyshared/*
index 25b2ec4..f760c13 100644 (file)
@@ -1 +1,3 @@
 doc/idl2wrs.1
+idl2deb.1
+asn2deb.1
index 5a07967..8614658 100644 (file)
@@ -1,10 +1,12 @@
-#! /bin/bash -e
+#! /bin/bash
 #
 # Debian prerm script for Python x.y hierarchical modules
 # Written by Gregor Hoffleit <flight@debian.org>
 # Extended by Matthias Klose <doko@debian.org>
 #
 
+set -e
+
 PACKAGE=`basename $0 | sed -e 's/\.[^.]*$//'`
 
 dpkg --listfiles $PACKAGE |
diff --git a/debian/wireshark-doc.docs b/debian/wireshark-doc.docs
new file mode 100644 (file)
index 0000000..34e1d4e
--- /dev/null
@@ -0,0 +1,2 @@
+docbook/wsdg_html_chunked
+docbook/wsug_html_chunked
diff --git a/debian/wireshark.docs b/debian/wireshark.docs
new file mode 100644 (file)
index 0000000..e174728
--- /dev/null
@@ -0,0 +1 @@
+debian/README.Debian
index 475aa84..7c39051 100644 (file)
@@ -1,3 +1,4 @@
 /usr/bin/wireshark
 /usr/share/applications/
 /usr/share/pixmaps/
+/usr/share/icons/