Imported Upstream version 2.0.1+dfsg
[packages/binwalk.git] / src / magic / bootloaders
1
2 #---------------------------Bootloaders--------------------------------
3
4 # CFE bootloader
5 0       string  CFE1CFE1        CFE boot loader
6 >40     string  CFE1CFE1        invalid
7
8 # U-Boot boot loader
9 0       string  U-Boot\x20  U-Boot version string,
10 >7  byte    <48         invalid,
11 >7  byte    >57         invalid,
12 >8  byte    !0x2E       invalid,
13 >0  string  x           "%s"